Themes description cannot be saved or edited.

RESOLVED FIXED in 2013-04-25

Status

RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: vcarciu, Assigned: kngo)

Tracking

({regression})

unspecified
2013-04-25
x86_64
Windows 7
regression

Details

(URL)

(Reporter)

Description

5 years ago
Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

Steps to reproduce:
1. Log in to AMO-dev
2. Go to Dev-hub and login a new theme with a description
3. Submit the theme and go to edit listing 

Expected result:
Theme description is saved and it can be edited from edit listing

Actual results:
Description is not saved and user is not able to properly edit the description

Please see screencast for this bug : http://screencast.com/t/5gP348fuJWTP

NOTES:
Reproducible also in production
Blocks: 741826
When did this start happening?
(Assignee)

Updated

5 years ago
Assignee: nobody → ngoke
(Assignee)

Comment 2

5 years ago
They have been getting saved, just not shown.

https://github.com/mozilla/zamboni/commit/323fc837462b10f6d08ac18768edd4ee24558e1a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

5 years ago
Description is still not displayed in Edit Listing page. Also, after saving a new description, the old description is still seen in View Listing page : http://screencast.com/t/WAOJ7hJy
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

5 years ago
https://github.com/mozilla/zamboni/commit/2c924bb3685e6b617924ecf9f834f05bb638cc1c
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

5 years ago
This is still intermittently reproducible . I think that this is a cache issue because after some page reloads the changes are visible.

We need a solution to display all fields immediately after theme submission , else everything will be confusing for themes developers.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla/zamboni/commit/044347fff9b3c7ec98db639ac6333f1e189a48e9
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.