If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[KeyBoard] When cursor is changed from one text field to another alternate layout text field,homescreen appears and disappears for a moment.

RESOLVED FIXED in 1.1 QE5

Status

Firefox OS
Gaia::Keyboard
P1
major
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Leo, Unassigned)

Tracking

unspecified
1.1 QE5
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18+ verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1. Title :When cursor is changed from one text field to another alternate layout text field,homescreen appears and disappears for a moment.
2. Precondition : Settings >> Keyboard >> Select Word Suggestion 
3. Action : Calendar >> Add account >> click username >> click password 
            Contact >> Add contact >> click Name >> click Email                     
4. Detailed Symptom (ENG.) : On changing from one input field to another alternate layout field,part of home screen appears in place of word suggestion bar and then disappear. 
5. GAIA version : D30007d
6. Expected : Word suggestion bar should disappear without any appearance of home screen.
7.Reproducibility: Y
1)Frequency Rate : 100%
(Reporter)

Updated

5 years ago
Flags: needinfo?(rlu)
Created attachment 746898 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9620/files

Pointer to Github pull-request
Flags: needinfo?(rlu)
Comment on attachment 746898 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9620/files

Update a patch after an off-line discussion.
Hope this can get it to work.

Hi Tim,

Could you help review this one?
Attachment #746898 - Flags: review?(timdream)
Comment on attachment 746898 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9620/files

Thanks!
Attachment #746898 - Flags: review?(timdream) → review+
Merged to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/336ee89cc64741074bf86ef31b1590a195d459f4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → affected
status-b2g18-v1.0.1: --- → affected
Resolution: --- → FIXED
Blocks: 867175
(Reporter)

Updated

4 years ago
tracking-b2g18: --- → +
(Reporter)

Comment 5

4 years ago
This issue is still reproducing.
Please check.
To reproduce the issue
Precondition : Word Suggestion ON
Action : Message >> New Message >> Input text >>Switch to "To:" field
OR
Browser >> Bookmark Entry >> Bookamark title >> Switch to Address (URL)
This issue still reproduces.
Flags: needinfo?(rlu)
STR for Gaia master that still can reproduce this issue,
========

open a website
Bookmark it >> Then Edit Bookmark >>
Word suggestion should be On
Switch from "Page Title" textfield to "address" textfield

I will try the steps later.
Thanks for the heads-up.
Flags: needinfo?(rlu)
(Reporter)

Updated

4 years ago
blocking-b2g: --- → leo+
(Reporter)

Updated

4 years ago
Priority: -- → P1
Target Milestone: --- → 1.1 QE5
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 336ee89cc64741074bf86ef31b1590a195d459f4
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(nobody)
(Reporter)

Comment 8

4 years ago
Rudy, do we have to reopen this to track the new issue or need to have a separate bug for tracking this?
Flags: needinfo?(rlu)
(Reporter)

Comment 9

4 years ago
Created attachment 772555 [details] [diff] [review]
Patch for Word Suggestion Bar Hides and No Home screen appears

Hi Rudy,
Please review the attached patch for this issue.
The previous patch does not work when I checked in browser.
This patch fixes for anywhere where word suggestion bar is not 
required and it hides.

Thank you
Attachment #772555 - Flags: review?(rlu)
Comment on attachment 772555 [details] [diff] [review]
Patch for Word Suggestion Bar Hides and No Home screen appears

Review of attachment 772555 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry that I don't think this could work.
Right now, the logic for the delay is wrong (see the comment below) and if I corrected it, the patch could not fix the issue.

BTW, because this bug has been marked as resolved, please help create another bug and nominate it as leo+.

::: apps/keyboard/js/keyboard.js
@@ +855,4 @@
>  function updateTargetWindowHeight(hide) {
>    if (IMERender.ime.dataset.hidden || hide) {
>      document.location.hash = 'hide';
> +  } else if (needsCandidatePanel() && candidatePanelEnabled) {

it should be !needsCandidatePanel() here.
Attachment #772555 - Flags: review?(rlu) → review-
Follow up bug @ Bug 891798
(In reply to Wayne Chang [:wchang] from comment #11)
> Follow up bug @ Bug 891798

Does this mean that we can close this bug on branches?
I think so.
Bug 891798 has bee fixed in both master and v1-train.
Flags: needinfo?(rlu)
Flags: needinfo?(nobody)
status-b2g18: affected → fixed
status-b2g18-v1.0.0: affected → wontfix
status-b2g18-v1.0.1: affected → wontfix

Comment 14

4 years ago
Verified Fixed on Latest Leo COM RIL. No part of the home screen appears in place of the word suggestion bar.


Environmental Variables
Build ID: 20130815041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/692d3414bb12
Gaia: 0f1f1ab0ab31a1df8a780baa048b5e7b2854205d
Platform Version: 18.1
RIL Version: 01.01.00.019.190
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified

Updated

4 years ago
Status: VERIFIED → RESOLVED
Last Resolved: 4 years ago4 years ago
You need to log in before you can comment on or make changes to this bug.