Closed Bug 863869 Opened 7 years ago Closed 4 years ago

(Australis) Modernize Windows control buttons

Categories

(Firefox :: Theme, enhancement)

All
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ge3k0s, Unassigned)

References

(Depends on 1 open bug, )

Details

(Whiteboard: [Australis:P-][Australis:M-])

Attachments

(1 file)

On Windows (especially XP) window's control buttons (minimize, restore, maximize) should be modernized according to the specs : https://wiki.mozilla.org/images/0/0c/Australis-i02-Tabs.jpg There is also a special spec for Win 8 (http://cl.ly/image/3a2i0c1o1D2J/o )
Summary: (Australis) Modernize window's control buttons → (Australis) Modernize Windows control buttons
Duplicate of this bug: 625310
Just a few questions (hope you don't mind) :
  What are "modern control buttons" and how are they better from the default ones?
  What is the benefits/work to do ratio?
  Is it worth breaking OS consistency for the sake of "modernization"?
  OSX and Linux don't seem to have mockups/bugs for changing the control buttons.
  Do you consider them modern or is it just not possible to change them?
(not criticizing here, just wondering)
(In reply to annaeus from comment #2)
> Just a few questions (hope you don't mind) :
>   What are "modern control buttons" and how are they better from the default
> ones?

See mockup in URL. They bring consistency between different Windows versions and IMO they look better than default ones (they are especially nicer on XP). They are more consistent with the fogged tabstrip on Vista/7 and they look more like ModernUI on Win 8.

>   What is the benefits/work to do ratio?

Consistency and visual improvement. I'm no dev so hard for me to weigh the work ratio.

>   Is it worth breaking OS consistency for the sake of "modernization"?

This is only Windows related and bring consistency between versions (XP to Win8).

>   OSX and Linux don't seem to have mockups/bugs for changing the control
> buttons.

This is only Windows-related.

>   Do you consider them modern or is it just not possible to change them?
> (not criticizing here, just wondering)

I choose the term "Modern" myself, but it is maybe not the right one. It's part of Australis specs and it's a project for a long time (see bug 625310 )

All answers written above are my opinions. I hope I've answered most of your interrogations.
They do look better. Modern is probably the right term, especially when talking about WinXP. The big chubby XP buttons do have this old and outdated feeling to them.

Thanks for the very quick reply. I like to have some insight behind this kind of changes.
(In reply to annaeus from comment #2)
>   What is the benefits/work to do ratio?

Benefits are what Guillaume listed. However, as for the work part of this, it really shouldn't be terribly difficult. I don't do Windows development, but if it is even sort of similar to customizing window controls on OS X, the work should not take to long at all. The hard part really is finding someone who knows how to do this, but around here that shouldn't take an extended amount of time.

Actually what's the most challenging here work-wise is the design, but as you can see from the mockup, that part is pretty much done.

Hope that helps.
No longer blocks: australis-tabs-win
I think the mockup is open to interpretations (unless it was already explicitly clarified by the designer of the mockup).

IMO, it could be interpreted as "Here's how it should look on Windows 7: the windows controls are native, the tabs/buttons should look like this".

Was it explicitly stated that the XP/Win8 designs should be identical to that mockup, rather than use native controls?

If this question wasn't answered already, I think that native windows controls are better for all the known reasons. Afteral, it's not a full skin which doesn't resemble anything: it DOES use the windows 7 native window controls.
Need info Shorlander about comment 6.
Flags: needinfo?(shorlander)
(In reply to Avi Halachmi (:avih) from comment #6)
> I think the mockup is open to interpretations (unless it was already
> explicitly clarified by the designer of the mockup).
> 
> IMO, it could be interpreted as "Here's how it should look on Windows 7: the
> windows controls are native, the tabs/buttons should look like this".
> 
> Was it explicitly stated that the XP/Win8 designs should be identical to
> that mockup, rather than use native controls?
> 
> If this question wasn't answered already, I think that native windows
> controls are better for all the known reasons. Afteral, it's not a full skin
> which doesn't resemble anything: it DOES use the windows 7 native window
> controls.

AFAICT from bug 590945, inspecting chrome, and my discussion with Stephen on IRC, the buttons are already non-native, and we can use the images from the mockups to implement the redesign. Does that answer your questions?
(In reply to :Gijs Kruitbosch from comment #8)
> AFAICT from bug 590945, inspecting chrome, and my discussion with Stephen on
> IRC, the buttons are already non-native, and we can use the images from the
> mockups to implement the redesign. Does that answer your questions?

I didn't read all the posts at that bug, and your interpretation is definitely valid IMO. However, I still think that the designer of that mockup (or anyone which knows the answer for a fact) is the ultimate authority here.

I don't think that any interpretation is better than the others, but when it's not so hard to get an authoritative answer, I think that should be our first goal.
(In reply to Richard Marti [:Paenglab] from comment #9)
> AFAIK on Aero Glass the buttons are natively drawn. See:
> http://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/browser-
> aero.css#122

I stand corrected. Which might make realizing this design... interesting.
Blocks: australis
I'm looking at the latest Mozilla UX quarterly, pages 8-9 (http://bit.ly/moz-Q2-2013 and relevant page attached), and it's quite clear from it that the windows controls should be native. I know that's not our reference mockup, but from that, together with the windows 7 mockup (which is native or close enough), I'd say native is what we're after.

But still, an authoritative reply would be better.
(In reply to Avi Halachmi (:avih) from comment #12)
> Created attachment 749177 [details]
> Page from UX quarterly 2013-02
> 
> I'm looking at the latest Mozilla UX quarterly, pages 8-9
> (http://bit.ly/moz-Q2-2013 and relevant page attached), and it's quite clear
> from it that the windows controls should be native. I know that's not our
> reference mockup, but from that, together with the windows 7 mockup (which
> is native or close enough), I'd say native is what we're after.
> 
> But still, an authoritative reply would be better.

Yeah the controls on these mockups are native on Linux and OSX (never said that it should be otherwise), but clearly not on Win 8. The change is to be done for XP (as said before planned for a long time bug 625310), Vista/7 (small changes : more fog and covering the window to the far right) and Win 8.

Waiting on Shorlander's answer though.
Whiteboard: [Australis:M-]
I think we should explore this. However until Windows has full window frame drawing we can't change the design. We should just move this to post Australis v1.
Flags: needinfo?(shorlander)
Whiteboard: [Australis:M-] → [Australis:M-][Australis:P?]
Whiteboard: [Australis:M-][Australis:P?] → [Australis:M-][Australis:P5]
Whiteboard: [Australis:M-][Australis:P5] → [Australis:M-]
Whiteboard: [Australis:M-] → [Australis:P-]
Whiteboard: [Australis:P-] → [Australis:P-][Australis:M-]
based on comment 14
Status: UNCONFIRMED → NEW
Ever confirmed: true
Can this bug be nominated for the backlog ?
Flags: firefox-backlog?
This was discussed at the firefox-backlog meeting and determined to not warrant firefox-backlog+ because it is unlikely that full-window drawing (which this relies upon) will be a reality within the next 6 months.
Flags: firefox-backlog? → firefox-backlog-
I don't think this is a needed change anymore.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.