Cyrillic letters don't shown on forms for some charset.

VERIFIED FIXED in M11

Status

()

Core
Internationalization
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: g16776, Assigned: buster)

Tracking

Trunk
x86
Windows 98
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Cyrillic letters shown correctly on the forms (buttons, combobox, etc)
only if western codepage selected. But, of couse, all over text on page
don't viewed correctly. If I set Cyrillic (win-1251) codepage,
plain text is Ok, but text on forms unreadable.

Updated

18 years ago
Assignee: ftang → pierre

Comment 1

18 years ago
As I understand, no matter what  you do, form (buttons, combobox, etc) won't
display anyway. When the GFX widget land, this should be solved. Reassign this
pierre since this is depend on his GFX based widget switching.

Updated

18 years ago
Blocks: 7228

Updated

18 years ago
Assignee: pierre → bobj

Comment 2

18 years ago
The description isn't very clear and I'm not as sure as Franck that this problem
is related to native widgets and will be fixed when we switch to GFX widgets.
Also, this bug has reported against Windows and shouldn't have been reassigned to
me.

So I'm reassigning now to <bobj> hoping he can confirm what Franck said and
either reassign to the right person (<pollmann>, I think) either close as
duplicate of another bug because we already have so many related to native
widgets and i18n issues.

Updated

18 years ago
Assignee: bobj → buster
Depends on: 6262

Comment 3

18 years ago
Current forms (native) widgets implementations are temporary.
Once the GFX widgets are enabled, we should regress all the bugs currently
reported against the native widgets.  We expect these to work because Ender
appears to be I18N enabled.  Making this dependent upon the GFX widget
bug #6262 and reassigning to buster for now.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: M9
(Assignee)

Comment 4

18 years ago
GFX widgets are landing in M9
(Assignee)

Updated

18 years ago
Target Milestone: M9 → M10
(Assignee)

Comment 5

18 years ago
GFX text control landing pushed back to M10.  See 6262.
(Assignee)

Updated

18 years ago
Target Milestone: M10 → M11
(Assignee)

Comment 6

18 years ago
moved to M11
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

18 years ago
gfx controls are now on by default on win and linux, easily settable on mac.
marking fixed.  Please verify with gfx controls turned on.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
Test cases is in http://warp/employees/erik/tests/forms/nbsp/all-charsets
I verified this in 10-18-08 Win32, Linux build.
You need to log in before you can comment on or make changes to this bug.