console.log with different object logged from same line number are grouped together

RESOLVED FIXED in Firefox 23

Status

()

Firefox
Developer Tools: Console
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Optimizer, Assigned: msucan)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 23
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR :
1. Open this link http://jsfiddle.net/MvK8t/1/ and run with web console open.

The logged object is different each time, but I see following things happening :

1) All three logs have different objects, but they are combined.
2) I do not see the object in the variables view,
3) I get this error in error console :
Error: Server did not specify an actor, dropping packet: {"error":"unknownError","message":"error occurred while processing 'prototypeAndProperties': Error: Permission denied to access object\n"}
Source File: resource://gre/modules/devtools/dbg-client.jsm
Line: 592
(Assignee)

Comment 1

5 years ago
Thanks for the bug report.
Depends on: 778766
OS: Windows 7 → All
Priority: -- → P2
Hardware: x86_64 → All
Version: unspecified → Trunk
(Assignee)

Comment 2

5 years ago
I have a fix for the issue with console.log messages being repeated when different objects are given. Need to write a test.
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
(Assignee)

Comment 3

5 years ago
Created attachment 744648 [details] [diff] [review]
fix for console.log repeats

This is the fix for the bug where the web console groups together multiple console.log calls with the same text, different objects, from the same line. Now we also check if these messages point to the same objects before merging. Test included.

This bug also reports an issue with objects failing to be inspectable when they come from a different iframe. I suggest we open a separate bug. Girish, can you please do that?

Try push: https://tbpl.mozilla.org/?tree=Try&rev=53aeb8e642cf
Attachment #744648 - Flags: review?(past)
Comment on attachment 744648 [details] [diff] [review]
fix for console.log repeats

Review of attachment 744648 [details] [diff] [review]:
-----------------------------------------------------------------

Works as advertised!
Attachment #744648 - Flags: review?(past) → review+
(Reporter)

Comment 5

5 years ago
(In reply to Mihai Sucan [:msucan] from comment #3)
> This bug also reports an issue with objects failing to be inspectable when
> they come from a different iframe. I suggest we open a separate bug. Girish,
> can you please do that?

I saw this issue only a couple of times. I don't actually have STRs to open a bug. If you have better STRs, please feel free to open the bug :)
(Reporter)

Updated

5 years ago
Duplicate of this bug: 868172
(Assignee)

Comment 7

5 years ago
Thank you!

Landed:
https://hg.mozilla.org/integration/fx-team/rev/ac3547a7ed84


(In reply to Girish Sharma [:Optimizer] from comment #5)
> (In reply to Mihai Sucan [:msucan] from comment #3)
> > This bug also reports an issue with objects failing to be inspectable when
> > they come from a different iframe. I suggest we open a separate bug. Girish,
> > can you please do that?
> 
> I saw this issue only a couple of times. I don't actually have STRs to open
> a bug. If you have better STRs, please feel free to open the bug :)

I always get failures when I try to inspect those objects from the jsfiddle test case.
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/ac3547a7ed84
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 23
(Assignee)

Comment 9

5 years ago
Filed follow-up bug report: bug 869003. Thank you Girish.
You need to log in before you can comment on or make changes to this bug.