Work - Several Syncing issues with Firefox Metro

RESOLVED INVALID

Status

Firefox for Metro
Sync
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Going through the "Sync" feature these past two days, I ran into several issues that occurred on a regular basis but don't really have a set of specific steps to reproduce the issues.

Observations:

- Sometimes the "Sync now" button under "Sync" in the "Settings" charm completely stops becoming responsive. Usually when you select the "Sync now" button, it will let you know that its syncing and then a time stamp is added. In some cases, it won't do anything and quickly flash between grayed/ungrayed states without any feedback from Firefox Metro (confirmation or success messages)

- When initially starting Firefox Metro and then going under "Sync" in the "Settings" charm once you have paired two devices together, it will display the "Connecting.." message and this can take up to 5 minutes at times.

- Sometimes the "Sync now" button is grayed out and not selectable but doesn't give you a reason on why. This makes it a little confusing as there is no indication if a sync occurring. Just seems like its disabled and sometimes takes over an hour for the button to be selectable once again.

- Pressing "Disconnect" button sometimes takes 2-3 minutes to fully disconnect from the sycning account. On some occasions, it wouldn't disconnect until Firefox Metro was closed and then restarted.

- As stated in Bug 865101, the "Unresponsive Script" error message appears often, once this message is received, the entire Sync feature slows down and becomes unresponsive. Usually at this point, the only way to recover is to restart the Firefox Metro browser.

- During the one successful sync that I managed to complete, seemed like not most of the data was being sycned over. Had "Bookmarks", "History" enabled but they didn't seem to sync over. The only one that seemed to sync was the "Tabs"

As mentioned above, most of these are not 100% reproducible with exact steps, but I think if you create a brand new account and attempt to Sync between two different machines a few times, you will run into some if not all of the issues described above.

Throughout these two days, I've only managed to properly sync between two machines once. Think the "Sync" feature could use some work to making it more stable and more intuitive to end users.
Kamil: do you have Sync logs correlated with these observations? And/or error console output?

There have apparently been a few server issues recently, which might impact some behaviors.

The rest seem like weird event loop interactions or UI bugs, mostly. But logs will tell.
Hey Kamil, please see Comment #1 for information request.
Flags: needinfo?(kamiljoz)
(Reporter)

Comment 3

5 years ago
Created attachment 741625 [details]
Computer A (initial sync setup)

Hi Richard,

Zipped up some logs into two files: (Hopefully there's some information you can use!)

Computer A Logs: Touch Laptop (Set the initial sync account on this machine)
Computer B Logs: Desktop machine that I wanted the information to sync into

After a few tries and several "Unresponsive Script" (async.js:127) errors, syncing finished on Computer A. Received some of the information on Computer B but seems like the Bookmarks are not syncing at all.

Please let know if there's anymore information I can provide to make things easier for you!
Flags: needinfo?(kamiljoz)
(Reporter)

Comment 4

5 years ago
Created attachment 741628 [details]
Computer B (desktop machine receiving the data)
Note that synced bookmarks are only accessible in the ui in the awesomebar. Only bookmarks from the metro root will show up. (We talked about this particular issue at the Monday metro meeting)

Note that the ui updates for synced history items *just* landed. (same deal as above, only showing up in the awesome bar)

The last sync unresponsive script bug was a hold over from gps' refactor that was not applied to the metro client(the artist formerly known as the fennec sync client). Don't know if that is the case here, but it's worth mentioning.

We really need to do away with the sync now button. Instant Sync went in a long time ago.

Kamil, what did you find broken in the passwords sync? I see it off this bug but no details from you in that one or in comment 0?
Bug 865101 is probably the most direct representation of whatever root cause is resulting in these behaviors. Tricky.

Updated

5 years ago
See Also: → bug 865101

Updated

5 years ago
No longer blocks: 859003
Summary: Defect - Several Syncing issues with Firefox Metro → Work - Several Syncing issues with Firefox Metro
Whiteboard: feature=defect c=Sync_features u=metro_firefox_user p=0 → feature=work
(Reporter)

Comment 7

5 years ago
(In reply to :Ally Naaktgeboren from comment #5)
> Kamil, what did you find broken in the passwords sync? I see it off this bug
> but no details from you in that one or in comment 0?

Ally, regarding the Password Syncs, didn't find anything specific relating to password syncs but couldn't get the sync to work. Tried for a few hours and usually ran into the "Unresponsive Script"(async.js:127) error or it just waited there for 30-40 minutes while it attempted to Sync. Think the second issue was related to server issues that has been mentioned by Richard in Comment 1.

Comment 8

5 years ago
(In reply to Kamil Jozwiak [:kjozwiak] from comment #0)

> - Sometimes the "Sync now" button under "Sync" in the "Settings" charm
> completely stops becoming responsive. Usually when you select the "Sync now"
> button, it will let you know that its syncing and then a time stamp is
> added. In some cases, it won't do anything and quickly flash between
> grayed/ungrayed states without any feedback from Firefox Metro (confirmation
> or success messages)
> 
> - Sometimes the "Sync now" button is grayed out and not selectable but
> doesn't give you a reason on why. This makes it a little confusing as there
> is no indication if a sync occurring. Just seems like its disabled and
> sometimes takes over an hour for the button to be selectable once again.

filed bug 867200.

> - When initially starting Firefox Metro and then going under "Sync" in the
> "Settings" charm once you have paired two devices together, it will display
> the "Connecting.." message and this can take up to 5 minutes at times.

filed bug 867205.

> - Pressing "Disconnect" button sometimes takes 2-3 minutes to fully
> disconnect from the sycning account. On some occasions, it wouldn't
> disconnect until Firefox Metro was closed and then restarted.

filed bug 867201.

> - As stated in Bug 865101, the "Unresponsive Script" error message appears
> often, once this message is received, the entire Sync feature slows down and
> becomes unresponsive. Usually at this point, the only way to recover is to
> restart the Firefox Metro browser.

already filed under bug 865101.

> - During the one successful sync that I managed to complete, seemed like not
> most of the data was being sycned over. Had "Bookmarks", "History" enabled
> but they didn't seem to sync over. The only one that seemed to sync was the
> "Tabs"

This was addressed through making the grid more dynamic. This needs to be qa'd to be sure it's working right currently. If it isn't we should open up a fresh bug on the problem.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Assignee)

Updated

3 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.