Closed Bug 865101 Opened 7 years ago Closed 7 years ago

Work - Receiving "Unresponsive Script" while Syncing (async.js:127)

Categories

(Firefox for Metro Graveyard :: Sync, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 809171

People

(Reporter: kjozwiak, Assigned: jimm)

References

Details

(Whiteboard: feature=work)

Attachments

(2 files)

When attempting to Sync two Windows 8 machines that are running the same build on a clean "Firefox Sync Account", I would receive these "Unresponsive Script" errors and never succeed in getting the Sync to work. Ran into this error more then a few times when testing Firefox Metro. (spent at least 3 hours trying to sync without any luck)

- Attached a screenshot of the error into this ticket

Steps to reproduce the issue (Note: Not 100% reproducible):

1) On Computer A, open Firefox Browser and select "Options" and then "Sync"
2) While still on Computer A, select "Set Up Firefox Sync" and then "Create a New Account" (Insert all the required information and create the account)
3) On the same machine (Computer A), open Firefox Metro and select "Sync" under the "Settings" charm and then select "Pair a device"
4) On Computer B, open Firefox Metro and then select "Sync" under the "Settings" charm and then select "Connect"
5) Insert the codes listed on Computer B into Computer A (Pair both of the machines

After both machines pair, sometimes you will get the error message mentioned above as shown in the screenshot (sometimes the machines would sync, sometimes you will receive that error making it very hard to sync)

Could be related to Bug 809171 (Created a new issue as its a different line that is unresponsive, please let me know if this is the same issue)

Current Behavior:

- Receiving a "Unresponsive Script" error when attempting to Sync two different machines

Expected Behavior:

- Should Sync without producing a "Unresponsive Script" error

Build Used:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-23-03-09-35-mozilla-central/
The line you're seeing here is just the endless sequence of function calls to make sure the app isn't quitting while we wait for an async callback (98, 127, 99, 98, 127...).

If there's nothing in the event loop, so line 99 ends quickly and we loop many times, these will occur in a way that looks very much like an infinite loop.

I would *hope* that yielding to the event loop doesn't trigger an unresponsive script warning, but perhaps that's not the case on Metro? See Bug 829770.

Alternatively, there could be a bug somewhere that results in a callback never being invoked, and so we're just spinning forever.
Richard,

I reproduced the error a few more times and attached a log file. Hopefully this has some information you can use.

Let me know if there's any other information you need
Kamil: did you quit two minutes after starting to sync?
(In reply to Richard Newman [:rnewman] from comment #3)
> Kamil: did you quit two minutes after starting to sync?

Ya, sometimes I wait around 10 minutes or so and then close the browser and receive the same error. When the error appears, the modal message freezes (tapping/pressing wont work) and the browser needs to be closed. When re-opening the browser, you will usually keep getting a few times until it finally stops appearing.

I've received it at random times (rarely) but could also be related to closing the browser during a sync that I didn't know was occurring.
OK, so it's hanging in buildGUIDMap in the bookmarks engine, and you're having to kill it.

Perhaps something odd is happening with places init?
(In reply to Richard Newman [:rnewman] from comment #5)
> OK, so it's hanging in buildGUIDMap in the bookmarks engine, and you're
> having to kill it.
> 
> Perhaps something odd is happening with places init?

Is there any way I can help checking this? Let me know!
See Also: → 865318
Blocks: 833130, 833131, 833132
No longer blocks: 831615
No longer blocks: metrov1defect&change
Summary: Defect - Receiving "Unresponsive Script" while Syncing (async.js:127) → Work - Receiving "Unresponsive Script" while Syncing (async.js:127)
Whiteboard: feature=defect c=Install_and_setup u=metro_firefox_user p=0 → feature=work
No longer blocks: 833130
Blocks: 833130
Blocks: 849312
No longer blocks: 833130, 833131, 833132
Assignee: nobody → jmathies
I see errors in async.js:96 and async.js:127, usually after one of the engines finishes up with:

Sync.Engine.(engine)	INFO	Records: X applied, X successfully, 0 failed to apply, 0 newly failed to apply, 0 reconciled.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809171
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.