Closed Bug 865336 Opened 8 years ago Closed 8 years ago

Long running scripts are just stopped

Categories

(Firefox OS Graveyard :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 921519

People

(Reporter: nick, Unassigned)

Details

Attachments

(1 file)

Attached file Test case files
In the browser, the user is warned when a script is taking too long to execute.  In an app, there is no choice or warning.  This means that if a page is stuck in a long running script block, the rest of the app will never be rendered.  A simple while (true); will do the trick.

STR:
1. Download attachment
2 [review]. unzip test_case.zip
3. get test device and machine you'll serve assets from on same network
4. get server's local ip address
5. python serve.py
6. on device, in browser, navigate to http://[server's local ip]:3000/install.html
7. install test case
8. on device, in browser, navigate to  http://[server's local ip]:3000/
9. Notice how warning appears about long running script (also note the ampersand in "& Don't ask me again")
10. close browser application
11. open test case app
12. Notice how no html is ever rendered, yet you are not warned about long running scripts.

This can be painful to debug apps that appear fine on the simulator, but take longer to run on device.  It's not made clear that the app has a long running script.  I initially suspected failures in the graphics layer because of the failed rendering.
Component: Gaia → Gaia::Browser
Jason, we show the "long running script" dialog when the page is loaded in the browser, but not when it's part of an app. I'm moveing to b2g::general until we are sure how to fix that (this may need some platform pieces).
Component: Gaia::Browser → General
For reference, in my description by browser I mean the browser app on device.  The script was not long running on desktop, but it was on device.  I suppose this has more to do with hardware performance than differing thresholds for long running scripts between the two.  Good thing the app I found this on was hosted, so I could also test it in the device browser, but if this happened in a packaged app, I'm not sure how I would have found it. :(
blocking-b2g: --- → koi?
Naveed,

Please check if this is a JSE issue and reassign appropriately.
Flags: needinfo?(nihsanullah)
Will consider for 1.3 since koi FC has already been done.
blocking-b2g: koi? → 1.3?
(In reply to Preeti Raghunath(:Preeti) from comment #4)
> Will consider for 1.3 since koi FC has already been done.

This likely isn't happening anytime soon for any release, so I'm clearing the nom.
blocking-b2g: 1.3? → ---
This is a dup and was already fixed. \o/
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 921519
Flags: needinfo?(nihsanullah)
You need to log in before you can comment on or make changes to this bug.