Closed Bug 921519 Opened 6 years ago Closed 6 years ago

Really disable the slow script dialog on B2G

Categories

(Core :: XPConnect, defect)

17 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27
blocking-b2g koi+
Tracking Status
firefox25 --- wontfix
firefox26 --- fixed
firefox27 --- fixed
b2g-v1.2 --- fixed

People

(Reporter: mrbkap, Assigned: mrbkap)

References

Details

Attachments

(1 file, 1 obsolete file)

Debugging bug 884394, I found that we end up hanging trying to bring up the slow script dialog (we try to bring up the dialog, but as far as I can tell, nobody is listening) and end up hanging in BrowserElementChild._waitForResult.
Attached patch patch v1 (obsolete) — Splinter Review
A value of 0 means "don't do that."
Attachment #811186 - Flags: review?(bobbyholley+bmo)
Comment on attachment 811186 [details] [diff] [review]
patch v1

Review of attachment 811186 [details] [diff] [review]:
-----------------------------------------------------------------

r=bholley with comments.

::: b2g/app/b2g.js
@@ +187,5 @@
>  pref("dom.max_chrome_script_run_time", 0); // disable slow script dialog for chrome
>  // Disable the watchdog thread for B2G. See bug 870043 comment 31.
>  pref("dom.use_watchdog", false);
> +pref("dom.max_script_run_time", 0);
> +pref("dom.max_chrome_script_run_time", 0);

This is redundant with the line 2 lines up. Remove the previous one and keep these together.

Also, please add a comment explaining why we need to both disable the watchdog and disable the listener.
Attachment #811186 - Flags: review?(bobbyholley+bmo) → review+
Blocks a blocker.
blocking-b2g: --- → koi+
Attached patch patch v1.1Splinter Review
Attachment #811186 - Attachment is obsolete: true
Attachment #811211 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/54a7972a9358
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Duplicate of this bug: 865336
You need to log in before you can comment on or make changes to this bug.