Closed Bug 865668 Opened 7 years ago Closed 7 years ago

Star button disappeared from toolbar in profiles where the Bookmarks Menu button had been removed

Categories

(Firefox :: Toolbars and Customization, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

Details

The "star-and-bookmarks-menu" dual button should probably be visible in any profile that had the star *or* the bookmarks menu button.

(But see also bug 865199.)
That's strange, our migration in nsBrowserGlue should put the button in the currentSet, though the localStore has always been quite buggy.
I will verify, though I wonder if that's caused by moving from a build with the new button, to a build without it, removing the button and moving again to a new build. This has indeed never been supported (UI migration runs just once)
See also bug 865441.
Is this still valid?
Flags: needinfo?(mak77)
as far as I can tell the current code in UX just puts the button on the toolbar, this shouldn't happen.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(mak77)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.