Closed Bug 865798 Opened 9 years ago Closed 9 years ago

installDate/updateDate are not added to social manifests

Categories

(Firefox Graveyard :: SocialAPI, defect)

22 Branch
x86
macOS
defect
Not set
normal

Tracking

(firefox22 fixed, firefox23 fixed)

RESOLVED FIXED
Firefox 23
Tracking Status
firefox22 --- fixed
firefox23 --- fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Details

(Whiteboard: [qa-])

Attachments

(1 file, 2 obsolete files)

install/update should stamp the manifest so the addon wrapper can properly provide that information for the addon manager and fhr.  The addon wrapper in SocialService.jsm does have the getters, but the AddonInstaller doesn't add the stamp.
Attached patch manifest timestamps.patch (obsolete) — Splinter Review
Assignee: nobody → mixedpuppy
Attachment #742002 - Flags: review?(felipc)
Attachment #742002 - Flags: review?(felipc) → review+
Attached patch manifest timestamps.patch (obsolete) — Splinter Review
adding tests and try

https://tbpl.mozilla.org/?tree=Try&rev=058a9c2495e3
Attachment #742002 - Attachment is obsolete: true
Attachment #743193 - Flags: review?(felipc)
Comment on attachment 743193 [details] [diff] [review]
manifest timestamps.patch

r+ with the potential removal of the "!Services.prefs.prefHasUserValue(prefname)" check, if you think it's ok to do. (run tests again?)

The comment didn't help me much to understand the if condition. I think you could add something like "... is set at a user-level by checking the existence of the updateDate field, which is not present in the default pref value".
Attachment #743193 - Flags: review?(felipc) → review+
patch with discussed change, carry forward r+, retested locally

https://hg.mozilla.org/integration/mozilla-inbound/rev/2d02910b859e
Attachment #743193 - Attachment is obsolete: true
Attachment #743378 - Flags: review+
Comment on attachment 743378 [details] [diff] [review]
manifest timestamps.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 851653
User impact if declined: fhr reporting is slightly flawed
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #743378 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/2d02910b859e
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Comment on attachment 743378 [details] [diff] [review]
manifest timestamps.patch

In support of FHR
Attachment #743378 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Does this bug require any qa testing? It seems have patch landed for it.
Flags: in-testsuite?
Whiteboard: [qa?]
Looks like this has tests in-testsuite so I'm tagging this [qa-]. Please remove this tag and add the verifyme keyword if you feel this needs QA verification.
Flags: in-testsuite? → in-testsuite+
Whiteboard: [qa?] → [qa-]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.