Last Comment Bug 865826 - Remove the browser.tabs.closeButtons pref
: Remove the browser.tabs.closeButtons pref
Status: RESOLVED FIXED
: addon-compat, dev-doc-needed
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
-- normal (vote)
: Firefox 31
Assigned To: Dão Gottwald [:dao]
:
: Dão Gottwald [:dao]
Mentors:
Depends on: 1022211 1001871 1007300 1022214
Blocks: 1001572
  Show dependency treegraph
 
Reported: 2013-04-25 13:00 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2014-09-08 02:02 PDT (History)
38 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
31+


Attachments
patch (21.70 KB, patch)
2014-04-17 03:12 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review
patch (21.54 KB, patch)
2014-04-18 02:51 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review
patch (22.63 KB, patch)
2014-04-18 10:01 PDT, Dão Gottwald [:dao]
jaws: review+
Details | Diff | Splinter Review

Description User image Jared Wein [:jaws] (please needinfo? me) 2013-04-25 13:00:03 PDT
The browser.tabs.closeButtons pref is only discoverable via about:config. It provides other locations for the tab close buttons, but none that we plan to move towards in the future.

These would be better supported and more discoverable if they were implemented by an add-on.

0: Display a close button on the active tab only
1: Display close buttons on all tabs (Default)
2: Don’t display any close buttons
3: Display a single close button at the end of the tab strip (Firefox 1.x behavior) 

Because we are removing this pref, we will effectively be migrating users back to the default value of 1.

To fix this bug, you'll need to update the following places:
http://mxr.mozilla.org/mozilla-central/search?string=browser.tabs.closeButtons
http://mxr.mozilla.org/mozilla-central/search?string=mCloseButtons

and remove mentions of the pref in:
http://mxr.mozilla.org/mozilla-central/source/browser/app/profile/firefox.js
Comment 1 User image James Lanham 2013-04-28 13:05:10 PDT
I've looked it over, and am interested in working on this as my first bug. Any objections?
Comment 2 User image Jared Wein [:jaws] (please needinfo? me) 2013-04-28 13:12:27 PDT
Nope, go for it! :)
Comment 3 User image Jared Wein [:jaws] (please needinfo? me) 2013-06-05 10:23:15 PDT
James, any progress on this?
Comment 4 User image James Lanham 2013-06-05 13:38:46 PDT
I'm sorry, I've switched computers and haven't downloaded any dev stuff onto here yet. I would appreciate if someone else would take over, it might take me a while because I have a lot on my plate right now.
Comment 5 User image Yati Sagade 2013-08-10 08:38:24 PDT
I'd like to work on this. Can someone please assign this to me?
Comment 6 User image Yati Sagade 2013-08-10 09:03:59 PDT
Sorry, did not notice you were assigned :)
Comment 7 User image Dão Gottwald [:dao] 2014-04-17 03:12:08 PDT
Created attachment 8408126 [details] [diff] [review]
patch
Comment 8 User image Dão Gottwald [:dao] 2014-04-18 02:51:35 PDT
Created attachment 8408887 [details] [diff] [review]
patch
Comment 9 User image Dão Gottwald [:dao] 2014-04-18 10:01:57 PDT
Created attachment 8409012 [details] [diff] [review]
patch
Comment 10 User image Jared Wein [:jaws] (please needinfo? me) 2014-04-24 12:49:19 PDT
Comment on attachment 8409012 [details] [diff] [review]
patch

Review of attachment 8409012 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/modules/BrowserUITelemetry.jsm
@@ -61,5 @@
>      "TabsToolbar": [
>        "tabbrowser-tabs",
>        "new-tab-button",
>        "alltabs-button",
> -      "tabs-closebutton",

Is this going to affect UITelemetry numbers that are counting how many items users have in their TabsToolbar? I'll flag :mconley about this.
Comment 11 User image Jared Wein [:jaws] (please needinfo? me) 2014-04-24 12:50:02 PDT
Mike, please see the question above in comment #10.
Comment 12 User image Mike Conley (:mconley) 2014-04-24 12:54:47 PDT
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #10)
> Comment on attachment 8409012 [details] [diff] [review]
> patch
> 
> Review of attachment 8409012 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/modules/BrowserUITelemetry.jsm
> @@ -61,5 @@
> >      "TabsToolbar": [
> >        "tabbrowser-tabs",
> >        "new-tab-button",
> >        "alltabs-button",
> > -      "tabs-closebutton",
> 
> Is this going to affect UITelemetry numbers that are counting how many items
> users have in their TabsToolbar? I'll flag :mconley about this.

No, this should be fine. We don't do raw counting of toolbar contents - we just see what built-in items were added, moved, removed, or stayed put. This patch just removes tabs-closebutton from the list of built-in items, which is fine.
Comment 13 User image Dão Gottwald [:dao] 2014-04-25 02:50:38 PDT
https://hg.mozilla.org/integration/fx-team/rev/1c2ef0d3d997
Comment 14 User image Carsten Book [:Tomcat] 2014-04-25 05:14:59 PDT
sorry had to backout for test failures like https://tbpl.mozilla.org/php/getParsedLog.php?id=38478621&tree=Fx-Team
Comment 15 User image Dão Gottwald [:dao] 2014-04-25 05:30:46 PDT
https://hg.mozilla.org/integration/fx-team/rev/1f5f1fe135b9
Comment 16 User image Ryan VanderMeulen [:RyanVM] 2014-04-25 13:29:13 PDT
https://hg.mozilla.org/mozilla-central/rev/1f5f1fe135b9
Comment 17 User image WildcatRay 2014-04-26 08:50:18 PDT
I would like to point out that this patch has led to the breaking of addons that utilized this pref and/or the code that supports it. In my case, I use Tab Mix Plus. Others users have reported that with TMP enabled, the browser is not usable.

I am disappointed that after this was proposed, no one asked if this change would negatively impact addons and, if it did negatively impact addon, should the change be implemented?

Honestly, "discover-ability" is quite low on the scale of things that need to be fixed, especially when addons already exist that utilize this pref and/or its code.

I hope you will reconsider this patch given the negative impact it is causing addons.
Comment 18 User image Dão Gottwald [:dao] 2014-04-26 08:57:29 PDT
(In reply to ol.rrm.2008@gmail.com from comment #17)
> I would like to point out that this patch has led to the breaking of addons
> that utilized this pref and/or the code that supports it. In my case, I use
> Tab Mix Plus. Others users have reported that with TMP enabled, the browser
> is not usable.

This is not surprising at all. Due to its tight integration with tabbrowser, it breaks very easily when we touch tabbrowser. Usually it's updated quite quickly.
Comment 19 User image WildcatRay 2014-04-26 09:06:19 PDT
(In reply to Dão Gottwald [:dao] from comment #18)
> (In reply to ol.rrm.2008@gmail.com from comment #17)
> > I would like to point out that this patch has led to the breaking of addons
> > that utilized this pref and/or the code that supports it. In my case, I use
> > Tab Mix Plus. Others users have reported that with TMP enabled, the browser
> > is not usable.
> 
> This is not surprising at all. Due to its tight integration with tabbrowser,
> it breaks very easily when we touch tabbrowser. Usually it's updated quite
> quickly.

Dao,

This is not about breaking Tab Mix Plus. It is about making a change that does little if anything to improve the browser or correct a problem with the browser, but does negatively affect addons. In other words, there was no risk analysis conducted to determine what the effects of this change would be and if those effects should or should not be avoided.
Comment 20 User image Dão Gottwald [:dao] 2014-04-26 09:24:45 PDT
You made a general claim about add-on compatibility and used TMP as an example, to which I responded. You can't extrapoate from TMP to other add-ons. While we made no formal risk analysis, we can say that, based on our experience with former changes to tabbrowser, this patch is unlikely to break lots of add-ons.
Comment 21 User image Luís Miguel [:quicksaver] (not reading bugmail) 2014-04-26 09:53:07 PDT
(In reply to Dão Gottwald [:dao] from comment #20)
> While we made no formal risk analysis, we can say that, based on
> our experience with former changes to tabbrowser, this patch is unlikely to
> break lots of add-ons.

FYI, it broke my OmniSidebar, although that'll be easy to fix on my side. ;)

PS. Please see bug 1001871, although not critical for the functioning of the browser, I think it's still important.
Comment 22 User image Dão Gottwald [:dao] 2014-04-26 10:11:06 PDT
(In reply to Luís Miguel [:Quicksaver] from comment #21)
> FYI, it broke my OmniSidebar, although that'll be easy to fix on my side. ;)

Due to the removal of the tabs-closebutton class, I suppose? It's unfortunate that we set the precedent of using that class outside of tabbrowser and then add-ons followed us. They should be using the close-icon class instead. I'm adding the addon-compat keyword for this.
Comment 23 User image Luís Miguel [:quicksaver] (not reading bugmail) 2014-04-26 10:15:42 PDT
(In reply to Dão Gottwald [:dao] from comment #22)
> (In reply to Luís Miguel [:Quicksaver] from comment #21)
> > FYI, it broke my OmniSidebar, although that'll be easy to fix on my side. ;)
> 
> Due to the removal of the tabs-closebutton class, I suppose?

Yep, that was it, I was getting the close button DOM node through a querySelectorAll('toolbarbutton.tabs-closebutton') in the header. It's an easy change to make in the add-on of course, but I thought you would want to know.
Comment 24 User image [github robot] 2014-04-26 12:42:16 PDT
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/b95c9d3ec4a49ca8a557e0126c4663c5c01f2b08
Bug 865826 - Remove the browser.tabs.closeButtons pref. r=jaws
Comment 25 User image PimpUigi 2014-04-26 17:31:11 PDT Comment hidden (abusive, anger)
Comment 26 User image Matthew N. [:MattN] (PM if requests are blocking you) 2014-04-26 18:35:05 PDT
(In reply to PimpUigi from comment #25)
> No more help button in the app menu, you have to press alt to show the
> menu...

It is in the app menu, it's the question mark icon in the footer which is standard for "help".
Comment 27 User image PimpUigi 2014-04-26 18:45:50 PDT
Yeah, you're right. Haha.
Comment 28 User image Octoploid 2014-04-27 00:29:18 PDT Comment hidden (advocacy, anger)
Comment 29 User image Michael Loney 2014-04-27 12:26:59 PDT
Please provide some way to add this back ASAP. Firefox now feels dumbed down just like Chrome. Why would anyone remove this without providing at least an addon to add the functionality back first? Now I have more wasted space on my tabs. I have tweaked this preference on ever Firefox install on Linux and Windows for years. Since I use a mouse with a middle button, I have no purpose for the close button. I can tolerate and even enjoy australis but this is going too far.
Comment 30 User image Aris 2014-04-27 12:32:13 PDT
I will add the close tab button options to CTR add-on.
Comment 31 User image Fyren 2014-04-28 00:13:25 PDT
Seems like adding .tab-close-button { display: none !important; } to userChrome.css is enough to make it act like removed pref when it had a value of 2.
Comment 32 User image Dirkjan Ochtman (:djc) 2014-04-28 02:06:06 PDT
I've built a small addon that takes care of removing the close buttons:

https://addons.mozilla.org/en-US/firefox/addon/no-close-buttons/
Comment 33 User image Aris 2014-04-28 02:39:26 PDT
Latest CTR beta restores the three missing states from browser.tabs.closeButtons preference,
--> Fx31 --> CTR prefwindow --> tab close settings on main tab

https://addons.mozilla.org/addon/classicthemerestorer/versions/1.1.9beta17
Comment 34 User image Dão Gottwald [:dao] 2014-04-28 08:01:08 PDT
It may make sense to have the release notes link to the add-on in comment 32 for removing all tab close buttons and/or comment 33 for completely restoring the pref.
Comment 35 User image Tim Nguyen :ntim 2014-04-28 09:29:42 PDT
(In reply to Dão Gottwald [:dao] from comment #34)
> It may make sense to have the release notes link to the add-on in comment 32
> for removing all tab close buttons and/or comment 33 for completely
> restoring the pref.

I would say comment 33 since it has all the previously included options.
Comment 36 User image Sylvestre Ledru [:sylvestre] 2014-04-30 05:19:42 PDT
dao, could you propose some wordings for the release notes? Thanks
By the way, you confirm that it is going to be for 31?
Comment 37 User image Dão Gottwald [:dao] 2014-04-30 14:02:07 PDT
(In reply to Sylvestre Ledru [:sylvestre] from comment #36)
> dao, could you propose some wordings for the release notes? Thanks

"The browser.tabs.closeButtons hidden preference is no longer supported. Add-ons can be used to customize the tab close buttons (link 1 <https://addons.mozilla.org/firefox/addon/no-close-buttons/>, link 2 <https://addons.mozilla.org/firefox/addon/classicthemerestorer/>)."

> By the way, you confirm that it is going to be for 31?

Yes.
Comment 38 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2014-05-01 23:09:16 PDT
(In reply to Dirkjan Ochtman (:djc) from comment #32)
> I've built a small addon that takes care of removing the close buttons:
> 
> https://addons.mozilla.org/en-US/firefox/addon/no-close-buttons/

Thanks Dirkjan!
Comment 39 User image tyaremco 2014-05-03 01:39:47 PDT
Sorry, where is the explanation for this bug?  You know, what are the reasons for it to exist?

> The browser.tabs.closeButtons pref is only discoverable via about:config. 

Yes, so are many prefs.  Why is this is even mentioned?

> It provides other locations for the tab close buttons

It provides ONE other location: the end of the tabbar.

> but none that we plan to move towards in the future.

So, modify the pref?  Why not?

> These would be better supported and more discoverable if they were implemented by an add-on.

How could a feature already baked into Firefox be better supported by an entity other than Mozilla?  

Wouldn't it also be more discoverable if it was say, put into an options dialog?  Why not?

The whole purpose of discoverability is to introduce the user to options they didn't know were available.  How does hosting an addon with thousands of others on a website aid in this endeavor?  If the user already knows they want to change the close button, there is essentially no difference between searching for information about browser.tabs.closeButtons and searching for which addon they need. 


Where is the discussion about the validity of this bug?  Is Jared just unilaterally making these decisions?  None of the arguments for it seem coherent.  Why does this bug make Firefox better?
Comment 40 User image Tim Nguyen :ntim 2014-05-03 03:46:20 PDT
(In reply to tyaremco from comment #39)
> Sorry, where is the explanation for this bug?  You know, what are the
> reasons for it to exist?
> 
> > The browser.tabs.closeButtons pref is only discoverable via about:config. 
> 
> Yes, so are many prefs.  Why is this is even mentioned?
> 
> > It provides other locations for the tab close buttons
> 
> It provides ONE other location: the end of the tabbar.
> 
> > but none that we plan to move towards in the future.
> 
> So, modify the pref?  Why not?
> 
> > These would be better supported and more discoverable if they were implemented by an add-on.
> 
> How could a feature already baked into Firefox be better supported by an
> entity other than Mozilla?  
> 
> Wouldn't it also be more discoverable if it was say, put into an options
> dialog?  Why not?
> 
> The whole purpose of discoverability is to introduce the user to options
> they didn't know were available.  How does hosting an addon with thousands
> of others on a website aid in this endeavor?  If the user already knows they
> want to change the close button, there is essentially no difference between
> searching for information about browser.tabs.closeButtons and searching for
> which addon they need. 
> 
> 
> Where is the discussion about the validity of this bug?  Is Jared just
> unilaterally making these decisions?  None of the arguments for it seem
> coherent.  Why does this bug make Firefox better?

I'm guessing not much people use the pref ? If more people used it, I'm sure it wouldn't have been removed.
Comment 41 User image tyaremco 2014-05-03 15:45:25 PDT
> I'm guessing not much people use the pref ? If more people used it, I'm sure
> it wouldn't have been removed.

My point is that it should not be ambiguous why a feature was removed.  Should the community be resigned to guessing about Mozilla's rationale?
Comment 42 User image Sylvestre Ledru [:sylvestre] 2014-05-04 06:41:32 PDT
Added in the release notes with the title "browser.tabs.closeButtons hidden preference no longer supported (See the <a href="https://addons.mozilla.org/fr/firefox/addon/no-close-buttons/">No Close Buttons</a> extension for alternative)"
Comment 43 User image Jared Wein [:jaws] (please needinfo? me) 2014-05-04 10:13:23 PDT
Sylvestre, please adjust the link to remove the locale from the URL. AMO should redirect the user to their requested locale if one is not provided in the link. Note that the link in comment 42 is for French.
Comment 44 User image Sylvestre Ledru [:sylvestre] 2014-05-04 14:42:42 PDT
Fixed, thanks
Comment 45 User image Jeremy Morton 2014-05-05 13:05:53 PDT Comment hidden (off-topic)
Comment 46 User image Jorge Villalobos [:jorgev] 2014-05-05 16:00:17 PDT
Looking into AMO add-ons, I saw a couple dozen that are using this pref, mostly in two categories: tab add-ons and hidden pref add-ons, notably:

* https://addons.mozilla.org/addon/tab-mix-plus/, 1M ADI
* https://addons.mozilla.org/addon/classic-compact-options/, 152K ADI
* https://addons.mozilla.org/addon/tab-utilities/, 37K ADI
* https://addons.mozilla.org/addon/guiconfig/, 26K ADI
* https://addons.mozilla.org/addon/configuration-mania-4420/, 23K ADI

Looking for tabs-closebutton leads to dozens additional results.

I wouldn't expect these add-ons to break very dramatically due to this change, or the fix to be particularly difficult, however.
Comment 47 User image jjdelc@gmail.com 2014-05-13 13:50:03 PDT
It took me a lot of interneting to find this bug. Bugzilla does not show this when searching for the "closeButtons" preference.

I am also bummed on how this decision was made. I respect the developer that proposed it, but it looks like it was an unilateral call without any discussion or input: "I don't use it, then nobody else must".

What is the cost/benefit of removing it vs leaving it. Does removing the feature improve the browser experience? Maybe reduces code complexity? 

Sure, the 20 of us who use it can very well go to userChrome.css and do it. I would have been more accepting if there was an argument on "why", so I can sleep at night. Not to explain "me" but so in the future when coming back we can understand the rationale and not fall for this in the future. Developer B may come with an idea "let's add a closeButtons preference" and do it again since there was no reason explaining why it was a good idea to get rid of it on the first place.

My personal stance, I think it bloats my browser more to have one more extension installed than setting a browser preference. The fact that a preference is not discoverable is not an argument by itself, we'd get rid of 90% of about:config options.
Comment 48 User image Chizilla 2014-05-13 21:36:08 PDT Comment hidden (off-topic)
Comment 49 User image Dão Gottwald [:dao] 2014-05-16 09:53:19 PDT
(In reply to Jj Del Carpio from comment #47)
> What is the cost/benefit of removing it vs leaving it. Does removing the
> feature improve the browser experience? Maybe reduces code complexity?

Yes, it did reduce code complexity.
Comment 50 User image Alex Shilov 2014-05-25 07:59:48 PDT Comment hidden (advocacy)
Comment 51 User image Tim Nguyen :ntim 2014-05-25 10:50:46 PDT
(In reply to Alex Shilov from comment #50)
> What the... I'm just updated my Nightly (I'm not using auto-update) and my
> sweet close tab button is gone. Now it's in every tab, instead of at the end
> of the tab strip.
> I used browser.tabs.closeButtons=3 for ages, since Phoenix 0.1, since
> Mozilla Suite 1, you name it. And now it's gone!
> I was already know the setting name, and assumed that some clever people
> could remove the setting. But it took some time to find this bug page. What
> about users who changed this setting via some addons, or just forgot the
> setting name, how can they find and write in this bug? Ok, i'm using
> nightly, how surprising it will be for million stable users.
> 
> Dao, as long as I remember you are the member of UX team? Have you done any
> research for this bug? What is the approximate number of people used this
> setting based of any collected data? I thought there was some sort of tool
> to measure it, right? Or it can be found in users sync data, right?
No he is not an UX member. Yes, we have telemetry, and I'm sure most users don't even know or use this prefs. You can ask the firefox-dev mailing list, they might have your answer.

> (In reply to Dão Gottwald [:dao] from comment #49)
> > (In reply to Jj Del Carpio from comment #47)
> > > What is the cost/benefit of removing it vs leaving it. Does removing the
> > > feature improve the browser experience? Maybe reduces code complexity?
> > 
> > Yes, it did reduce code complexity.
> And it _broke_ experience! 
> In fact, if classicthemerestorer has effect, theme-addons still must support
> browser.tabs.closeButtons=3 button, right? If so, what complexity of the
> code are reduced exactly?
Add-ons build their own code to recreate the pref.


> Let me explain which UX behaviour cases are broken:
> 1) I have 20 tabs open and want quickly close five of them from the middle.
> I select first one to delete and click mouse to the static-placed close
> button which number of times what I want. Each tab width at this moment
> could stretch and shrink, it doesn't matter as long as the close button
> stays stock-still. 
> Now if tab width are changing when tabs count reducing the close button
> jumping over tab strip.
Note that the tab width stays in place for a few seconds. Also, you can middle click tabs to close them, it's a very handy trick I use to close tabs quickly.

> 2) Then I have 100+ tabs open tab width are 30px, then browser hand I
> sometimes click two times to change it, now accidentally I could press close
> button then selecting the tab, it's unacceptable.
Note that if you have lots of tabs, the close button will only appear for the selected tab. So there's no chance of closing a tab while selecting it.

> 3) If I have 100+ tabs and want to close some specific tabs (based on
> favicons, like only Google searches tabs), I could move them using Ctrl+Tab
> by left hand, and by right hand clicking close button in the right. It was
> easy. Now I can't do that. 
Middle clicking the tab to close it is your friend, it's fast and requires just one hand.


> If there was so much complexity let's check this out. In your patch, you
> removed 96 lines of code, MOST of them are comments or CSS in default theme,
> (the lines which are currently present in thousands of themes), and added 36
> lines of code. It actually about a dozen of somehow significant lines of
> code are removed. Firefox codebase has about 11 million lines of code, so
> you reduce complexity for about 0.0000%. You haven't optimize rendering
> engine, or js-engine, or startup time at all, all you did is broke some
> users experience.
It does reduce lots of code complexity, especially for future tab code we'll introduce. It removes the close button at the end of the tab bar and the CSS and javascript related to it.
Comment 52 User image Tim Nguyen :ntim 2014-05-25 10:52:15 PDT
(In reply to Alex Shilov from comment #50)
You might also want to post this to the firefox-dev mailing list, this is not a place for discussion.
Comment 53 User image Alex Shilov 2014-05-25 12:05:18 PDT Comment hidden (advocacy)
Comment 54 User image Alex Shilov 2014-05-25 12:42:56 PDT Comment hidden (off-topic)
Comment 55 User image Ben Bucksch (:BenB) 2014-05-27 02:25:38 PDT
Alex, in addition to middle click, you can also use Ctrl-W. When I want to use several tabs in a row, I select the first one, then use Ctrl-W several times to close the tabs.
Comment 56 User image Tim Nguyen :ntim 2014-05-27 08:00:10 PDT
(In reply to Alex Shilov from comment #54)
Then file a new bug. This bug is clearly to overloaded for more comments.
Comment 57 User image Alex Shilov 2014-05-27 08:26:14 PDT
(In reply to Ben Bucksch (:BenB) from comment #55)
> Alex, in addition to middle click, you can also use Ctrl-W. When I want to
> use several tabs in a row, I select the first one, then use Ctrl-W several
> times to close the tabs.
Thanks Ben, of course for closing tab I can press Ctrl-W, or Ctrl-F4 - which I use sometimes, but it's not my preferred way. The question is not How I can do something different from habitual way, the question is Why I should do that, if both way works fine till Firefox 32.0a. 
So I prefer selecting tab by the left hand, and closing it by the right hand. But that's not the point, then I browsing - I'd like using mouse alone (in the right hand) w/o keyboard shortcuts, so closing multiple tabs in a row it's now hard for me. 
Also notice that there was very old bug 78414, so keyboard shortcuts not working if page containing Flash (like youtube player) and it selected. So Ctrl-W has no effect on that pages.

When I described UX cases, they are not synthetical, they used by the real user - me. 
> 1) I have 20 tabs open and want quickly close five of them from the middle.
> I select first one to delete and click mouse to the static-placed close
> button which number of times what I want. Each tab width at this moment
> could stretch and shrink, it doesn't matter as long as the close button
> stays stock-still. 
> Now if tab width are changing when tabs count reducing the close button
> jumping over tab strip.
In this case using Ctrl-F4 could slow down my work, because I must using both keyboard and mouse, instead of only mouse.
> 2) Then I have 100+ tabs open tab width are 30px, then browser hand I
> sometimes click two times to change it, now accidentally I could press close
> button then selecting the tab, it's unacceptable.
Shortcuts can't help in this case either.
> 3) If I have 100+ tabs and want to close some specific tabs (based on
> favicons, like only Google searches tabs), I could move them using Ctrl+Tab
> by left hand, and by right hand clicking close button in the right. It was
> easy. Now I can't do that. 
In this case I can use Ctrl-W, but on my left hand there will be two shortcut positions Ctrl-W and Ctrl-Tab, which will be twice as hard in using.

I have viewed telemetry data (http://telemetry.mozilla.org/), and also have a reply from DevTeam member (Benjamin Smedberg) who states that there are no such telemetry data. So this bugfix cause based on nothing. 

(In reply to Tim Nguyen [:ntim] from comment #56)
> (In reply to Alex Shilov from comment #54)
> Then file a new bug. This bug is clearly to overloaded for more comments.
If so... OK.
Comment 58 User image Steve Brecht 2014-06-17 10:53:34 PDT Comment hidden (advocacy)
Comment 59 User image PimpUigi 2014-06-18 00:45:18 PDT Comment hidden (advocacy)
Comment 60 User image Artem S. Tashkinov 2014-06-18 07:40:13 PDT Comment hidden (advocacy)
Comment 61 User image Lukas 2014-07-22 11:27:01 PDT Comment hidden (advocacy)
Comment 62 User image Dão Gottwald [:dao] 2014-07-23 03:46:48 PDT
(In reply to Lukas from comment #61)
> Now I am closing tabs by mistake.
> Why must you constantly annoy users? You really do everything to put Firefox
> down. :(

You can customize this with add-ons. For instance:

https://addons.mozilla.org/en-US/firefox/addon/no-close-buttons/

https://addons.mozilla.org/en-US/firefox/addon/tabs-closebutton-restored/

If you think we should change how/where we display tab close buttons by default, that would be a separate discussion (the firefox-dev@mozilla.org mailing list is the right place for that).
Comment 63 User image Aris 2014-07-23 06:40:05 PDT
(In reply to Lukas from comment #61)
> Why on Earth you remove this preference? Now I am closing tabs by mistake.
> Why must you constantly annoy users? You really do everything to put Firefox
> down. :(

You can also use Classic Theme Restorer to restore close buttons previous features: https://addons.mozilla.org/addon/classicthemerestorer/
Comment 64 User image the-edmeister 2014-07-23 13:29:22 PDT
Quite honestly the "browser.tabs.closeWindowWithLastTab" should have been changed to "false" as part of the Bug fix. There is no excuse for closing the window (or exiting Firefox) as a result of accidentally closing the last or sole tab.
Comment 65 User image PimpUigi 2014-07-23 14:16:59 PDT Comment hidden (abusive)
Comment 66 User image Tim Nguyen :ntim 2014-07-23 17:46:19 PDT
(In reply to PimpUigi from comment #65)
> (In reply to the-edmeister from comment #64)
> > Quite honestly the "browser.tabs.closeWindowWithLastTab" should have been
> > changed to "false" as part of the Bug fix. There is no excuse for closing
> > the window (or exiting Firefox) as a result of accidentally closing the last
> > or sole tab.
> 
> Uh, no. That's just as dumb as this bug fix is to begin with.

Note that that was the old behaviour.
Comment 67 User image Andrew N Dowden 2014-07-25 22:05:40 PDT
This is just another reason Mozilla Firefox is lossing market share. While I will still use it, I'm not sure I can continue to recommend it.

I have used this specific feature, set to '1', for so long I had forgeotten where it was. By design (I assume), the developers never really cared whether anyone knew about this feature. I have accidentally closed the wrong tab over twenty times, just in last two weeks.

Keep dumbing down the product, and you will reach 10% market share. (I assume that is your goal.)
Comment 68 User image PimpUigi 2014-07-26 04:44:41 PDT
Maybe we really should just write in to that email posted and ask them to change their default behavior.
I honestly don't see why anyone would close a tab by accident...but all the extra close buttons not only waste space, but they move! A static close tabs button on the end of the close tabs bar is the way to go because you can close five tabs in a row if you want.

You can already middle click a tab to close it if you wanted a close tabs button on a tab. The whole tab is that button!
Comment 69 User image Sylvestre Ledru [:sylvestre] 2014-07-28 02:13:54 PDT
(In reply to PimpUigi from comment #68)
> Maybe we really should just write in to that email posted and ask them to
> change their default behavior.
Indeed. You should write an email on dev-platform ( https://lists.mozilla.org/listinfo/dev-platform ).
You should explain the context, why you think Firefox should have it again, etc.
Comment 70 User image Per Olausson 2014-07-29 05:30:35 PDT Comment hidden (abusive)
Comment 71 User image cousteau 2014-07-29 17:54:42 PDT
(In reply to PimpUigi from comment #68)
> I honestly don't see why anyone would close a tab by accident...
I have done this several times.  This was one of the reasons for me to do this.  I find the close buttons more harmful than useful.  (Actually I don't see them useful at all)

> all the extra close buttons [...] waste space
This was another reason.  My screen is a tiny 1024x768 and I don't want close buttons taking up space. Then again, they only show on the active tab anyway.

> You can already middle click a tab to close it if you wanted a close tabs
> button on a tab. The whole tab is that button!
This was the third reason why I removed the close buttons; I didn't need them anyway.  I guess Firefox is moving towards compatibility with platforms that do not have a middle button, e.g. touchscreens.  But removing this possibility doesn't make sense in my opinion; it just limits the user's customization freedom.

> ask them to change their default behavior.
Probably they should just add an option on the GUI to add/remove the close buttons, rather than removing it from about:config because "it's not in the GUI".

I'm glad someone pointed out the "No Close Buttons" addon, but having to rely on addons to get the behavior that was available before and that made sense is kind of annoying, specially since sometimes these addons are not easy to find.

I don't like the direction the UI design is moving to; it limits the user's freedom to configure the browser without a justified reason other than "it's not available in the GUI and probably nobody used it anyway".  I wish some more flexibility were added to the UI customization.
Comment 72 User image PimpUigi 2014-07-29 18:51:04 PDT
I've emailed them and asked them to change the default behavior.
But I maintain you have to be pretty incompetent to close a tab by accident, no matter what the option, to the point that you have to blame the option. That's like admitting a mental handicap.

Wasted space, yes. Inconsistent close button location, yes. Redundant, yes. Two very annoying things, and one slightly annoying thing.

Email and ask them to change the default behavior with me, but don't be all like "I'm closing my tabs by accident! All your fault!" every single browser on the market works like this. It's not a widespread or even small spread issue.
Comment 73 User image Sylvestre Ledru [:sylvestre] 2014-07-30 00:46:59 PDT
I'm restricting further comments on this bug. Bugzilla isn't intended as a debate forum. If you want to discuss on this, as said previously, please do it on the dev-platform mailing list (you have to register before sending email).

[Comments are restricted to users with the editbugs privilege -- with privilege comes responsibility, so please consider carefully before commenting if you are able.]
Comment 74 User image Matthew N. [:MattN] (PM if requests are blocking you) 2014-07-30 01:35:24 PDT
Actually firefox-dev would be a better forum as this is a Firefox change, not a cross-application one.

https://mail.mozilla.org/listinfo/firefox-dev

Note You need to log in before you can comment on or make changes to this bug.