Last Comment Bug 865997 - Don't prune complex subtrees for roles usually having no children
: Don't prune complex subtrees for roles usually having no children
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla23
Assigned To: alexander :surkov
:
Mentors:
Depends on: 877982
Blocks: treea11y
  Show dependency treegraph
 
Reported: 2013-04-26 00:18 PDT by alexander :surkov
Modified: 2013-05-31 00:35 PDT (History)
1 user (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.50 KB, patch)
2013-04-26 00:18 PDT, alexander :surkov
tbsaunde+mozbugs: review+
Details | Diff | Review

Description alexander :surkov 2013-04-26 00:18:46 PDT
Created attachment 742220 [details] [diff] [review]
patch

Make nsAccUtils::MustPrune smarter (it makes a part of bug Bug 249292 not necessary: http://hg.mozilla.org/mozilla-central/diff/217edac6b29f/accessible/src/base/nsAccUtils.cpp): make it to look into subtree to decide.

The reason is we were reported that we don't expose children in the following case:

<ul aria-label="Account Menu" role="menu navigation" id="userNavigation" class="navigation">
  <li role="menuitem" aria-selected="true">
    <form id="logout_form">
      <label><input type="submit" value="Log Out"></label>
    </form>
  </li>
</ul>
Comment 1 Trevor Saunders (:tbsaunde) 2013-04-29 05:52:23 PDT
Comment on attachment 742220 [details] [diff] [review]
patch

seems ok, though adding the virtual call sucks, use ContentChildAt() maybe, or maybe I should just get around to devirtualizing GetChildAt()

btw have we  considered what it would take to just not create text leaves in these cases?
Comment 2 alexander :surkov 2013-04-29 08:23:42 PDT
(In reply to Trevor Saunders (:tbsaunde) from comment #1)
> Comment on attachment 742220 [details] [diff] [review]
> patch
> 
> seems ok, though adding the virtual call sucks, use ContentChildAt() maybe,

that should be working.

> or maybe I should just get around to devirtualizing GetChildAt()

ideas/plans? Should I care about ContentChildAt() stuff here?

> btw have we  considered what it would take to just not create text leaves in
> these cases?

I guess name computation and text ifrace are broken
Comment 3 Trevor Saunders (:tbsaunde) 2013-05-01 16:17:06 PDT
(In reply to alexander :surkov from comment #2)
> (In reply to Trevor Saunders (:tbsaunde) from comment #1)
> > Comment on attachment 742220 [details] [diff] [review]
> > patch
> > 
> > seems ok, though adding the virtual call sucks, use ContentChildAt() maybe,
> 
> that should be working.

not sure what you mean

> > or maybe I should just get around to devirtualizing GetChildAt()
> 
> ideas/plans? Should I care about ContentChildAt() stuff here?

I think we can just special case tree stuff, but probably won't get to it particularly soon.

> > btw have we  considered what it would take to just not create text leaves in
> > these cases?
> 
> I guess name computation and text ifrace are broken

sounds right
Comment 5 Ryan VanderMeulen [:RyanVM] 2013-05-08 21:37:30 PDT
https://hg.mozilla.org/mozilla-central/rev/898b2c5eaa5d

Note You need to log in before you can comment on or make changes to this bug.