Firefox Facebook Messenger Not showing online user chat list

RESOLVED DUPLICATE of bug 872413

Status

()

Firefox
SocialAPI: Providers
--
major
RESOLVED DUPLICATE of bug 872413
5 years ago
5 years ago

People

(Reporter: iamjayakumars, Unassigned)

Tracking

Trunk
All
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testday-20130426)

Attachments

(5 attachments)

(Reporter)

Description

5 years ago
Created attachment 742465 [details]
Showing - Not Logged In

User Agent: Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130425162858

Steps to reproduce:

Hi, Firefox Beta [testday-20130426]
*Showing "Not logged In" 
*Not showing the online user list
*Chat search user also not working
*No Notification of Chat

But it showing the other updates, above the chat

Attached image
(Reporter)

Updated

5 years ago
Whiteboard: [testday-20130426]
(Reporter)

Updated

5 years ago
Whiteboard: [testday-20130426] → testday-20130426
(Reporter)

Comment 1

5 years ago
Created attachment 742467 [details]
Showing the updates of other users
(Reporter)

Updated

5 years ago
Component: Untriaged → SocialAPI

Comment 2

5 years ago
Confirming this bug. I logged out one day, cannot log back in (even after removing/readding Facebook Messenger, empty cache, etc.)

Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20130425 Firefox/23.0
(In reply to Mathieu Marquer from comment #2)
> Confirming this bug. I logged out one day, cannot log back in (even after
> removing/readding Facebook Messenger, empty cache, etc.)
> 
> Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20130425 Firefox/23.0

Can you please provide steps to reproduce?

Comment 4

5 years ago
* Install Facebook Messenger (FM) from https://www.facebook.com/about/messenger-for-firefox
--> FM is showing on the right part of Firefox
* Click on the FM icon, and select the logout option
--> FM is logged out
* Click on the FM icon, click on the big "Not logged it" button
--> Facebook.com is opened on the default FB page, already logged in
* Click on the FM icon, select "show side bar"
--> Side bar is correctly shown with information from FB as a logged in user, but there is no chat info
* On the bottom right of the side bar, click on "log out"
--> Side bar displays a "logged out" message and a log in" button
* Click on the "Log In" button
--> A FB login page is opened. Once logged in, the side bar still shows the "logged out" message
* Uninstall/reinstall FM, empty cache, delete cookies, etc.
--> Same behavior

Anything else I can provide?

Comment 5

5 years ago
* Click on FM button, select turn off FM, click again, select turn on FM, then show side bar
--> Side bar is correctly shown with information from FB as a logged in user, but there is no chat info (no way to start a chat conversation / see contacts / get a chat message from someone)
Actually I can't even enable FB messenger on first run with a new profile. I'm getting an error in Error Console:

Error: TypeError: this.data.fb_dtsg is undefined
Source File: https://www.facebook.com/desktop/fbdesktop2/socialfox/fbworker.js.php

I think that's what could be causing this and it would appear to be an issue on Facebook's end given the location of the source file.
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: SocialAPI → SocialAPI: Providers
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Version: 21 Branch → Trunk
I am unable to reproduce this. I could have been an interim breakage, take a look to see if it is loading again for you.
(In reply to Shane Caraveo (:mixedpuppy) from comment #7)
> I am unable to reproduce this. I could have been an interim breakage, take a
> look to see if it is loading again for you.

Yup, this is now working for me. Now to test comment 4.
(In reply to Mathieu Marquer from comment #4)
> * Install Facebook Messenger (FM) from
> https://www.facebook.com/about/messenger-for-firefox
> --> FM is showing on the right part of Firefox
> * Click on the FM icon, and select the logout option

I see no log out option under the FB icon, it's under the "gear" icon in the sidebar for me.

> --> FM is logged out
> * Click on the FM icon, click on the big "Not logged it" button
> --> Facebook.com is opened on the default FB page, already logged in

When I do this I am redirected to FB's login page (ie. I'm logged out and need to log back in). After entering my credentials the sidebar reloads.

I've tried this numerous times and the result is always the same.
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 10

5 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #9)
> I see no log out option under the FB icon, it's under the "gear" icon in the
> sidebar for me.

Right, my memory was wrong.

> When I do this I am redirected to FB's login page (ie. I'm logged out and
> need to log back in). After entering my credentials the sidebar reloads.
> 
> I've tried this numerous times and the result is always the same.

I just created a fresh profile, logged into Facebook, then enabled the FM: the timeline in the sidebar is shown correctly, but the FM button still says "not logged in" and the chat functionalities seem to be disabled (chat menu is empty)

See screenshot attached (I can't make a screenshot the the FM button menu, it disappears whenever a screenshot is made)

Comment 11

5 years ago
Created attachment 742688 [details]
Comment #10 - Sidebar - timeline ok, chat ko

Comment 12

5 years ago
Now encountering the same issue on a Windows computer, I didn't even logout from Facebook Messenger, I just noticed this morning it was showing as "not logged in" (although I'm logged in on Facebook).

Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20130428 Firefox/23.0
Thanks, I'm able to reproduce this in the latest Nightly on Windows XP but not on Windows 7. It seems like this issue might be isolated to Windows XP but I'm not sure how that's possible given the error is coming for server-side code.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: All → Windows XP
I can reproduce in Nightly 23.0a1, Aurora 22.0a2, Beta 21.0b4, and Firefox 17.0. Given that I am convinced this is an issue on Facebook's end and not a regression in Firefox.
This is working for me today.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 16

5 years ago
It still showing this error. Facebook contacts are not displayed exactly as detailed above. Is not necesary to log out, eventually, It wont show the contacts. It is presented at least since FF22 to FF25.0a1 and I have Windows 7 on different computers but it does the same in all of them. This bug needs to be RE-OPENED.
(In reply to scorella from comment #16)
> This bug needs to be RE-OPENED.

See bug 872413.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 872413
Created attachment 773710 [details]
Image with Facebook login and Facebook messenger

User Agent : Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130710 Firefox/25.0
Build ID: 20130710030205

It didn't work if I follow below steps.
Tested on Windows 8.1 using latest nightly from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/

Steps to reproduce and Expected result:
1. Install latest nightly build of Firefox and open it.
2. Don't login to Facebook.
3. Activate Facebook Messenger using www.facebook.com/about/messenger-for-firefox You should see Facebook Messenger login page in right column.
4. Click on login and Enter username  and password.
5. After login to Facebook, open new website in new tab. You should see desired website and Facebook newsfeed and online friends list.

Actual result:
After doing step 4 and 5, I can not see Facebook newsfeed and online friends list with desired website.
Created attachment 773711 [details]
Image 2 with Facebook login and Facebook Messenger
You need to log in before you can comment on or make changes to this bug.