Closed Bug 866529 Opened 10 years ago Closed 5 years ago

Not possible to create a folder or separator between two folders in bookmarks sidebar — goes into the selected folder

Categories

(Firefox :: Bookmarks & History, defect, P5)

20 Branch
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: xircal, Unassigned)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image no_separator.png
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

Open the bookmarks sidebar, then choose a folder. Right click the folder and choose "New Separator" from the context menu.


Actual results:

An outline appears around the folder as shown in the screenshot, but no separator. 

A separator can be added between two bookmarks, but not between two folders. 


Expected results:

A separator should appear between the two folders.
Could you test with a new profile, please: 
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(xircal)
21.0 Beta for GNU/Linux.  The separator appears inside the selected folder, just like a new bookmark does.
OS: Windows XP → All
This is like bug 175404 (fixed for Library and Bookmarks Toolbar — strangely, Library's sidebar does not allow creation of separators), but for the sidebar.
Component: Untriaged → Bookmarks & History
Flags: needinfo?(xircal)
Summary: Cannot add a new separator in the sidebar between folders → Not possible to create a folder or separator between two folders in bookmarks sidebar — goes into the selected folder
Status: UNCONFIRMED → NEW
Ever confirmed: true
It's a regression, it works in firefox-3.1a1pre.2008-06-01-02.en-US.linux-i686 (see also bug 407409).
Keywords: regression
Actually it doesn't work in 2008-06-01, two changes have happened.

Objects created near the selected folder:
* 2007-01-01-04-mozilla-central-firefox-3.0a2pre.en-US.linux-i686
* 2008-04-29-03-mozilla-central-firefox-4.0a1pre.en-US.linux-i686
Objects created inside the selected folder, but the folder opens at the same time:
* 2008-04-29-04-trunk-firefox-3.0pre.en-US.linux-x86_64
* 2008-07-08-04-mozilla-central-firefox-3.1a1pre.en-US.linux-x86_64
Objects created inside the selected folder, the folder does not open:
* 2008-07-16-04-mozilla-central-firefox-3.1a1pre.en-US.linux-x86_64
* 2011-02-28-03-mozilla-central-firefox-4.0b13pre.en-US.linux-x86_64
Attached image Tested with new profile
Tested with a new profile as requested. Unfortunately, it didn't make any difference as can be seen in the screenshot.
Work around is to create the selector on the parent folder and then move it into the desired location.
Priority: -- → P5
Hardware: x86 → All
The problem is that if we make the default destination be "before" the folder, like is on the toolbar and on the menus, it becomes impossible to insert into an empty folder in the sidebar, that is an even worse problem.
So, this is not easily fixable.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.