Plugins can no longer be enabled/disabled using addons like QuickJava or FlashDisable

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Markus Popp, Unassigned)

Tracking

({addon-compat})

23 Branch
addon-compat
Points:
---

Firefox Tracking Flags

(firefox22 unaffected, firefox23 affected)

Details

(Reporter)

Description

5 years ago
Due to some change in Firefox 23.0, plugins can no longer be enabled and disabled using addons like QuickJava or FlashDisable.

To reproduce:

install one of these addons:
https://addons.mozilla.org/en-us/firefox/addon/flashdisable/
https://addons.mozilla.org/en-US/firefox/addon/quickjava/

Try to enable or disable Flash using the icons that these addons provide. It won't work. As it works with Firefox 22.0, some update in Firefox 23.0 must have caused it.

(PS: it would be nice if Firefox provided icons to enable/disable common plugins like Flash out of the box, see bug #828819)

Comment 1

5 years ago
Please can you find the regression range using https://github.com/mozilla/mozregression?
Component: General → Add-ons Manager
Flags: needinfo?(markus.popp)
Keywords: regression, regressionwindow-wanted
OS: Linux → All
Product: Firefox → Toolkit
Hardware: x86_64 → All

Comment 2

5 years ago
Tested with add-on FlashDisable.

Regression range:
good=2013-04-11
bad=2013-04-12
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2949e808ed33&tochange=7b8ed29c6bc0

My guess goes to suspected bug:
avid Keeler — bug 854467 - fix nsIPluginTag enabled state API r=bsmedberg r=unfocused
Blocks: 854467
status-firefox22: --- → unaffected
tracking-firefox23: --- → ?
Component: Add-ons Manager → Plug-ins
Flags: needinfo?(markus.popp)
Keywords: regressionwindow-wanted → addon-compat
Product: Toolkit → Core

Updated

5 years ago
status-firefox23: --- → affected
(In reply to Loic from comment #2)
> My guess goes to suspected bug:
> David Keeler — bug 854467 - fix nsIPluginTag enabled state API r=bsmedberg
> r=unfocused

Yes, that is caused by that patch. Plugins are now disabled using:
  pluginTag.enabledState = Ci.nsIPluginTag.STATE_DISABLED;

STATE_ENABLED and STATE_CLICKTOPLAY are the other supported states.
Keywords: regression
tracking-firefox23: ? → ---

Comment 4

5 years ago
Maybe the doc should be updated, or the add-on devs informed?
(In reply to Loic from comment #4)
> Maybe the doc should be updated, or the add-on devs informed?

I CCed Jorge, who should know how to inform add-on devs. I'm not sure if and where we have docs for this.
I flagged bug 854467 for add-on compatibility, which means we will warn developers about it when we do our Firefox 23 compatibility outreach, further down the line. I don't think there's anything else to do in this bug, given that the change is intentional.

Closing as invalid, since we don't fix add-on bugs. Thank you for the heads up.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 7

5 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #6)
> I flagged bug 854467 for add-on compatibility, which means we will warn
> developers about it when we do our Firefox 23 compatibility outreach,
> further down the line. I don't think there's anything else to do in this
> bug, given that the change is intentional.
> 
> Closing as invalid, since we don't fix add-on bugs. Thank you for the heads
> up.

As of note, my addon (QuickJava) did *not* receive a compatibility issue, instead it said it was good and automatically updated to 23 for compatibility.
We did include it in the blog post, but decided not to include it in the automatic compatibility checks.
You need to log in before you can comment on or make changes to this bug.