Open Bug 866623 Opened 7 years ago Updated Last year

Firefox spoils cyrillic text in the Network Monitor response tab

Categories

(DevTools :: Netmonitor, defect, P3)

23 Branch
defect

Tracking

(Not tracked)

REOPENED
Firefox 23

People

(Reporter: ru-vadik, Unassigned)

References

Details

Attachments

(2 files, 9 obsolete files)

Attached image bug_screenshot.png (obsolete) —
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20130428 Firefox/23.0
Build ID: 20130428031010

Steps to reproduce:

1. Nightly Button -> Web Developer -> Network
2. Go to rbc.ru
3. Open "/" File
4. Click on Response


Actual results:

<title>РосБизнесКонсалтинг - новости, акции, курсы валют, погода, доллар, евро</title>


Expected results:

<title>РосБизнесКонсалтинг - новости, акции, курсы валют, погода, доллар, евро</title>
Component: Untriaged → Developer Tools
Component: Developer Tools → Developer Tools: Netmonitor
OS: Windows 7 → All
Priority: -- → P2
Hardware: x86 → All
Assignee: nobody → vporof
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch v1 (obsolete) — Splinter Review
Attachment #743061 - Flags: review?(rcampbell)
Comment on attachment 743061 [details] [diff] [review]
v1

Review of attachment 743061 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/netmonitor/test/sjs_content-type-test-server.sjs
@@ +13,5 @@
>      switch (format) {
> +      case "txt": {
> +        response.setStatusLine(request.httpVersion, 200, "OK");
> +        response.setHeader("Content-Type", "text/plain", false);
> +        response.write("Братан, ты даже поднять?");

Братан, ты даже поднять?
Attachment #743061 - Flags: review?(rcampbell) → review+
Anton, please let us know of this question's grammatical accuracy. I'm afraid I was only able to resort to primitive methods of translation, as all my Russian connections seem to be busy at the moment.
Flags: needinfo?(anton)
Whiteboard: [land-in-fx-team]
This is a very literal translation of, I assume, "Bro, do you even lift?" and, unfortunately, it doesn't make any sense. The word поднять means "to pick up" (as in "pick up a box" but not lift in terms of weightlifting). Anyway, the "bro do you even lift" is a very American thing because in post-Soviet countries we have more pressing problems to deal with such as speeding on highways, wrestling bears and assembling/disassembling AK47 for time.

But if I were to attempt to translate this question I'd make "Братан, ты вообще качаешься?" or "Братан, ты в зал-то ходишь?" (Bro, do you even go to the gym?)

Hope my answer will move the open web forward.
Flags: needinfo?(anton)
Cosmetic criticism: the patch consistently misspells "cyrillic" with only one l.
darn.
Whiteboard: [land-in-fx-team]
Summary: Firefox spoils cyrilic text in the Web Developer Console → Firefox spoils cyrillic text in the Network Monitor response tab
Attached patch v1.1 (obsolete) — Splinter Review
Fixed typo, changed response text.
Attachment #745017 - Flags: review+
good to land?
(In reply to Rob Campbell [:rc] (:robcee) from comment #8)
> good to land?

Needs rebase or landed after bug 859041 :)
Depends on: 859041
https://hg.mozilla.org/mozilla-central/rev/ba062746f3e7
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 23
Attached image Path don't work (obsolete) —
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130516 Firefox/24.0
Patch don't work. See reopen.png.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
:( I'll take a look again.
Attached patch v2 (obsolete) — Splinter Review
Fixed convertToUnicode misbehaving when a request has no attached contentCharset and added more thorough testing.
Attachment #742962 - Attachment is obsolete: true
Attachment #743061 - Attachment is obsolete: true
Attachment #750501 - Attachment is obsolete: true
Attachment #751335 - Flags: review?(rcampbell)
Attached patch v2.1 (obsolete) — Splinter Review
Went through try and this happens on Windows:
IOError: [Errno 2] No such file or directory: u'e:\\builds\\moz2_slave\\try-w32-0000000000000000000000\\build\\browser\\devtools\\netmonitor\\test\\html_\u043a\u0438\u0440\u0438\u043b\u043b\u0438\u0446\u0430-test-page.html' 

(sigh) 

Reverted to a more traditional test filename. This will have to do.
Sorry about the double r? robcee.
Attachment #751335 - Attachment is obsolete: true
Attachment #751335 - Flags: review?(rcampbell)
Attachment #751384 - Flags: review?(rcampbell)
Comment on attachment 751384 [details] [diff] [review]
v2.1

Review of attachment 751384 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/netmonitor/netmonitor-view.js
@@ +716,5 @@
>      domain.setAttribute("value", hostPort);
>      domain.setAttribute("tooltiptext", hostPort);
>  
> +    let waterfall = $(".requests-menu-waterfall", template);
> +    waterfall.style.backgroundImage = this._cachedWaterfallBackground;

This is here because I observed that on http://www.rbc.ru/ very rapid succession of requests render empty waterfalls for a split second (which was to be expected, but I had no idea it could be so ugly in some cases; this shouldn't cause any performance issues).
Attachment #751384 - Flags: review?(rcampbell) → review+
https://hg.mozilla.org/mozilla-central/rev/a82fc9b83ea9
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Depends on: 876111
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130531 Firefox/24.0 - fix don't work.
Attached image os x (obsolete) —
Works for me on OS X, I'll test on Windows shortly. Maybe your nightly isn't up to date?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached image windows (obsolete) —
Just tested on Linux and Windows and it works as expected. I'm marking this bug as FIXED again because I just can't reproduce the problem.

I don't know what to make of your screenshot though.. If you could possibly find a reduced test case and file a new bug, or try a clean profile, that'd be immensely helpful.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
After create new profile cyrilic text is OK. Thanks.
Duplicate of this bug: 892435
Attached image cyrilic_broken.png
Firefox 24 beta1
Mozilla/5.0 (Windows NT 6.2; rv:24.0) Gecko/20100101 Firefox/24.0

Bug not fixed. Firefox be installed on clear Windows. See cyrilic_broken.png.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
You just said in comment #25 that after creating a new profile, it works ok. Also, as per comment #24, from my testing, things seem to work as expected. I'm having a very hard time trying to reproduce this bug.
Assignee: vporof → nobody
Priority: P2 → P3
Сurrently not work. After create new profile too.
Attachment #745017 - Attachment is obsolete: true
Attachment #751384 - Attachment is obsolete: true
Attachment #756950 - Attachment is obsolete: true
Attachment #756961 - Attachment is obsolete: true
Attachment #756975 - Attachment is obsolete: true
Works for me on www.rbc.ru (https://bugzilla.mozilla.org/attachment.cgi?id=788552)
But I also tried actions, described in https://bugzilla.mozilla.org/show_bug.cgi?id=892435 and for
http://www.google.ru/?q=тест
I see
q: "B5AB"
in Params – Query string
("тест" means "test" in Russian too)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.