table cells render background image when background="image" is set in body in xhtml

RESOLVED DUPLICATE of bug 68061

Status

()

--
major
RESOLVED DUPLICATE of bug 68061
17 years ago
4 years ago

People

(Reporter: markushuebner, Assigned: karnaze)

Tracking

({testcase, xhtml})

Trunk
testcase, xhtml
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P2], URL)

Attachments

(7 attachments)

(Reporter)

Description

17 years ago
When going to the URL 
http://www.world-direct.com/gia/test/mozrules.asp
the rendering of the XML data over a XSL stylesheet is completely broken.
The same looks fine in IE.

build 2001061823 on win2k

Comment 1

17 years ago
Hrm. Completely broken? No.
Have that more precise? Or do you expect us to reverse engineer your stylesheet?

Axel
(Reporter)

Comment 2

17 years ago
Certainly not ... the way it should look like is at
http://www.world-direct.com/gia/mozrules2.asp

I am sure you see what I mean :)
Keywords: mozilla0.9.3, nsCatFood
this is certainly not catfood...

Marcus: I've asked you on irc and I'll ask you here: please make a smaller 
testcase. You don't have to and I'm sure that someone will look at this anyway 
sometime. But it's a big stylesheet and I wouldn't be surpriced if there are 
more then one bug lurking in there, so a smaller testcase increases the chance 
of a fix before 0.9.3
Severity: major → normal
Keywords: nsCatFood
(Reporter)

Comment 4

17 years ago
broken refers to: the background image is not displayed correctly, no 
stylesheet applied to text, top image not positioned correctly, table not 
rendered correctly ...

Comment 5

17 years ago
This is simple.
We use XHTML, instead of html, and XHTML is not interpreting the html style
options. Looking at the intended result, I mark this as a dupe of 53030.

Axel

*** This bug has been marked as a duplicate of 53030 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

17 years ago
Things are quite strange ...

http://www.world-direct.com/gia/test/mozrules3.asp
has the right table as well as the table below removed
is displayed okay

http://www.world-direct.com/gia/test/mozrules2.asp
has the right table removed and the table below included
leading to a broken display

http://www.world-direct.com/gia/test/mozrules.asp
including the right table and removind the table below
is also leading to a broken display


Status: RESOLVED → REOPENED
Keywords: testcase
Resolution: DUPLICATE → ---
(Reporter)

Comment 7

17 years ago
Did the original page render in standard mode
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 
4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

and looks also fine
http://www.world-direct.com/gia/test/standard.htm

(Reporter)

Comment 8

17 years ago
does this only appear on win2k ?!

Comment 9

17 years ago
No, I see it on Linux build 2001070106 as well
(Reporter)

Updated

17 years ago
Severity: normal → major
Keywords: correctness
OS: Windows 2000 → All

Updated

17 years ago
Priority: -- → P5
(Reporter)

Comment 10

17 years ago
Do you need more testcases or something changed to help in development?
The smaller the better... And when it comes to tables it's always much easier 
to see what's going on if you don't hide the border.
(Reporter)

Comment 12

17 years ago
Every table is now visible.
There are several testcases now starting from very small.
Might the rewrite of the output for transform have an impact on this?

Comment 13

17 years ago
This is not an XSLT bug, but an xhtml display problem.
Trying layout component for further work.

I will attach two testcases, one xml, one html. The xml one has a awkward
white bar right below the image, no idea where that comes from, document
inspector doesn't map that area to anything
Assignee: kvisco → karnaze
Severity: major → normal
Status: REOPENED → NEW
Component: XSLT → Layout
Keywords: correctness, mozilla0.9.3
QA Contact: kvisco → petersen
Summary: Rendering problems with XML/XSL → Rendering problems with table in xhtml

Comment 14

17 years ago
Created attachment 43542 [details]
html version of testcase (good)

Comment 15

17 years ago
Created attachment 43543 [details]
xml version of testcase (bad bar)
(Reporter)

Comment 16

17 years ago
Adding keywords and major again.
Severity: normal → major
Keywords: mozilla0.9.4, xhtml
Priority: P5 → --
Hardware: PC → All
The bug is INVALID. We render the XHTML test case as per the specs. One of the
differences between XHTML and HTML4 is the background of the <body> does not
stretch across the canvas in XHTML. (I have spoken to the chairman of the HTML
working group to check this. He was very clear this.)

If you want to use XHTML, then use XHTML Strict with CSS, and set the background
on the <html> element not the <body> element.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 18

17 years ago
Reopening since this bug is not just about the body background rendering.
This bug has a great impact since it will affect all pages that are rendered 
using XML/XSL.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Ok, so *what is the bug*? If this is an XSL bug, it needs to go to the XSL
component and a minimised test case (less than one kilobyte total) needs to be
created showing the problem. If this is an XHTML issue, then it needs to be 
simplified so that none of the XSL is present (again, a test case of less than
one kilobyte is required).

Without testcases, there is very little chance that anything can be fixed, since
there is no-one who knows all of XSLT, XHTML and CSS well enough to diagnose
the bug from the current page.

Removing testcase keyword since the only testcases provided (the attachments)
are apparently not what the bug is about, and removing xhtml keyword since there
is no evidence that this is an XHTML bug.
Keywords: testcase, xhtml → qawanted
Whiteboard: need testcases

Comment 20

17 years ago
Hey Hixie,
a bit more precise:
I don't worrry about the body fixup rule.
I made a screenshot, and marked the offending area with red arrows.
There is a bar in light grey beneath the image, within the darker grey body.
Sorry, the "white" in my comment was rather misleading.
The attachements show the behaviour, so it's not a XSLT issue.
If you agree, please reset the status.
I suspect the large testcases to show the same bug, just in more detail/colors.

Axel

Comment 21

17 years ago
Created attachment 43651 [details]
screenshot, offending area marked

Comment 22

17 years ago
Created attachment 43653 [details]
xml file, showing the background image in td's?

Comment 23

17 years ago
Is this just a different symptom of bug 68061?

The background image is rendered in the TD, 29 line testcase coming up.
I didn't cut it down to a minimum, the bug got less obvious then.

Axel

(getting back all our glorious keywords)
Keywords: qawanted → testcase, xhtml
Whiteboard: need testcases

Comment 24

17 years ago
Created attachment 43654 [details]
29 lines of td and background trouble

Comment 25

17 years ago
->tables
Status: REOPENED → NEW
Component: Layout → HTMLTables
Keywords: xhtml
QA Contact: petersen → amar
Whiteboard: [Hixie-P2]

Comment 26

17 years ago
I'll add a valid testcase to demonstrate the bug
Keywords: xhtml

Comment 27

17 years ago
Created attachment 44537 [details]
testcase that uses xhtml trnasitional dtd declaration

Updated

17 years ago
Summary: Rendering problems with table in xhtml → table cells render background image when background="image" is set in body in xhtml
(Reporter)

Comment 28

17 years ago
any progress on this one?!
Created attachment 47811 [details]
Wrap in a tbody and it works
(Reporter)

Comment 30

17 years ago
good to know a workaround exists - thx peterv!
anyway, hope it's getting in soon.
Very similar as bug 68061, maybe even dup.
Keywords: mozilla0.9.4
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.5
(Reporter)

Comment 32

17 years ago
What's the current status of this?
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.6

*** This bug has been marked as a duplicate of 53944 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
actually...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
... It's a dup of this one

*** This bug has been marked as a duplicate of 68061 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.