crash in mozilla::dom::AudioContext::GetJSContext

RESOLVED DUPLICATE of bug 866108

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 866108
6 years ago
6 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

23 Branch
All
Windows 7
Points:
---

Firefox Tracking Flags

(firefox22 unaffected, firefox23 affected)

Details

(crash signature)

It first showed up in 23.0a1/20130427. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a6104e0e5a2c&tochange=0e45f1b9521f
It might be caused by http://hg.mozilla.org/mozilla-central/rev/7c244b521e54.

Signature 	mozilla::dom::AudioContext::GetJSContext() More Reports Search
UUID	874c3daf-8bad-452f-ac4f-8811e2130428
Date Processed	2013-04-28 18:43:08
Uptime	116
Last Crash	more than 3 months before submission
Install Age	1.9 minutes since version was first installed.
Install Time	2013-04-28 18:41:00
Product	Firefox
Version	23.0a1
Build ID	20130428031010
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 23 stepping 6
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x9581, AdapterSubsysID: 30c5103c, AdapterDriverVersion: 8.850.0.0
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ WebGL? EGL? EGL+ GL Context? GL Context+ WebGL+ 
Processor Notes 	sp-processor05.phx1.mozilla.com_19953:2012
EMCheckCompatibility	True
Adapter Vendor ID	0x1002
Adapter Device ID	0x9581
Total Virtual Memory	4294836224
Available Virtual Memory	3225526272
System Memory Use Percentage	71
Available Page File	4983857152
Available Physical Memory	1218576384

Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::dom::AudioContext::GetJSContext 	content/media/webaudio/AudioContext.cpp:353
1 	xul.dll 	`mozilla::dom::ScriptProcessorNodeEngine::SendBuffersToMainThread'::`4'::Command 	content/media/webaudio/ScriptProcessorNode.cpp:293
2 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
3 	xul.dll 	NS_ProcessNextEvent 	obj-firefox/xpcom/build/nsThreadUtils.cpp:238
4 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:82
5 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:212
6 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:186
7 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
8 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:113
9 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:289
10 	xul.dll 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3879
11 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3946
12 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:4158
13 	firefox.exe 	do_main 	browser/app/nsBrowserApp.cpp:271
14 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:105
15 	firefox.exe 	__tmainCRTStartup 	crtexe.c:552
16 	kernel32.dll 	BaseThreadInitThunk 	
17 	ntdll.dll 	__RtlUserThreadStart 	
18 	ntdll.dll 	_RtlUserThreadStart 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Adom%3A%3AAudioContext%3A%3AGetJSContext%28%29
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 866108
You need to log in before you can comment on or make changes to this bug.