Intermittent webspeech/recognition/test/test_success_without_recognition_service.html,test_timeout.html,test_call_start_from_end_handler.html | application crashed [@ mozilla::dom::AudioContext::GetJSContext() const]

RESOLVED FIXED in mozilla23

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: RyanVM, Assigned: Ehsan)

Tracking

({crash, intermittent-failure})

unspecified
mozilla23
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

Reporter

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=22282690&tree=Mozilla-Inbound

Android Armv6 Tegra 250 mozilla-inbound opt test mochitest-2 on 2013-04-26 06:24:54 PDT for push 1f53f6fc47f0
slave: tegra-261

28265 INFO TEST-START | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html
28266 INFO TEST-INFO | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | requesting EVENT_START
28267 INFO TEST-INFO | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | requesting EVENT_AUDIO_DATA
28268 INFO TEST-INFO | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | Queuing event EVENT_RECOGNITIONSERVICE_FINAL_RESULT until we're done sending audio data
28269 INFO TEST-PASS | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | received event audiostart
28270 INFO TEST-PASS | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | received event start
28271 INFO TEST-PASS | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | received event speechstart
28272 INFO TEST-PASS | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | received event speechend
28273 INFO TEST-PASS | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | speechend must come after speechstart
28274 INFO TEST-PASS | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | received event audioend
28275 INFO TEST-PASS | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | audioend must come after audiostart
INFO | automation.py | Application ran for: 0:17:42.684985
INFO | zombiecheck | Reading PID log: /tmp/tmp6KIgmopidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-armv6/1366977596/fennec-23.0a1.en-US.android-arm-armv6.crashreporter-symbols.zip
mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-armv6/1366977596/fennec-23.0a1.en-US.android-arm-armv6.crashreporter-symbols.zip
PROCESS-CRASH | /tests/content/media/webspeech/recognition/test/test_success_without_recognition_service.html | application crashed [@ mozilla::dom::AudioContext::GetJSContext() const]
Crash dump filename: /tmp/tmp4zte1j/3001c77e-af0d-867b-43b3c9a5-1ee89bcc.dmp
Operating system: Android
                  0.0.0 Linux 2.6.32.9-00002-gd8084dc-dirty #1 SMP PREEMPT Wed Feb 2 11:32:06 PST 2011 armv7l nvidia/harmony/harmony/harmony:2.2/FRF91/20110202.102810:eng/test-keys
CPU: arm
     2 CPUs

Crash reason:  SIGSEGV
Crash address: 0x0

Thread 5 (crashed)
 0  libxul.so!mozilla::dom::AudioContext::GetJSContext() const [nsIScriptGlobalObject.h:1f53f6fc47f0 : 62 + 0x0]
     r4 = 0x4f00e77c    r5 = 0x59cb1380    r6 = 0x4f00e7ec    r7 = 0x515ffcd0
     r8 = 0x00000001    r9 = 0x4ec2b5ac   r10 = 0x4f00e81f    fp = 0x0024c000
     sp = 0x4f00e778    lr = 0x546ad44c    pc = 0x53e69d7c
    Found by: given as instruction pointer in context
 1  libnss3.so!PR_Unlock [ptsynch.c:1f53f6fc47f0 : 205 + 0x2]
     sp = 0x4f00e7a8    pc = 0x50f93610
    Found by: stack scanning
 2  libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:1f53f6fc47f0 : 627 + 0xa]
     sp = 0x4f00e7d8    pc = 0x546e216c
    Found by: stack scanning
 3  libxul.so!NS_ProcessNextEvent(nsIThread*, bool) [nsThreadUtils.cpp:1f53f6fc47f0 : 238 + 0x12]
     sp = 0x4f00e818    pc = 0x546b1250
    Found by: stack scanning
 4  libxul.so!mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) [MessagePump.cpp:1f53f6fc47f0 : 82 + 0xa]
     sp = 0x4f00e828    pc = 0x543dd85c
    Found by: stack scanning
 5  libxul.so!MessageLoop::RunInternal() [message_loop.cc:1f53f6fc47f0 : 219 + 0xa]
     sp = 0x4f00e850    pc = 0x54728368
    Found by: stack scanning
 6  libxul.so!MessageLoop::Run() [message_loop.cc:1f53f6fc47f0 : 212 + 0x6]
     sp = 0x4f00e858    pc = 0x547284e4
    Found by: stack scanning
Trying to get a JSContext on thread 5 seems bad.
Assignee

Comment 2

6 years ago
(In reply to Andrew McCreight [:mccr8] from comment #1)
> Trying to get a JSContext on thread 5 seems bad.

It does, doesn't it?  :-)
Assignee: nobody → ehsan
Assignee

Comment 3

6 years ago
It's actually not necessarily bad, since this is Android and the Gecko main thread will not be thread 1.

That being said, this stack provides absolutely no useful information at all.
Assignee: ehsan → nobody
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #3)
> It's actually not necessarily bad, since this is Android and the Gecko main
> thread will not be thread 1.
Oh, interesting!
Reporter

Comment 5

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=22290436&tree=Mozilla-Inbound
Summary: Intermittent webspeech/recognition/test/test_success_without_recognition_service.html | application crashed [@ mozilla::dom::AudioContext::GetJSContext() const] → Intermittent webspeech/recognition/test/test_success_without_recognition_service.html,test_timeout.html | application crashed [@ mozilla::dom::AudioContext::GetJSContext() const]
Comment hidden (Legacy TBPL/Treeherder Robot)
https://tbpl.mozilla.org/php/getParsedLog.php?id=22311545&tree=Mozilla-Inbound
Summary: Intermittent webspeech/recognition/test/test_success_without_recognition_service.html,test_timeout.html | application crashed [@ mozilla::dom::AudioContext::GetJSContext() const] → Intermittent webspeech/recognition/test/test_success_without_recognition_service.html,test_timeout.html,test_call_start_from_end_handler.html | application crashed [@ mozilla::dom::AudioContext::GetJSContext() const]
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 12

6 years ago
Posted patch Patch (v1)Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #742728 - Flags: review?(paul)
Assignee

Updated

6 years ago
Duplicate of this bug: 866079
Assignee

Comment 14

6 years ago
Posted patch Part 2Splinter Review
Attachment #742754 - Flags: review?(paul)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Attachment #742728 - Flags: review?(paul) → review+
Attachment #742754 - Flags: review?(paul) → review+
Assignee

Updated

6 years ago
Duplicate of this bug: 866722

Updated

6 years ago
Crash Signature: [@ mozilla::dom::AudioContext::GetJSContext() const] [@ mozilla::dom::AudioContext::GetJSContext()]
Comment hidden (Legacy TBPL/Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/bad7e6827695
https://hg.mozilla.org/mozilla-central/rev/217a16890daa
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Assignee

Updated

6 years ago
Duplicate of this bug: 866839
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 25

6 years ago
Mass moving Web Audio bugs to the Web Audio component.  Filter on duckityduck.
Component: Video/Audio → Web Audio
You need to log in before you can comment on or make changes to this bug.