Closed Bug 866863 Opened 8 years ago Closed 7 years ago

Land new pretty icons for the Panel menu widgets

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: jaws, Assigned: mconley)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M5])

Attachments

(3 files, 6 obsolete files)

Currently we are using extremely upscaled images for the menu panel's widgets, but we'll need some pretty icons before we can ship the new Australis menu.

Stephen, can you take point on this? Either upload the icons here or put together a patch?
Does this also cover changing Linux icons ?
Assignee: shorlander → jaws
Attached patch WIP v1 (obsolete) — Splinter Review
This is the start, but it's missing icons for: Add-ons, Open File, Save(currently a blank page, but should it be a floppy disk?), Downloads, Home, Reload, Bookmarks, Stop, Full Screen

Here's a screenshot with the new icons, http://screencast.com/t/Dofh4n5RVOJ
Duplicate of this bug: 868704
there is no 'save' button, and the current customize does not look pretty like that. the current customize does not look like any of the specs/fake drawings. are there builds I am missing (I am on UX), or did you Just Photoshop it. also, the customize menu does NOT center on lower resolutions, it just stays where it is. the buttons also do not look like that. yet the image looks real...
???
(In reply to rexyrexy2 from comment #4)
> there is no 'save' button, and the current customize does not look pretty
> like that. the current customize does not look like any of the specs/fake
> drawings. are there builds I am missing (I am on UX), or did you Just
> Photoshop it. also, the customize menu does NOT center on lower resolutions,
> it just stays where it is. the buttons also do not look like that. yet the
> image looks real...
> ???

The patch here hasn't landed yet.
No longer blocks: 855287
Whiteboard: [Australis:M5]
Steven says he's still working on 2 and busy with Metro workweek stuff, but might be able to get to it today.
Flags: needinfo?(shorlander)
Attached file Menu Panel Icons - i01 (obsolete) —
ZIP file with the icons for the menu panel
Flags: needinfo?(shorlander)
Attached patch Patch (obsolete) — Splinter Review
I've left Linux out of this since we still haven't figured out what we're gonna do there (need a mix of some new icons, upscaled ones, etc).
Attachment #747029 - Attachment is obsolete: true
Attachment #750667 - Flags: review?(mconley)
Comment on attachment 750667 [details] [diff] [review]
Patch

Hey Jared,

The code looks fine - but when I drag any of those items (the "Find" widget, for example) to the nav-bar, I see the entire toolbar spritesheet - ex: http://i.imgur.com/7CPJlCR.png

I only tried Windows.

-Mike
Attachment #750667 - Flags: review?(mconley)
Attached patch Patch v1.1 (obsolete) — Splinter Review
This patch includes a temporary hack to scale down the pretty icons if the widgets are placed in the toolbar. We'll need to get Toolbar.png updated to include the actual icons, but I don't want that to block this.
Attachment #750667 - Attachment is obsolete: true
Attachment #751083 - Flags: review?(mconley)
Comment on attachment 751083 [details] [diff] [review]
Patch v1.1

So I hate to make you do more here, but this kinda really busts things up on Linux because all of the icons are gone.

I know we're waiting on the spritesheet for Linux, so I think in the meantime, a dummy icon (as you suggested in IRC) would be good.

For OSX, I've noticed that the icons are scaled down when they're in the menu panel or the palette.  When in customization mode, if I "grab" an icon, it scales up and looks crisp.

Also for OSX - the bookmark icon is missing.

So, the code looks good, but I think we're going to want a few changes before landing.
Attachment #751083 - Flags: review?(mconley)
Yoink
Assignee: jaws → mconley
Attached patch Patch v1.2 (obsolete) — Splinter Review
I'm opting to not scale the large icons by 0.5 when in the toolbar. That seems to be causing some weirdness with all of the other toolbars (clicking on them causes them to "squish" down in their pressed state).

Leaving them big makes it more obvious what work there is left to do, whereas the "squish" effect doesn't really make it obvious what is causing the problem. So there's my justification.

Anyhow, we're gonna need those small icons at some point. I'll file a bug for that.

I've also gotten rid of the toolbar icon max-width and max-height that was calculated. That was forcing us to resize the icons and made them fuzzy on OSX. Gonna check out how this looks on Windows and Linux and then request review.
Attachment #751083 - Attachment is obsolete: true
Attached patch Patch v1.3 (obsolete) — Splinter Review
So I didn't want to create a bunch of temporary rules for Linux to deal with the fact that we don't have icons, so I just copied over OSX's icons as a stopgap. I can file a bug to replace the graphic.
Attachment #752300 - Attachment is obsolete: true
Comment on attachment 752390 [details] [diff] [review]
Patch v1.3

So, here's what I did:

1) I've eased up on some of the toolbarbutton icon rules so that we don't have fuzzy icons on OSX
2) I've copied over OSX's icons over to the Linux GTK theme as a stopgap until we can get icons there
3) For the icons on Linux that didn't originally have a spritesheet (like the cut and copy buttons), I've given those rules !important for now. They're going to get torn out when those individual buttons get removed, so this is just temporary.
Attachment #752390 - Flags: review?(jaws)
Comment on attachment 752390 [details] [diff] [review]
Patch v1.3

Review of attachment 752390 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/linux/browser.css
@@ +670,5 @@
>  }
>  
> +
> +#bookmarks-button {
> +  list-style-image: url("chrome://browser/skin/Toolbar.png") !important;

Can you add comments about these !important usages and reference the bug to remove them?

::: browser/themes/windows/jar.mn
@@ +29,5 @@
>          skin/classic/browser/customizableui/customizeMode-separatorHorizontal.png  (customizableui/customizeMode-separatorHorizontal.png)
>          skin/classic/browser/customizableui/customizeMode-separatorVertical.png  (customizableui/customizeMode-separatorVertical.png)
> +        skin/classic/browser/customizableui/menuPanel-icons.png        (customizableui/menuPanel-icons.png)
> +        skin/classic/browser/customizableui/menuPanel-small-icons.png  (customizableui/menuPanel-small-icons.png)
> +        skin/classic/browser/engineManager.css

engineManager.css still needs the preprocesser directive ("*") at the beginning of the line because the file includes %if 0 and %endif to comment out the license header.
Attachment #752390 - Flags: review?(jaws) → review+
Addressing jaws' comments.
Attachment #752390 - Attachment is obsolete: true
Attachment #752423 - Flags: review+
Landed on UX as https://hg.mozilla.org/projects/ux/rev/6eda5fb78959
Whiteboard: [Australis:M5] → [Australis:M5][fixed-in-ux]
Depends on: 875163
When moving some buttons to the nav-bar, they preserve the size supposed to be used in the panel instead of the 16x16 one. Here is the screenshot:

http://www.dropmocks.com/iBtMDT

Only tested on Windows 7
For consistency in the panel menu and in the homepage the icon should be the same for preferences and with the same name
https://hg.mozilla.org/mozilla-central/rev/6eda5fb78959
https://hg.mozilla.org/mozilla-central/rev/95c1125909b9
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M5][fixed-in-ux] → [Australis:M5]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.