[Calendar][User Story] Direct event creation at specific date/time

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: pdol, Assigned: gaye)

Tracking

({feature, relnote})

unspecified
1.1 QE2 (6jun)
x86
Gonk (Firefox OS)
feature, relnote
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18+ verified)

Details

(Whiteboard: c=, relnote-b2g:1.1+, URL)

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
UCID: Calendar-052

User Story:
As a user, I would like to be able to add an event to the calendar to a specific date/time, with a one hour duration, without having to first create an event and manually selecting the start time, in order to make event creation much quicker.

Updated

6 years ago
Depends on: 861226
(Assignee)

Updated

6 years ago
Assignee: nobody → gaye

Comment 1

6 years ago
Created attachment 743950 [details]
UX for adding events from a day and time when there are no existing events.

Comment 2

6 years ago
Created attachment 743953 [details]
UX for adding events from a day and time when there *are* existing events

The "existing_events" PDF shows how quick-add should work if the user already has a booking in a specific time slot. 

The "no events" PDF shows that if the user taps on the margin with the time, it should do the same thing as it would if the user had hit the "correct" time spot.
(Assignee)

Updated

6 years ago
Depends on: 869216
(Assignee)

Updated

6 years ago
No longer depends on: 869216
(Assignee)

Comment 3

6 years ago
Created attachment 747073 [details]
Pull request
Attachment #747073 - Flags: review?(kgrandon)
(Assignee)

Updated

6 years ago
Attachment #747073 - Attachment mime type: text/plain → text/html

Updated

6 years ago
tracking-b2g18: --- → +

Updated

6 years ago
Whiteboard: c=

Updated

6 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

6 years ago
Keywords: feature
Comment on attachment 747073 [details]
Pull request

Review is done. Just two small issues I found in the pull request (bubbling and back flow). After those are resolved I think we can land.
Attachment #747073 - Flags: review?(kgrandon)
(Assignee)

Comment 5

5 years ago
Created attachment 749130 [details]
Pointer to Feature Video
(Assignee)

Updated

5 years ago
Attachment #749130 - Attachment mime type: text/plain → text/html
(Assignee)

Comment 6

5 years ago
Hey All,

Went ahead and made a video of me playing around with the tap to create feature. Let me know if this looks good for the first pass :).
Flags: needinfo?(pdolanjski)
(Reporter)

Comment 7

5 years ago
(In reply to gaye from comment #6)
> Went ahead and made a video of me playing around with the tap to create
> feature. Let me know if this looks good for the first pass :).

Looks solid!  Nice work.
Flagging UX for review.
Flags: needinfo?(pdolanjski) → needinfo?(firefoxos-ux-bugzilla)
Attachment #747073 - Flags: review+
Landed in master: https://github.com/mozilla-b2g/gaia/commit/9547f81c98f77c58e4d2d52c91906d1845f7cf81
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

5 years ago
Created attachment 751110 [details]
Uplift Request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Tap to create feature request
User impact if declined: They won't have this beautiful feature! (Which LG requested)
Testing completed: All of the javascript is unit-tested and both kgrandon and I have tried this out on devices.
Risk to taking this patch (and alternatives if risky): The feature was well tested and contained to the day view so I think the risk is pretty low.
String or UUID changes made by this patch: None
Attachment #751110 - Flags: approval-gaia-v1?
This is going to require QA signoff to get uplift on a non-blocking feature. I'll try to look into this when some of 1.01 fires calm down a bit.
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: qawanted
QA Contact: jsmith
(Assignee)

Comment 11

5 years ago
Cyee just gave a thumbs up for ux with the caveat that a hit-state when we tap on the time slot would be a nice to have.

Comment 12

5 years ago
Looks great! :)
Comment on attachment 751110 [details]
Uplift Request

Let's let this ship in v1.2 - fairly major enhancement for where we are in the release.
Attachment #751110 - Flags: approval-gaia-v1? → approval-gaia-v1-
Pulling qawanted since uplift isn't going to happen here.
Keywords: qawanted

Updated

5 years ago
blocking-b2g: --- → leo+
(Assignee)

Updated

5 years ago
Attachment #751110 - Flags: approval-gaia-v1- → approval-gaia-v1?
(Assignee)

Comment 15

5 years ago
leo+ < = > approval-gaia-v1+ ?
Comment on attachment 751110 [details]
Uplift Request

If you've got a leo+, then you don't need approval. You get approval by default if it's a leo+.
Attachment #751110 - Flags: approval-gaia-v1?

Updated

5 years ago
Flags: in-moztrap?(jsmith)
Keywords: verifyme
(Assignee)

Comment 17

5 years ago
Uplifted 9547f81c98f77c58e4d2d52c91906d1845f7cf81 to:
v1-train: e5712b2a55cd4785142c01529048a5a5c84f22da
status-b2g18: --- → fixed

Updated

5 years ago
Duplicate of this bug: 813149

Updated

5 years ago
Flags: in-moztrap?(jsmith) → in-moztrap+
Target Milestone: --- → 1.1 QE2 (6jun)
lgtm on 6/6 unagi b2g18 build. Very robust, no issues found running through the day view on a few days and tapping to add events on hour & all-day event blocks.
status-b2g18: fixed → verified
Keywords: verifyme
Keywords: relnote
Whiteboard: c= → c=, relnote-b2g:1.1+
You need to log in before you can comment on or make changes to this bug.