Closed Bug 86707 Opened 20 years ago Closed 20 years ago

Browser doesn't launch right after migration from 4.72

Categories

(Core Graveyard :: Profile: Migration, defect)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: ji, Assigned: ccarlen)

References

Details

(Keywords: platform-parity, regression)

Build: 06/18 trunk 

Browser doesn't launch right after migration from 4.72. It exits after a flash
of activation page. You can launch it the second time with the same profile.

Steps to reproduce:
1. Remove .netscape and .mozilla directory
2. Launch  Communicator 4.72 and quit it after use.
3. Lauch NS 6.1. After the convertion of profile is finished, the activation
page comes up, but just a flash, then the browser exits.
I see the same thing on Win32 with migrating my 4.72 profile...but don't get a
flash of activation page.The browser just never starts, though the Netscp6.exe
process shows it's running in Tsk Manager on WinNT. A new profile will start
browser however on Win.(win32 2001-06-20-06Trunk)

On Linux, for me, the browser would not start with either  a new or migrated
profile. I had to use a good profile from the Linux 2001-06-19-14Trunk build to
launch todays (linux 6-20-08Trunk) browser  successfully on linux.

Mac was ok with todays builds using both new profiles or Migrated ones.(mac
2001-06-20-04Trunk)

In all cases I used a full install of the product into a fresh directory, and
remove the profiles and registry files to simulate a new (fresh) install.
Nominating nsbeta1 for high visibility.
Severity: normal → critical
Keywords: nsbeta1, pp, regression
OS: Linux → All
Hardware: PC → All
er, or is that an rtm nomination... :-\
Keywords: rtm
I am seeing the same behavior as scalkins on Mac and Linux (logged bug 86922 for 
the Linux) 
I am able to launch on Win but do not see activation (isn't that bug 6573?)
using migrated 4.x profiles (tried with 2 profiles)
I saw this yesterday.  When a new profile is made, we seem to go into -turbo
mode, and you have to start it again to get the window to show (like -turbo). 
To ccarlen@netscape.com to investigate.  I'm fairly sure there is a dupe of
this, I'll start looking.
Assignee: racham → ccarlen
today, on win builds, a new profile won't launch browser either. I went back to
a profile I had in 6.1 beta release and only then can i start the broswer
Looks like we're talking about commercial here. With commercial, making a new
profile or migrating a profile will lead to activation and in that case, doom.
That bug is http://bugscape.mcom.com/show_bug.cgi?id=6758
Status: NEW → ASSIGNED
ccarlen: could this have to do with 86902?
> ccarlen: could this have to do with 86902?

I doubt it. I have not found bug 86902 to happen. Also, since bug 86902 was with
mozilla, not ns6 (tell me if I'm wrong), I don't tink it's related to this.
86902 definitely happens, make sure you're trying it with a new profile.  Also, 
it happens on commercial, the question is whether it happens on Mozilla.
If it happens on commercial, it's a different story. Any new profile activity on
commercial is doomed by http://bugscape.mcom.com/show_bug.cgi?id=6758.

As far as bug 86902, I have not been able to reproduce it with mozilla. If
somebody could confirm that, it would be good.
new profile- does not happen on mozilla
Is there a reason this has no milestone and hasn't been triaged yet? Just curious..
Keywords: rtmnsBranch
Because it's probably a dup of bug 86922. Between bug 86922 (better go in today)
and http://bugscape.mcom.com/show_bug.cgi?id=6758 (checked in) automigration and
activation were horked. When 86922 goes in, this will be fixed. I've tested it.
Whether it's a dup, invalid, or what, I'd rather just wait until that point and
say its fixed or WFM.
I am seeing something very simular in mozilla 2001062509/
1. Delete mozilla profiles
2. Run mozilla -installer.
3. Select netscape profile for migration..
4. If you doubleclick on a profile it will migrate but not launch or appear as 
migrated in profile manager. If you select profile and click start mozilla, it 
will migrate and start. This is old behavior from a long ago time.
I think this bug has morphed into bug 88893
It no longer happens on Win and Mac (since bug 6758 and bug 86922 were fixed)

Need to check last comments- double clict before marking duplicate
I still see this problem with todays branch builds with this test case, only the
activation dialog no longer flashes after the convert dialog appears. The
browser never launches after the convert profile status bar disappears.
The last message in the console I see is "Inside Migrate Profile Routine". 
I have RH 6.1 with Gnome desktop

Linux 2001-07-09-04Brnch
Any chance it'll be fixed for rtm?
Suzanne, what kind of install?   See also bug 89488
yeah, I always do a full/clean install , so sun java would be in there.
So this is  a depends on that one?
Retested this with 07/24 branch build. Browser doesn't launch right after 
migration from 4.72. It seems fix for bug 89488 has fixed this bug.
On my above comments, "Browser doesn't launch right after migration from 4.72"
should be read as "Browser does launch right after migration from 4.72". Sorry 
for the typo.
I was wondering about that :-) So, can we close this one?
Blocks: 99194
Not seeing this anymore either
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.