Open Bug 86758 Opened 22 years ago Updated 4 years ago

Cannot Toggle Status Bar when hidden from javascript

Categories

(Core :: DOM: UI Events & Focus Handling, enhancement, P3)

enhancement

Tracking

()

mozilla1.9alpha8

People

(Reporter: tpowellmoz, Unassigned)

References

(Depends on 1 open bug)

Details

As far as I can tell, in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:0.9.1+) Gecko/20010613 there is no way to toggle the statusbar with the
keyboard. In Netscape 4.x this was supported with Ctrl+Alt+S. It would be very
nice if this was supported in Mozilla. 

I'm primarily concerned with the situation where JavaScript windows are opened
without the status bar, menu bar, and toolbar. This makes it difficult to
determine when the page is finished loading or what's wrong. Being able to pop
up the status bar at least lets you see if there's something wrong and if the
page is still loading. (For example, you could see Class not found Java errors)

It's unclear to me why bug 18768 was resolved wontfix. It didn't resolve the RFE
as far as I can tell. It seems that was interpreted as a need for minimal
chrome. I actually want the option to turn ON the status bar in certain
situations, but I don't want to override it across the board. I'm less concerned
about what keyboard combination is used (apparently double modifiers such as
Ctrl+Alt are generally no-nos). However, because Nav 4.x used Ctrl+Alt+S, I'd
suggest the same key combo.
I agree about the Javascript opened windows.  Being able to see some sort of
loading status would really help.
->aaronl, for the nonce.
Assignee: alecf → aaronl
Keywords: 4xp
Whiteboard: DUPEME
i don't think this is a dup... there's of course bug 18768, but i don't *think*
this should be dupped for that since this isn't asking only for ctrl+alt+S
--this one seems more like a general request to find/have a shortcut for
toggling the keyboard. okay, i'm rambling...what does aaronl/other folx think of
this?
Whiteboard: DUPEME
I don't think it's very important to have a keyboard shortcut for toggling the
status bar, because it's not done very often, and the option is already
keyboard-accessible using menus.  If you're trying to get screen extra
real-estate, see bug 68136, which would add a full-screen mode.  If you're
trying to convert pop-up windows into normal browser windows, bug 69099 would
let you get a menu bar in a pop-up window by pressing F10 or by getting a
context menu and choosing "show menu bar" (normally hidden).
Jesse, you may not use this very often, but I use it frequently both as a web 
developer and user. I don't see how it harms anything to have a convenient 
keyboard shortcut to toggle the statusbar. Apparently the developers for 
Netscape 4.x thought it was pretty important. Contrary to what you say, the 
option is not available from menus in the exact situation where it's wanted 
(and as described by this bug).

If I understand what's being proposed in bug 69099, I'd have to press F10, down 
arrow to the appropriate point in the context menu, turn on the menu bar, press 
Alt+V to trigger the view menu, press down arrow, and right arrow to get to the 
Hide/Show submenu, and eventually toggle the status bar. And then it's unclear 
if there'd be any way to turn off the menubar again. Even if the menu items 
just worked when triggered on Alt, pressing the key sequence Alt+V,W,S is 
pretty hard to remember. Needless to say, this is not at all convenient.
I agree with Jesse. Alt+V W S is plenty convenient.
Yes, it's hard to remember if you don't do it very often.
If you do it all the time, it's easy to remember.

There's a lot of harm in using up hotkeys for everything.
As you can see in
http://www.mozilla.org/projects/ui/accessibility/mozkeyplan.html, there are very
few hotkeys left. Ctrl+Alt keys are not acceptible, at least in our current
thinking. I think some hotkey for full screen mode will suffice.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WONTFIX
Read my comments above about why Alt+V,W,S is unacceptable. This key sequence 
does exactly nothing when a new window has been launched that has no menus and 
no statusbar (in build 20010725). This is precisely the case where I want a way 
to toggle the statusbar ON with the keyboard. Until this happens this bug needs 
to stay open.

REPEAT AFTER ME: This bug is not about full screen mode.

To state it again: I want the ability to turn the status bar ON. In Netscape 4 
this is easy accomplished with Ctrl+Alt+S, a key combination that is easy to 
remember and quite simple to execute. Alt+V,W,S is a much slower key sequence 
that doesn't work. No solution has yet been suggested in this bug.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Ah, I can see the need to fix the status bar not getting toggled when it's not
there in a popup.

However, what about scripts that disable the menu bar, or the
close/minimize/maximize/system menu buttons, or the scrollbars, or resize, etc.
etc. This is a general problem not just with status bars. We don't have enough
keys to toggle each thing back on individually. I think we need one command to
turn a pop up into a full browser window. We don't have any Ctrl+Alt key combos
in the app currently. Usually those are reserved for user defined application
hotkeys in Windows.
As aaron said, there are many things you can't do without menus.  The problem
isn't that there's no keyboard shortcut to get the status bar; the problem is
that there's no keyboard shortcut to for "make the menu bar appear" or "turn
this window into a real browser window".  See bug 69099 for adding a keyboard
shortcut for getting the menu bar (F10, Alt, and Alt+V should all work).
iirc ben is adding show menubar to the context menu, and that would probably 
happen w/in a week [never quote a bugzilla commenter]
There are 2 separate issues here:
1. The ability to show a hidden status bar at all, once it's been disabled from js
2. The ability to have a nifty keyboard shortcut

Maybe we can work on a shortcut after we've made it *possible* (item 1).
Assignee: aaronl → ben
Status: REOPENED → NEW
Depends on: 26353
Summary: [RFE] Toggle Status Bar from keyboard → [RFE] Cannot Toggle Status Bar when hidden from javascript
BTW, tpowell, you can set your prefs to "When Navigator Starts Up, Display" ->
"Last page visited".

If you do that, Accel+N will then open chromeless or statusbar-less windows in a
full browser window.
Timeless: Some nasty pages even disables right click.  Ben's effort (adding
"show menubar" to the context menu) would not work in this situation.
true, that's covered by this mess of bugs:
bug 14716 [RFE] don't popup new windows while mouse button is down 
bug 28604 [DOM] Context menu should wait for onclick / onmousedown handler
bug 40535 [RFE] disallow/queue alert (and window.open?) on right-click
bug 60889 handler doesn't get called if context-menu is active onClick
bug 71705 Right-click triggers onclick handler.
bug 72084 There is no way to disable the context menu upon right-click 
(oncontextmenu?) 
bug 86193 There is no way to always open the context menu upon right-click 
(oncontextmenu?) 

Note that just because a bug is fixed doesn't mean the fix is satisfactory for 
all parties. esp bug 72084.

However I expect that the last item will eventually be fixed and that this bug 
shouldn't care about the bugs i just listed (I'm listing them here because it 
took too long for me to find any of them).
Status: NEW → ASSIGNED
Target Milestone: --- → Future
I think the context menu item in bug 69099 should be "show toolbars" and include
the status bar.  See bug 69099 comment 28.  It might also make sense for the
keyboard shortcuts (Alt and F10) to show all the toolbars and not just the menu bar.
Summary: [RFE] Cannot Toggle Status Bar when hidden from javascript → Cannot Toggle Status Bar when hidden from javascript
*** Bug 188526 has been marked as a duplicate of this bug. ***
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey
Status: ASSIGNED → NEW
Assignee: ben_seamonkey → aaronleventhal
Priority: -- → P3
Target Milestone: Future → mozilla1.9beta
Mass un-assigning bugs assigned to Aaron.
Assignee: aaronleventhal → nobody
QA Contact: bugzilla → keyboard.navigation

Firefox no longer offers a statusbar. Is this bug obsolete now?

Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.