Alt/F10/context menu item to make hidden menubar visible

NEW
Unassigned

Status

SeaMonkey
UI Design
--
enhancement
17 years ago
a year ago

People

(Reporter: sean echevarria, Unassigned)

Tracking

(Blocks: 2 bugs, {access})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I hate it when a site opens up a popup window and hides the menubar in it.  I'd 
like to be able to rt-click in the window and enable the menubar from the 
context menu.

Comment 1

17 years ago
would it be ok if we put it in the system menu? [i don't know if all os's allow 
this] [macos probably doesn't care]
Assignee: asa → ben
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh
(Reporter)

Comment 2

17 years ago
available anywhere, doesn't matter where.  Doesn't even necessarily have to be 
on a menu of any sort - a pref with no ui where you can specify a key 
combination to toggle the menubar would work.
use a user stylesheet to turn off the menubar in your build. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

17 years ago
Why?

Ben: You misunderstood the bug. The problem isn't hiding the menu, it's showing
the menu once the menu has been hidden.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 6

17 years ago
 Ahh Yes I like this idea immensly. It always pisses me off when I cant use
Context menu's in a site. Marking NEW and putting in Browser General because I
dont think its XP-Apps.
Assignee: ben → asa
Status: UNCONFIRMED → NEW
Component: XP Apps: GUI Features → Browser-General
Ever confirmed: true
QA Contact: sairuh → doronr
Summary: [rfe] add show/hide menubar to content context menu → [RFE] Add show/hide menubar to content context menu

Updated

17 years ago
Assignee: asa → ben
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh

Comment 7

17 years ago
over to XPApps.
this would be useful, but i'd rather not have it in the context menu. i don't
mind have having this option in one of the main menus [prolly View] and/or
having a hidden pref.

recommend wontfix for the context menu aspect.
(Reporter)

Comment 9

17 years ago
I don't think an option to show the menubar would be of much help if it was in 
the menubar that was hidden.
Trying my hand at resummarizing.
Summary: [RFE] Add show/hide menubar to content context menu → [RFE] Add mechanism that user can invoke to show the menubar if it's been hidden by content javascript
(Reporter)

Comment 10

17 years ago
That's not meant to imply that the context menu is the right place either...
sean, heh, good point... hm, other than having a pref [hidden or otherwise],
methinks this might be a candidate for a keyboard shortcut. thoughts?

Comment 12

17 years ago
If the key can just show the menu (doesn't need to actually toggle the menu), 
F10 would work.

Comment 13

17 years ago
i like F 10.
(Reporter)

Comment 14

17 years ago
ditto

Comment 15

17 years ago
It might also be good to show the menubar if the user presses Alt (without 
pressing anything else while Alt is held down.)

Comment 16

17 years ago
Hmm, or Alt+F (or another menu mnemonic).

Comment 17

16 years ago
Matthew, comments?

-> markh, who did F10.  Mark, can you help out with expanding and showing 
menubars if these accelerators are pressed? (Doing it from C++ would be 
difficult; the expansion part might be impossible.  Then again, if we do it 
from the FE, we want this behavior for all menubars. Perhaps we can do it in 
the binding, if the menubar gets the keypress from anywhere...)
Assignee: ben → MarkH

Comment 18

16 years ago
Any mechanism offered has to be available from both the mouse and the keyboard, 
for accessibility reasons. `F10' won't cut it, especially on platforms where 
the function keys are reserved for OS use(ahem).

Here's what I suggest.

On Mac OS, the window.open flag to turn the menu bar off should have no effect 
at all. Now before standards compliance people (or people who think I'm giving 
the Mac special treatment) jump up and down, here's the explanation ... When 
authors use this flag, they're asking for a window without a menu bar *in it*. 
On Mac OS, that's what they always get anyway, so setting the flag should have 
no effect. (And indeed, on Internet Explorer for Mac OS the flag does have no 
effect.)

On other platforms, when the menu bar is turned off, there should be an item at 
the bottom of *every* context menu (not just the page context menu, but also 
the context menus for links, images, image links, and frames), saying `Show 
Menu Bar'. This does the obvious thing. And yes, I know this makes the context 
menus even longer, but (a) it's only for popups, and (b) I have a bug to clean 
out the trash from the context menus already.

Updated

16 years ago
Summary: [RFE] Add mechanism that user can invoke to show the menubar if it's been hidden by content javascript → [RFE] Alt/F10/context menu item to make hidden menubar visible

Comment 19

16 years ago
This isn't just about menus.

This is also about scroll bars being taken away. I have had times where I needed
to scroll a popup but couldn't.

There should be a way to get back any part of a window's chrome that you need -
be it the menu, status bar, close window, scroll bars, whatever.

Comment 20

16 years ago
Adding access keyword, as this has been discussed by the W3C User Agent
Accessibilit group.
Keywords: access

Comment 21

16 years ago
It would be cool if pressing Alt or Alt+MenuLetter would temporarily show the 
menubar and hide it again when a menu item has been activated or Esc pressed. 

It'd also be nice to permanently restore any missing chrome. As already noted, 
it's a bigger problem than just the menu. It's important to be able to restore 
(and I'd suggest toggle them off again, too) the menus, scrollbars, statusbar, 
toolbars, and locationbar.

I believe IE4 put this context menu in the application control menu (available 
from Alt+Spacebar and by clicking on the icon at the left end of the titlebar). 
IE5 seems to have removed the capability as near as I can tell.

Does this require some sort of pref to disable this capability for a kiosk 
mode? (I don't know if Mozilla supports a kiosk mode).

Comment 22

16 years ago
Pressing Alt shouldn't show the menu bar.  This will be messy with access keys 
for HTML elements.  If I have a field named "_L_ast Name:", I need to press 
Alt+L to access that field.  Undoubtedly, I will press Alt before I press L.

As for context menus, what about sites that have eat the oncontextmenu event so 
that they are never displayed?

Comment 23

16 years ago
Sorry, I should have been clearer. When I said press Alt, I meant that it 
should trigger the menu on the release of Alt. Just like the File menu is 
normally highlighted after pressing and releasing Alt. Mozilla would certainly 
know whether the Alt+Letter combo was for a menu or accesskey. Only a combo for 
the menu would need to show the menu.

Comment 24

16 years ago
Last time I checked, this would be a technique for a W3C User Agent Guideline.
The user is supposed to be able to stop UI from being removed by web content.
Blocks: 24413

Comment 25

16 years ago
See also bug 72001, pressing Alt+E while menu bar is collapsed makes it
impossible to click on the menu after uncollapsing the menu bar.

Comment 26

16 years ago
See bug 81331, Ctrl+L should make location bar visible if it's hidden.

Updated

16 years ago
Blocks: 26353

Comment 27

16 years ago
*** Bug 128406 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
I would prefer if the context menu item was "Show toolbars" instead of "Show 
menu bar".  Just showing the menu bar would be awkward, and I'm usually most 
interested in seeing the location bar.

Showing the menu bar (or other toolbars) should also turn on scrollbars if 
scrollbars were disabled for the window, because there's no menu item for 
toggling scrollbars and because the content is likely to need scrollbars once 
any chrome becomes visible.

Comment 29

15 years ago
*** Bug 137004 has been marked as a duplicate of this bug. ***
Blocks: 135841
Summary: [RFE] Alt/F10/context menu item to make hidden menubar visible → [RFE] Alt+F10/context menu item to make hidden menubar visible

Comment 30

15 years ago
*** Bug 142105 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Summary: [RFE] Alt+F10/context menu item to make hidden menubar visible → [RFE] Alt/F10/context menu item to make hidden menubar visible

Comment 31

15 years ago
*** Bug 144318 has been marked as a duplicate of this bug. ***

Comment 32

15 years ago
Recommend wontfix since we now have prefs (see bug 107949) to prevent scripts
from hiding the menubar in the first place.

Comment 33

15 years ago
That's silly.

I *do not* want all of my pop-up windows to have menubars.  That would just
clutter things unnecessarily.

And yet, in those rare occasions when I need to get at infrequently-used
commands on those popup windows (doc info, etc) I still want some way to get at
them.

(I agree that on a mac it might make sense to just never hide the menubar, but
I'm talking about unix.)

Comment 34

15 years ago
Jamie, all of your popups wouldn't have menu bars - you would only get the menu
bars if you used a command to navigate to the menubar.

Comment 35

15 years ago
Aaron Leventhal wrote:
>
> Jamie, all of your popups wouldn't have menu bars - you would only
> get the menu bars if you used a command to navigate to the menubar.

That sounds fine.  But I was replying to:

Jonas Jørgensen wrote:
>
> Recommend wontfix since we now have prefs (see bug 107949) to
> prevent scripts from hiding the menubar in the first place.

which I interpret as "if you ever want a popup to have a menu bar, then
set a preference to make them all always have menubars", which sounds
like a terrible idea.

Updated

15 years ago
Summary: [RFE] Alt/F10/context menu item to make hidden menubar visible → Alt/F10/context menu item to make hidden menubar visible

Comment 36

15 years ago
add JG

Comment 37

13 years ago
I believe that this feature should nto only be limited to the menubar, but it
should show all items that have been removed by the window.open command.
This includes, but is not limited to:
the menu
the toolbar(s)
the address bar
the status bar
the scroll bars

As such, a more descriptive context menu item may be necessary.
Some ideas:
"Restore window defaults"
"Show window tools"
"Restore window toolbars"

--------------------------
In addition to this, I also have several questions that I believe need to be
addressed.
1) Would it is also be equally useful to have a context menu option to restore
the window back to its original form (with whatever toolbars, and menubars that
were originally missing)?  Just like this feature we are proposing, it would
only apply to windows that were once a pop-up.
2) Of a more serious nature, what do we do when that window calls a close()
command in javascript?!
If the user started using that page to browse other sites on the internet, then
if he encountered (either accidentally or through a malicious website) a page
that calls window.close(), then he would suddenly have his window closed on him.
 This, of course, would not be a good thing.
In order to prevent these kinds of problems, I would think that the window
should no longer be allowed to close.  However, if we did this, would this cause
other problems that I am not familiar with? Would it affect W3C compliance? 
Should we not allow the user to restore all "chrome" features in the first place?

Comment 38

13 years ago
I just looked at Bug 26353, however I'm not sure of the difference between that
bug and this bug.
Here's what I made out:
This bug suggests adding a keyboard shortcut and context menu item, while Bug
26353 just suggests a context menu item.
This bug suggests an option to restore the menubar, while Bug 26353 suggests an
option to restore all the chrome items including the menubar.

Should both bugs exist?
Product: Core → Mozilla Application Suite

Comment 39

12 years ago
Probably, because this bug is one of two open bugs genuinely blocking bug 26353.

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design

Updated

6 years ago
Assignee: mhammond → nobody
You need to log in before you can comment on or make changes to this bug.