[B2G] [Browser] Youtube videos lose sync between audio and video

VERIFIED DUPLICATE of bug 863441

Status

Firefox OS
Gaia::Video
VERIFIED DUPLICATE of bug 863441
5 years ago
5 years ago

People

(Reporter: CKreinbring, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 744217 [details]
Log of YouTube video with lost audio/video sync

Description:
The audio and video in YouTube videos will lose sync, with the video falling behind the audio.

Repro Steps:
1) Updated to Inari Build ID: 20130501070201
2) Launch the browser and navigate to YouTube.com
3) Select a video to play, the longer the better.
4) As the video plays, observe how well the audio and video are synced.

Actual:
The video will lose sync with the audio and lag behind, causing the video to appear to end early.

Expected:
Audio and video remain synced throughout the duration of the video clip.

Environmental Variables:

Occurs on the Inari device.
Build ID: 20130501070201
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/010498e599a7
Gaia: 09046df332cd217cf4fad55c48ce9ce3f14ee5a4
Version #: 18.0

Notes:
Repro frequency: 80%
Q Analysts Test Team Priority: Pri 2
See attached logcat logs for more info.
(Reporter)

Comment 1

5 years ago
Also seen on Leo 1.1 mozilla RIL.

Build ID: 20130501070205
Kernel Date: Apr 25
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/765d296cff66
Gaia: e420d71c9528786621f176fb4ce67d291e0a530e
Version #: 18.0
Does this happen with all the videos you play?

Updated

5 years ago
Component: Gaia::Browser → Gaia::Video
Not sure if this is similar to Bug 863441, but it doesn't sound as if the video freezes.
I haven't able to reproduce this on on Ikura device on 1.0.1 yet using the 20130501 Commercial RIL build. Would be helpful to point to the video you were playing when this occurred.
I noticed this while playing an Ogg Theora video saved on the memory card (The Elephants Dream to be precise). The audio and video were not in sync.
(Reporter)

Comment 6

5 years ago
A good YouTube vid to repro this defect with is "Persona 4 The Animation- Yu vs Margaret (subbed) [720p]".  The subtitles are especially useful for noting how out of sync the audio and video has become.

http://www.youtube.com/watch?v=g6DXhqsBYy8

Updated

5 years ago
blocking-b2g: --- → tef?
Right now we are seeing inconsistent results when testing this. Using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/5c1d67e0c242
Gaia   11477c127ae9be5051e4cfbcbf3da1d4150f9967
BuildID 20130502070201
Version 18.0

and both Inari and Ikura devices, Sreenidhi and I could not get the video in Comment 6 to play, and we also cannot play any youtube videos from the browser. I often get an "Invalid Response Received." The smoketest team was able to play the videos, but they are out of sync.

Adding qawanted since we clearly need to hit some other devices to see what is going on. 

(In reply to ckreinbring from comment #6)
> A good YouTube vid to repro this defect with is "Persona 4 The Animation- Yu
> vs Margaret (subbed) [720p]".  The subtitles are especially useful for
> noting how out of sync the audio and video has become.
> 
> http://www.youtube.com/watch?v=g6DXhqsBYy8
Keywords: qawanted
I downloaded the Elephant ogg video in Comment 5 but I was not able to reproduce the out of sync issue using the same build as in Comment 7.

Updated

5 years ago
Whiteboard: [tef-triage]

Comment 9

5 years ago
The good example to repro this issue is to go to YouTube and search for "songs with subtitles in English" - search results will bring several videos of Special English education reports one of them "Are You Learning English? These Songs May Help" http://youtu.be/33qbMCuJ5XI 
- With lady on a screen who speaks really clearly and it is easy to read her lips while she is talking so issue with audio going ahead of the video is clearly noticeable. 
You can also play other videos from this series to repro this issue.

Issue with sound goes ahead of the video repro 10/10 times 
second issue with video stops (freezes) and green screen appears few seconds later repro  8/10 times
Issue were reproduced on latest builds of Inari Leo and Unagi

Environmental  Variables:
Inari Build ID: 20130503070205
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3f3489356bbc
Gaia: 3e232bce289c9e156d92553e752616cba284bc8f


Leo Build ID: 20130503070204
Kernel Date: Apr 25
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8becaf2a0bc7
Gaia: b0aca0dd1e2955e11190ede725e1fb9ee596438b

Unagi Build ID: 20130503070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8becaf2a0bc7
Gaia: b0aca0dd1e2955e11190ede725e1fb9ee596438b

Comment 10

5 years ago
see also repro video http://youtu.be/juU2NJjhgmU
Keywords: qawanted

Comment 11

5 years ago
This is repro video for Inari, in this case we also ended up with a green Screen.

http://youtu.be/hhqeCzDnpfE
(Reporter)

Updated

5 years ago
Summary: [B2G] [Inari] [Browser] Youtube videos lose sync between audio and video → [B2G] [Browser] Youtube videos lose sync between audio and video
It seems this is having some very bad effects on the gecko media cache for long videos. See bug 863441.
Dup into bug 863441?
(In reply to Diego Wilson [:diego] from comment #13)
> Dup into bug 863441?

Maybe. Let's double check with Sotaro on this as well.

Sotaro - What do you think? Is this a dupe of bug 863441?
Flags: needinfo?(sotaro.ikeda.g)
> > Dup into bug 863441?
> Sotaro - What do you think? Is this a dupe of bug 863441?

Yes, it is dupe of bug 863441. By applying temporary fix as in Bug 863441 comment #67, the problem was fixed.
Flags: needinfo?(sotaro.ikeda.g)

Updated

5 years ago
Status: NEW → RESOLVED
blocking-b2g: tef? → ---
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 863441

Updated

5 years ago
Whiteboard: [tef-triage]
(Reporter)

Comment 17

5 years ago
Fix verified on Inari 1.0.1 commercial RIL.  YouTube video now retain video and audio sync throughout the video.

Build ID: 20130509070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/b0b2b5cfdc5b
Gaia: 30ad443fbe5363a7381c19c6bf9d6ca49228fb8b
Status: RESOLVED → VERIFIED

Updated

5 years ago
Blocks: 878343
You need to log in before you can comment on or make changes to this bug.