Remote Debugging Protocol needs a way to transfer files

RESOLVED DUPLICATE of bug 797639

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 797639
6 years ago
Last year

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

This is an alternative, simpler, suggestion to bug 797639. Since phones OOM instead of swapping, to transfer large data blobs we need it would be easier to generate them directly to a file stream and hand over a file name/handle to RDP to handle the transfer piecewise.

To be clear we only need one of this or bug 797639.
Jim, how do you feel about this idea?
Flags: needinfo?(jimb)
Priority: -- → P2
I'd like to understand the restrictions we're operating under better. When you generate these big blobs of data, are you able to return to the event loop between chunks? Or do you have code which needs to run entirely in a single event tick, and generates all the data?

Are you suggesting that the RDP transfer the data chunkwise using the ordinary JSON framing?
Flags: needinfo?(jimb)
Since we're actively implementing bug 797639, I'll dupe this to that one.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797639
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.