Unable to load image/video content when performing search on bing.com

RESOLVED WORKSFORME

Status

P1
major
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: bajaj, Assigned: hsteen, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sitewait][country-all][microsoft], burirun3, URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR :
1)Open a new tab and go to www.bing.com
2)Type a search term and tap Search. (for e.g. "mozilla") 
3)You should be seeing content load with three tab's "web" "images" "video"
4)Click on images/videos

Expected Result :
You should be able to view images/Video content

Actual Result :
There is absolutely no content shown on those tabs

Device tested : Samsung galaxy s3 & s4 on Fx Release : 20.0.1 and Fx 21.0b5
Device details : Samsung S3
Model : GT -I9300
Android version: 4.1.2

Tried to run similar STR  on Chrome was getting content as expected.
Reproducible on desktop with the mobile user-agent. Over to Tech Evangelism.
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 20 → Trunk

Updated

6 years ago
Blocks: 766964
Created attachment 745157 [details]
Bing Image/Video Search - Screenshot

This looks eerily similar to bug 766964.

Updated

6 years ago
See Also: → bug 766964
(Assignee)

Updated

5 years ago
(Assignee)

Comment 3

5 years ago
FirefoxOS UA gets desktop site (which is possibly not good) and this works fine (which is, I guess). Firefox Android UA still gets missing content.

Updated

5 years ago
Duplicate of this bug: 870068

Updated

5 years ago
Duplicate of this bug: 909209
Is Microsoft aware of these issues using that using Bing in Firefox for Android is rather abysmal?
Flags: needinfo?(hoonk)
(Assignee)

Comment 7

5 years ago
So, loading this URL:
http://www.bing.com/videos/search?q=cats&FORM=HDRSC3
is supposed to cause another request for this URL to get the actual search results:
http://www.bing.com/m/videos/search?mobile=1&q=cats%20filterui:playable_html5&first=0&count=20&IG=ac887a2bfa9a4bdea8db1ec9df80e8f0&IID=video.1&SFX=1

The second request never happens in Firefox on Android. The underlying reason is an exception that happens because they expect document.styleSheets[n].rules to be a collection (the standards-compliant property is of course document.styleSheets[n].cssRules). Fixing this code makes both video and image search work:

		function r(n){ 
			for(var u="rules",t,i,r=0;r<_d.styleSheets.length;r++)
				if(t=_d.styleSheets[r][u],t)
					for(i=0;i<t.length;i++)
						if(t[i].selectorText===n)
							return t[i];return null}
(Assignee)

Updated

5 years ago
Severity: normal → major
Priority: -- → P1
Whiteboard: [contactready][country-all][microsoft]
(Assignee)

Comment 8

5 years ago
Reached out through site's feedback feature and on Twitter
Assignee: nobody → hsteen
Status: NEW → ASSIGNED
Whiteboard: [contactready][country-all][microsoft] → [sitewait][country-all][microsoft]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 924589

Updated

5 years ago
Duplicate of this bug: 931771
Whiteboard: [sitewait][country-all][microsoft] → [sitewait][country-all][microsoft], burirun3

Updated

5 years ago
Duplicate of this bug: 941275
(In reply to Hallvord R. M. Steen from comment #7)

> The second request never happens in Firefox on Android. The underlying
> reason is an exception that happens because they expect
> document.styleSheets[n].rules to be a collection (the standards-compliant
> property is of course document.styleSheets[n].cssRules). Fixing this code
> makes both video and image search work

Is this the only option? It's not clear to me whether Bing's code is actually broken, or how we display the information is different to how others do it. ie why does Chrome and Safari work? 

I'm trying to see if we have another approach to follow other than Bing changing the way they handle a Mozilla search request, because this type of evangelism bug will take a while to get prioritized and fixed. I'm looking for options.
(In reply to Karen Rudnitski [:kar] from comment #12)

> It's not clear to me whether Bing's code is
> actually broken, or how we display the information is different to how
> others do it. ie why does Chrome and Safari work? 

The reason this works in Chrome and Safari (and other WebKit) browsers is because they've implemented the non-standard IE way of accessing a CSSRuleList via the .rules property. Firefox implements the .cssRules property (per spec). Note that WebKit browsers _also_ implement the standard property.
And fwiw, http://www.opera.com/docs/specs/presto2.12/dom2/css/ cssRules in Presto.

Comment 15

5 years ago
I am working through business channels to identify a resource on the Bing mobile team to assist with this issue.  Will follow-up once I have a response.  Thanks, Joanne
This works for me as of today (December 19th).
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.