Slow startup warning displayed where Fx was not slow to start up.

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Florian Bender, Unassigned)

Tracking

(Depends on: 1 bug, {steps-wanted})

21 Branch
x86_64
Mac OS X
steps-wanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox22- wontfix, firefox23-, firefox24-)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130430204233

Steps to reproduce:

Start Firefox. I'm on a 2012 MBA with SSD and 8GB RAM, and startup did not take any longer than ~1 sec. 

I'm not exactly sure about the actual STR. Might have been during restart just after prompting to update from b5 to b6. Might have been because network was disabled (I don't remember that exactly). 


Actual results:

Slow startup warning was displayed. 

browser.slowStartup.averageTime   = 18441
                   .samples       = 1
                   .timeThreshold = 60000


Expected results:

No warning message. 


The ~20s startup time (in the config) hints to this happening because timing startet before the update was applied, and ended after full startup after the update. If this is the case, a notice should not be displayed immediately after update. 


FHR data.last (excerpt) = 
      "org.mozilla.appInfo.appinfo": {
        "_v": 2,
        "appBuildID": "20130430204233",
        "distributionID": "",
        "distributionVersion": "",
        "hotfixVersion": "",
        "id": (upon request),
        "locale": "de",
        "name": "Firefox",
        "os": "Darwin",
        "platformBuildID": "20130430204233",
        "platformVersion": "21.0",
        "updateChannel": "beta",
        "vendor": "Mozilla",
        "version": "21.0",
        "xpcomabi": "x86_64-gcc3"
      },
      "org.mozilla.profile.age": {
        "_v": 1,
        "profileCreation": 15816
      },
      "org.mozilla.appSessions.current": {
        "_v": 3,
        "startDay": 15828,
        "activeTicks": 81,
        "totalTime": 469,
        "main": 792,
        "firstPaint": 17929,
        "sessionRestored": 18379
      },
      "org.mozilla.sysinfo.sysinfo": {
        "_v": 1,
        "cpuCount": 4,
        "memoryMB": 8192,
        "architecture": "x86-64",
        "name": "Darwin",
        "version": "12.3.0"
      }
(Reporter)

Comment 1

5 years ago
Probably solved by Bug 838713, then this may need an uplift.
Depends on: 838713
Hardware: x86 → x86_64
(Reporter)

Comment 2

5 years ago
Oh, landed already in Fx 21. Then it may not work as intended (if my original assumption is correct). 

(Sorry for Bugspam.)

Updated

5 years ago
Depends on: 868712

Updated

5 years ago
Blocks: 836010

Comment 3

5 years ago
I'm still occasionally getting bogus slow-start warnings on Nightly.  Bug 868712 might be part of it, but is probably not the only thing going wrong.
tracking-firefox22: --- → ?
tracking-firefox23: --- → ?
tracking-firefox24: --- → ?

Updated

5 years ago
Keywords: steps-wanted

Comment 4

5 years ago
(In reply to Jesse Ruderman from comment #3)
> I'm still occasionally getting bogus slow-start warnings on Nightly.  Bug
> 868712 might be part of it, but is probably not the only thing going wrong.

You've been seeing this behavior since FF22 on Nightly as well? Or was it even earlier?

There isn't enough info to go off of to block the release of FF22 on this change, so wontfixing.
status-firefox22: --- → wontfix
tracking-firefox22: ? → -
This looks like an intermittent issue and something we may not be able to block unless we have reliable STR or more reports.

Please fell free to renominate if there is a disagreement here.
tracking-firefox23: ? → -
tracking-firefox24: ? → -
I filed bug 896025 for the same problem, I have some useful info there, I'm investigating whether I can find anything more since I still have the session ongoing.

Updated

5 years ago
Depends on: 896025

Updated

5 years ago
No longer depends on: 896025

Updated

5 years ago
Depends on: 896025
I haven't been able to reproduce this on recent builds. Does anyone still see this issue?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.