video playback is choppy on tumblr

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: dusty-2011, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
On my system, the video playback on tumblr is very choppy when I increase the video size or play it fullscreen. This is the case for all videos which use tumblr's own player, so not for youtube or vimeo videos.

Steps to reproduce:
-Visit http://videohall.tumblr.com/post/45234276692/dairy-cows-in-holland-are-let-out-to-pasture-for#notes    (this link is suitable for work, but mute your audio)
-Play the video
-The video should automatically enlarge when you play it. If not press the button on the lower right corner to enlarge the video.

Look at the movement of the cows. The movement is not smooth, but very choppy. The framerate is low and unstable. If I play the same video in Internet Explorer 9 or Chrome 26, the video is super smooth.

I have Firefox 20.0.1 installed, my OS is Windows 7 64-bits, I have a Radeon HD 4570 graphics card, I have the AMD Catalyst Legacy Drivers 13.1 installed (latest stable version). I have a 23-inch monitor, so the video gets enlarged a lot.

I have no video playback issues on any other site. For example, on Youtube I can watch 1080p videos fullscreen without a problem. Also, my system is fast enough to playback a Bluray smoothly.
(Reporter)

Comment 1

5 years ago
Another good example is http://videohall.tumblr.com/post/44032559382/car-goes-through-ice-ok#notes
Look at the line of moving text at the bottom of the video. The movement of the text is very choppy in Firefox. In IE9 and Chrome 26 the movement of the line is much smoother.

Also, when playing this video multiple times in a row in Firefox, the problems get worse. Often the video does not move for the first 10 seconds (and I just get audio for the first 10 seconds, but no moving picture), and then resumes playing (but choppy). Sometimes the video does not start playing at all, and I have to press the X in the upper right corner and refresh the page for the video to start playing. You can reproduce these issues by playing the video once, let it finish, then play it again, let it finish, then play it again etc.
(Reporter)

Comment 2

5 years ago
Btw, I have checked my plugins and they are all up to date (including Flash Player, the version is Shockwave Flash 11.7 r700).

Comment 3

5 years ago
It looks like a website issue.
(Reporter)

Comment 4

5 years ago
(In reply to Loic from comment #3)
> It looks like a website issue.

Does that mean it's not Firefox to blame, but the web developers of tumblr? It may be worth contacting the people behind tumblr in that case, because they host 106 million blogs and almost 50 billion messages. It would be a shame if millions of videos continued to be choppy in Firefox.

Comment 5

5 years ago
I tried in old Firefox 8 and the 2nd playback is broken too, the video displays wheel running endlessly.
Looks choppy in FF 20 indeed, but works fine in nightly.
Could you please try on latest nightly? http://nightly.mozilla.org/
Flags: needinfo?(dusty-2011)
(Reporter)

Comment 7

5 years ago
Ontopic: The videos are visually smooth in the latest nightly (23.0a1). A second playback of the video is also no longer broken in the latest nightly . HOWEVER, there is a new issue in the nightly. The SOUND distorts!! This is clearly noticeable in the cow video, where the song Beautiful Day by U2 plays. There is a clear cracking sound noticeable throughout the video, a distortion. This distortion was not present in Firefox 20, and is also not present in IE9 or Chrome 26. Also in the other tumblr video, the sound distorts in the latest nightly build. The person's voice is surrounded by cracking noises.

I have tested whether this sound distortion problem is present on other sites as well in the latest nightly build. I have tested these videos: 
https://www.youtube.com/watch?v=qqIIW7nxBgc
http://www.zie.nl/video/algemeen/Fors-meer-geevacueerden-Wetteren-dan-gedacht/m1nzerif0vja
http://vimeo.com/65576562

There were no audio distortion problems in the above videos. The audio distortion problems seems to be isolated to the tumblr video player.


Offtopic:

I am not satisfied with the overall experience of installing Nightly!! Here are some other issues I am having:

-Nightly has no jumplist when right clicking on the taskbar icon. So I cannot open a new tab, new window or new private window from the jumplist.
-Installing nightly has screwed up my Firefox 20 installation. The bookmarks button was missing. I've added the bookmarks button myself, but when pressing it I now get a bookmarks sidebar instead of a bookmarks window.
-Adding the bookmarks button in Firefox 20 has screwed up Nightly. I now have the classic bookmarks button in Nightly (instead of the redesigned one), and it opens a bookmark sidebar instead of a bookmarks window.
Flags: needinfo?(dusty-2011)
(Reporter)

Comment 8

5 years ago
I have filed a new bug about the audio distortion problems of tumblr videos when using the latest Firefox nightly (23.0a1). See bug 870400: https://bugzilla.mozilla.org/show_bug.cgi?id=870400

Offtopic: I am not able to add a page to my bookmarks in the Nightly build. Because the redesigned bookmarks button has been replaced with the old button (see previous post). So I am going to uninstall Nightly and repair the Firefox 20 installation.
Thanks for taking the time to report this!

(In reply to dusty-2011 from comment #7)
> -Nightly has no jumplist when right clicking on the taskbar icon. So I
> cannot open a new tab, new window or new private window from the jumplist.
bug 870529

> -Installing nightly has screwed up my Firefox 20 installation. The bookmarks
> button was missing. I've added the bookmarks button myself, but when
> pressing it I now get a bookmarks sidebar instead of a bookmarks window.
The bookmark button exists, but it's displayed just after the search box.
Works fine for me.

(In reply to dusty-2011 from comment #8)
> So I am going to uninstall Nightly and repair
> the Firefox 20 installation.
No need to, you can use multiple profiles instead http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.