[SMS][MMS] Migrate entire Messaging app to threadId (previously used phone number)

RESOLVED FIXED

Status

Firefox OS
Gaia::SMS
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rwaldron, Assigned: rwaldron)

Tracking

({feature})

unspecified
x86
Mac OS X
feature
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

Attachments

(1 attachment)

45 bytes, text/x-github-pull-request
gnarf
: review+
julienw
: review+
Details | Review | Splinter Review
(Assignee)

Description

5 years ago
Previously the app used the phone number to attribute a message to a particular thread. That's not cool, and now we have threadId, so use that instead.
AFAIK we know have all the necessary support in Gecko: we have the thread id in the Thread object when getting them from getThreads, we can provide a thread id in a filter, and we have the thread id when getting a message from the system message.

Borja, am I missing a use case here ?

Marking leo? because we'll need this so that everything works as intended with multi-recipients threads.
blocking-b2g: --- → leo?
Summary: [SMS][MMS] Update all uses of "number" where threadId is more appropriate → [SMS][MMS] use the threadId as the "key" of a thread instead of a phone number in all places where it's relevant
Triage: likely to block on this, but can you provide the bug that this blocks so we can understand the dependencies?
Flags: needinfo?(waldron.rick)
(Assignee)

Updated

5 years ago
Depends on: 862311

Updated

5 years ago
Assignee: nobody → waldron.rick
This is part of the core MMS work for proper thread support now that multiple numbers may be involved, marking blocking.
blocking-b2g: leo? → leo+
Flags: needinfo?(waldron.rick)
Keywords: feature
Depends on: 870562

Comment 4

5 years ago
last comment was 4days ago.  what's the status here?
(Assignee)

Comment 5

5 years ago
Faramarz, sendMMS is not functional (or, no one has confirmed ever sending an MMS message successfully). If it was, this might've been done on Monday.

https://bugzilla.mozilla.org/show_bug.cgi?id=867227
https://bugzilla.mozilla.org/show_bug.cgi?id=872219
https://bugzilla.mozilla.org/show_bug.cgi?id=871772
https://bugzilla.mozilla.org/show_bug.cgi?id=869807
(In reply to Rick Waldron from comment #5)
> Faramarz, sendMMS is not functional (or, no one has confirmed ever sending
> an MMS message successfully). If it was, this might've been done on Monday.
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=867227
> https://bugzilla.mozilla.org/show_bug.cgi?id=869807

Just for the records, please see bug 869841, comment #8. Hope it's nothing but just a typo. ;)

> https://bugzilla.mozilla.org/show_bug.cgi?id=871772
> https://bugzilla.mozilla.org/show_bug.cgi?id=872219

At the same time, I'm looking into the above two bugs. Please stay tuned.
Depends on: 872373

Updated

5 years ago
Blocks: 872369
(Assignee)

Updated

5 years ago
Summary: [SMS][MMS] use the threadId as the "key" of a thread instead of a phone number in all places where it's relevant → [SMS][MMS] Migrate entire Messaging app to threadId (previously used phone number)
(Assignee)

Comment 7

5 years ago
Created attachment 750760 [details] [review]
Fix for 868679
Attachment #750760 - Flags: review?(gnarf37)
Attachment #750760 - Flags: review?(felash)
Whiteboard: [NO_UPLIFT]
Comment on attachment 750760 [details] [review]
Fix for 868679

r=me

some follow up, notably Bug 873703, but we need this to not block other people. And it works :)

waiting for Corey's thumb up, because 2 more eyes could be good for this big patch.
Attachment #750760 - Flags: review?(felash) → review+

Comment 9

5 years ago
master: 2f444eefd99078cb782e227e8d16c4964c99b1f1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Attachment #750760 - Flags: review?(gnarf37) → review+

Updated

5 years ago
Whiteboard: [NO_UPLIFT]
v1-train: bda16a0
status-b2g18: --- → fixed
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.