Last Comment Bug 868742 - Nested Frame can not be scrolled vertically in Mobile Firefox
: Nested Frame can not be scrolled vertically in Mobile Firefox
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 21 Branch
: ARM Android
: -- normal with 1 vote (vote)
: mozilla24
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
:
Mentors:
http://www.muho-mannheim.de/frame.php...
: 873463 (view as bug list)
Depends on:
Blocks: 878767
  Show dependency treegraph
 
Reported: 2013-05-04 05:20 PDT by Stefan Fleiter (:sfleiter)
Modified: 2013-06-25 06:43 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
fixed
fixed
fixed
22+


Attachments
Use scroll(Left|Top)Max in fennec (1.95 KB, patch)
2013-05-24 08:44 PDT, Kartikaya Gupta (email:kats@mozilla.com)
mark.finkle: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Stefan Fleiter (:sfleiter) 2013-05-04 05:20:24 PDT
Hi,

this bug is about a scrolling (of frames) regression from Mobile Firefox 21 onwards.

Steps:
- Install Firefox Mobile from 21 (current Beta) to 23 (current nightly)
  Tested on Samsung Galaxy Note 2 and Google Nexus 7.
- Open $URL which is in German and contains a nested frameset.
- Click "Alle Veranstaltungen" in the left navigation bar.
  The content frame should now contain the word "Veranstaltungskalender" at the very top.
- Try to scroll down that frame which will not work.

Expected:
- Should scroll as it does with desktop Firefox or mobile Chrome browser.

Bonus Step:
- Retry with Firefox Mobile 20.0.1 (current release)
- Notice that the frame scrolls as expected
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-24 08:32:08 PDT
Loading the page http://www2.muho-mannheim.de/ by itself in desktop FF shows that the body of the document has a clientHeight 6 pixels shorter than the scrollHeight. This results in the inability to scroll it on mobile, because we incorrectly detect the body as the scrollable element rather than the document element. Furthermore trying to actually scroll the body element by increasing its scrollTop value doesn't actually move it anywhere.

This seems like a regression in layout. It is very similar to the problem in bug 755971.
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-24 08:35:26 PDT
Also to clarify a bit, the problem can be reproduced on desktop as follows:

1) Load http://www2.muho-mannheim.de/
2) Open the developer console or firebug
3) Examine the values for "document.body.clientHeight" and "document.body.scrollHeight". Note that clientHeight < scrollHeight.
4) Try increasing the scrollTop on the body. "document.body.scrollTop += 1"
5) Check to see the new scrollTop "document.body.scrollTop"

Note that in step 5 it returns 0 even though it should be 1.
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-24 08:44:08 PDT
Created attachment 753812 [details] [diff] [review]
Use scroll(Left|Top)Max in fennec

We can fix the original bug with this patch (which is more correct) which uses the new properties added back in bug 766937. I think there's still an underlying layout regression that triggered this bug but that might actually be expected behaviour. We can defer that to if/when it manifests some other way.
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-24 08:50:53 PDT
*** Bug 873463 has been marked as a duplicate of this bug. ***
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-24 12:46:41 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/94aa313f23d8
Comment 6 Phil Ringnalda (:philor) 2013-05-25 21:08:45 PDT
https://hg.mozilla.org/mozilla-central/rev/94aa313f23d8
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-27 06:01:19 PDT
Comment on attachment 753812 [details] [diff] [review]
Use scroll(Left|Top)Max in fennec

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unknown
User impact if declined: some frames are not scrollable when they should be. this appears to affect a small percentage of websites.
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): affects fennec only, pretty low risk.
String or IDL/UUID changes made by this patch: none
Comment 8 Stefan Fleiter (:sfleiter) 2013-05-27 06:50:33 PDT
Thanks for fixing this!
Verified works on Nexus 7 with Firefox Mobile nightly build.
Comment 9 Ryan VanderMeulen [:RyanVM] 2013-05-28 12:06:48 PDT
Please update the bug when you uplift patches so that others don't waste their time duplicating efforts.

https://hg.mozilla.org/releases/mozilla-aurora/rev/9b072d87665a
https://hg.mozilla.org/releases/mozilla-beta/rev/6fc2baf36c55
Comment 10 Kevin Brosnan [:kbrosnan] 2013-05-31 13:50:31 PDT
Might be worth a relnote? Fixes a regression in 21 as part of Firefox 22.
Comment 11 Kevin Brosnan [:kbrosnan] 2013-05-31 14:06:06 PDT
Paul would you investigate if automating this issue is possible.
Comment 12 Paul Feher 2013-06-03 05:53:45 PDT
We will look into this, I've opened bug 878767 regarding this issue.

Note You need to log in before you can comment on or make changes to this bug.