Remove support for document.createEvent("AnimationEvent"), document.createEvent("TransitionEvent"), AnimationEvent.initAnimationEvent, and TransitionEvent.initTransitionEvent

RESOLVED FIXED in mozilla23

Status

()

Core
DOM
RESOLVED FIXED
4 years ago
7 months ago

People

(Reporter: smaug, Assigned: dbaron)

Tracking

({dev-doc-complete, site-compat})

unspecified
mozilla23
dev-doc-complete, site-compat
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Need to check what Webkit, Trident and Blink have and also do some
search whether the feature is used in the web pages or script libraries.
(Reporter)

Updated

4 years ago
No longer depends on: 848291
(Reporter)

Updated

4 years ago
Depends on: 848291
(Assignee)

Comment 1

4 years ago
At the very least, the event type argument to document.createEvent() in WebKit / blink isn't compatible, or wasn't until very recently.  I think we should just remove and see if we get feedback; I have a patch to do so.
(Assignee)

Comment 2

4 years ago
https://tbpl.mozilla.org/?tree=Try&rev=75a2adbecd62
(Assignee)

Comment 3

4 years ago
make that https://tbpl.mozilla.org/?tree=Try&rev=c4e6644234dc
(Assignee)

Comment 4

4 years ago
Created attachment 746671 [details] [diff] [review]
Remove support for obsolete document.createEvent("AnimationEvent"), document.createEvent("TransitionEvent"), AnimationEvent.initAnimationEvent, and TransitionEvent.initTransitionEvent.
Attachment #746671 - Flags: review?(bugs)
(Assignee)

Updated

4 years ago
Assignee: nobody → dbaron
(Assignee)

Comment 5

4 years ago
Comment on attachment 746671 [details] [diff] [review]
Remove support for obsolete document.createEvent("AnimationEvent"), document.createEvent("TransitionEvent"), AnimationEvent.initAnimationEvent, and TransitionEvent.initTransitionEvent.

Note that this comment:
>+  // NEW EVENT TYPES SHOULD NOT BE ADDED HERE; THEY SHOULD USE ONLY EVENT
>+  // CONSTRUCTORS
was added based on an in-person discussion I had with annevk.
(Reporter)

Comment 6

4 years ago
Comment on attachment 746671 [details] [diff] [review]
Remove support for obsolete document.createEvent("AnimationEvent"), document.createEvent("TransitionEvent"), AnimationEvent.initAnimationEvent, and TransitionEvent.initTransitionEvent.

I guess we can do this this way, although I'd probably leave init*Event method to
.idl files and make them [noscript].
Attachment #746671 - Flags: review?(bugs) → review+
(Assignee)

Comment 7

4 years ago
(In reply to Olli Pettay [:smaug] from comment #6)
> I guess we can do this this way, although I'd probably leave init*Event
> method to
> .idl files and make them [noscript].

Why would you want to do that?
(Reporter)

Comment 8

4 years ago
oh, right, creating these events in C++ outside libxul becomes hard anyway. So, removing
init* from .idl makes sense.
(Assignee)

Comment 9

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a20ea0d494a0
(Assignee)

Updated

4 years ago
Keywords: dev-doc-needed
Summary: Investigate if initTransitionEvent method could be removed → Remove support for document.createEvent("AnimationEvent"), document.createEvent("TransitionEvent"), AnimationEvent.initAnimationEvent, and TransitionEvent.initTransitionEvent
https://hg.mozilla.org/mozilla-central/rev/a20ea0d494a0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
I've added this bug to the compatibility doc. Please correct the info if wrong.
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_23
Keywords: site-compat
OS: Linux → All
Hardware: x86_64 → All
Documentation updated
https://developer.mozilla.org/en-US/docs/Web/API/TransitionEvent.initTransitionEvent
https://developer.mozilla.org/en-US/docs/Web/API/AnimationEvent.initAnimationEvent
https://developer.mozilla.org/en-US/docs/Web/API/document.createEvent
https://developer.mozilla.org/en-US/docs/Web/API/AnimationEvent
https://developer.mozilla.org/en-US/docs/Web/API/TransitionEvent

https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/23
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_23
Keywords: dev-doc-needed → dev-doc-complete
(Assignee)

Updated

3 years ago
Duplicate of this bug: 868769
Depends on: 1314303
You need to log in before you can comment on or make changes to this bug.