After changing one of the restart-required settings in the DevTools option window, a restart button should be provided

RESOLVED DUPLICATE of bug 881807

Status

()

Firefox
Developer Tools: Framework
RESOLVED DUPLICATE of bug 881807
5 years ago
4 years ago

People

(Reporter: jaws, Unassigned)

Tracking

23 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

There are two settings that require a restart: Enable Chrome Debugging and Enable Remote Debugging.

The text above them states that they will require a restart. If someone changes one of them, we should display a "Restart &brandShortName;" button within the Advanced Settings area.

This is useful because there is no simple way to restart Firefox and maintain the session if someone has disabled the "Show my windows and tabs from last time" setting, and even then it would require the user to exit Firefox and relaunch it. 

This feature could probably use the same approach that the Restartless Restart add-on uses.
There is now a text link to restart, but I didn't check to see what bug added it.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: dupeme
Resolution: FIXED → DUPLICATE
Duplicate of bug: 881807

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.