Closed Bug 881807 Opened 6 years ago Closed 6 years ago

Simplify 'advanced settings' part of options panel

Categories

(DevTools :: Framework, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 24

People

(Reporter: jwalker, Assigned: Optimizer)

References

Details

(Whiteboard: [fixed-in-fx-team])

Attachments

(1 file, 1 obsolete file)

There are too many * and so on. How about:

----

[ ] Enable chrome debugging
[ ] Enable remote debugging
[ ] Disable JavaScript
    (This session only, will reload page)

----

When either of the first 2 are enabled we show an alert that says 'need to restart'.

The definition of 'session' is vague, but probably good enough to ensure people are not surprised.

Thoughts?
I agree. Although I think that the double dagger I added in bug 872670 might be actually useful (removes redundant text in case of multiple non supported tools) and its not an always visible thing too.
Assignee: nobody → scrapmachines
Enable chrome debugging and enable remote debugging both require a browser restart ... how would you like us to represent that?
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #2)
> Enable chrome debugging and enable remote debugging both require a browser
> restart ... how would you like us to represent that?

We have many options:
- A notification door hanger, just like when you install a normal addon, it says restart now.
- A notification panel on toolbox with a button to restart
- A div at the bottom, just like IE's notification system, with a button to restart.
(In reply to Girish Sharma [:Optimizer] from comment #3)
> (In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #2)
> > Enable chrome debugging and enable remote debugging both require a browser
> > restart ... how would you like us to represent that?
> 
> We have many options:
> - A notification door hanger, just like when you install a normal addon, it
> says restart now.
> - A notification panel on toolbox with a button to restart
> - A div at the bottom, just like IE's notification system, with a button to
> restart.

They would all happen after the checkbox is clicked and I think that being forewarned is better. I think that mixing the two methods will be fine, especially because "this session only" is only ever likely to be linked with one option:
[ ] Enable chrome debugging *
[ ] Enable remote debugging *
[ ] Disable JavaScript
    (This session only, will reload page)

* Requires restart
Assignee: scrapmachines → nobody
Status: NEW → ASSIGNED
Assignee: nobody → scrapmachines
Duplicate of this bug: 882560
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #4)
> (In reply to Girish Sharma [:Optimizer] from comment #3)
> > (In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #2)
> > > Enable chrome debugging and enable remote debugging both require a browser
> > > restart ... how would you like us to represent that?
> > 
> > We have many options:
> > - A notification door hanger, just like when you install a normal addon, it
> > says restart now.
> > - A notification panel on toolbox with a button to restart
> > - A div at the bottom, just like IE's notification system, with a button to
> > restart.
> 
> They would all happen after the checkbox is clicked and I think that being
> forewarned is better.

How does being forewarned make a difference? You click the checkbox, get a popup, and maybe a restart link appears. How is your life better/worse off compared to if you knew that you would have to restart before you clicked the checkbox?

On the other hand, having the text there slows everyone down because it gives you more to read.
(In reply to Joe Walker [:jwalker] from comment #6)
> (In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #4)
> > (In reply to Girish Sharma [:Optimizer] from comment #3)
> > > (In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #2)
> > > > Enable chrome debugging and enable remote debugging both require a browser
> > > > restart ... how would you like us to represent that?
> > > 
> > > We have many options:
> > > - A notification door hanger, just like when you install a normal addon, it
> > > says restart now.
> > > - A notification panel on toolbox with a button to restart
> > > - A div at the bottom, just like IE's notification system, with a button to
> > > restart.
> > 
> > They would all happen after the checkbox is clicked and I think that being
> > forewarned is better.
> 
> How does being forewarned make a difference? You click the checkbox, get a
> popup, and maybe a restart link appears. How is your life better/worse off
> compared to if you knew that you would have to restart before you clicked
> the checkbox?
> 
> On the other hand, having the text there slows everyone down because it
> gives you more to read.

My point was that people have a tendency not to read notifications and may be surprised when settings do not immediately take effect.
+1 for just adding a Restart link after toggling, and not cluttering up the panel before.

Maybe just add text right below the pref after toggling:
"This option requires a restart [Restart Now]"
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #7)
> (In reply to Joe Walker [:jwalker] from comment #6)
> > (In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #4)
> > > (In reply to Girish Sharma [:Optimizer] from comment #3)
> > > > (In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #2)
> > > > > Enable chrome debugging and enable remote debugging both require a browser
> > > > > restart ... how would you like us to represent that?
> > > > 
> > > > We have many options:
> > > > - A notification door hanger, just like when you install a normal addon, it
> > > > says restart now.
> > > > - A notification panel on toolbox with a button to restart
> > > > - A div at the bottom, just like IE's notification system, with a button to
> > > > restart.
> > > 
> > > They would all happen after the checkbox is clicked and I think that being
> > > forewarned is better.
> > 
> > How does being forewarned make a difference? You click the checkbox, get a
> > popup, and maybe a restart link appears. How is your life better/worse off
> > compared to if you knew that you would have to restart before you clicked
> > the checkbox?
> > 
> > On the other hand, having the text there slows everyone down because it
> > gives you more to read.
> 
> My point was that people have a tendency not to read notifications and may
> be surprised when settings do not immediately take effect.

Right, but I'm not sure we can't use "people don't read" as a reason to have more text.

Heather's solution is nice - possibly harder than an alert, but would look nicer, and due to the link, be easier to use.
I was thinking this : 
- A div at the bottom, just like IE's notification system, with a button to restart.

(the third option from my suggestions)

This should be :
- Catching enough  to get attention.
- Has the restart button to be helpful
- Is temporary, less clutter, clearly laid out to say that "restart is required"
(In reply to Girish Sharma [:Optimizer] from comment #10)
> I was thinking this : 
> - A div at the bottom, just like IE's notification system, with a button to
> restart.
> 
> (the third option from my suggestions)
> 
> This should be :
> - Catching enough  to get attention.
> - Has the restart button to be helpful
> - Is temporary, less clutter, clearly laid out to say that "restart is
> required"

Is there an advantage to putting the div at the bottom? Isn't that just further for your eye and mouse to travel?

How about this combination of all the ideas:

[ ] Disable JavaScript
    (This session only, will reload page)
[ ] Enable chrome debugging
[ ] Enable remote debugging
    <Browser restart required [Restart]>

(The section in <...> is hidden unless a browser restart is required, i.e. when the state of either of the 2 'enable ... debugging' checkboxes isn't what it was to start with)
(In reply to Joe Walker [:jwalker] from comment #11)
> (In reply to Girish Sharma [:Optimizer] from comment #10)
> > I was thinking this : 
> > - A div at the bottom, just like IE's notification system, with a button to
> > restart.
> > 
> > (the third option from my suggestions)
> > 
> > This should be :
> > - Catching enough  to get attention.
> > - Has the restart button to be helpful
> > - Is temporary, less clutter, clearly laid out to say that "restart is
> > required"
> 
> Is there an advantage to putting the div at the bottom? Isn't that just
> further for your eye and mouse to travel?
> 
> How about this combination of all the ideas:
> 
> [ ] Disable JavaScript
>     (This session only, will reload page)
> [ ] Enable chrome debugging
> [ ] Enable remote debugging
>     <Browser restart required [Restart]>
> 
> (The section in <...> is hidden unless a browser restart is required, i.e.
> when the state of either of the 2 'enable ... debugging' checkboxes isn't
> what it was to start with)

+1 to Joe's suggestion.
Agreed to Joe. On it now.
Attached patch patch v1.0 (obsolete) — Splinter Review
Makes the changes as required as per the discussions above.
Attachment #765558 - Flags: review?(jwalker)
Attached patch patch v1.1Splinter Review
forgot to save osx/toolbox.css before qref'ing
Attachment #765558 - Attachment is obsolete: true
Attachment #765558 - Flags: review?(jwalker)
Attachment #765559 - Flags: review?(jwalker)
Depends on: 872670
Note that this bug and bug 872670 should be landed in the same push, 872670 first then this
Attachment #765559 - Flags: review?(jwalker) → review+
Whiteboard: [land-in-fx-team]
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7c1c4bb1263a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 24
Duplicate of this bug: 868903
Depends on: 985531
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.