currentset should return defaultset if it doesn't have a value, so add-ons don't reset the toolbar

RESOLVED INVALID

Status

()

Firefox
Toolbars and Customization
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: jorgev, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Bug 868820 and probably others are caused by incorrect manipulation of the button set in a toolbar before any other customizations have happened.

According to bug 868820 comment 5, the problem is that getting the currentset when no customizations have happened will get you a blank string. In those cases, one should ask for defaultset instead. However, if currentset were never blank, this problem would be avoided entirely. I don't know if there's a reason for this, but we should reconsider it, given that the incorrect usage of this property can lead to blank toolbars and lots of user confusion.
Toolbars' currentSet property returns a string containing all present elements even when no customization happened. People should use that.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Depends on: 903905
You need to log in before you can comment on or make changes to this bug.