Closed Bug 869199 Opened 7 years ago Closed 3 months ago

[SkiaGL] Investigate terrible performance on FishIE with Skia

Categories

(Core :: Graphics, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: gw280, Unassigned)

References

Details

22:53 < snorp> gw280: though there is 24% of time in libglesv2
22:54 < snorp> gw280: I bet it does something stoopid with the geometry
22:54 < snorp> gw280: I assume that's skiagl

This isn't to say that's the issue; this bug is to try and find out what's going on.
I could ran FishIE on my leo device and got 11 fps with skiaGL enabled.
And it didn't take too much memory as everything.me app.
Please skip comment 1.

I couldn't run fish ie on unagi because out of memory. 
Now I'm asking perf support on leo device.

(In reply to peter chang[:pchang] from comment #1)
> I could ran FishIE on my leo device and got 11 fps with skiaGL enabled.
> And it didn't take too much memory as everything.me app.
Assignee: nobody → pchang
Hi Peter, any update?
Flags: needinfo?(pchang)
unassigned myself.
Assignee: pchang → nobody
Flags: needinfo?(pchang)
Need better STR on this bug if we're going to make it actionable.  George, what device, what exactly are you running, what exact performance are you seeing, etc.?
Flags: needinfo?(gwright)
This is very old. I don't remember what exactly we were seeing, but given that FishIE is now a standard test run by QA I think we're ok here?
Flags: needinfo?(gwright)
I don't know about it being a standard test, but there was recently work that dealt with the scenario where we were thrashing in bug 1042305, so if you're not seeing the symptoms, let's close this bug.

SkiaGL was removed by bug 1530471.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.