Bug 1186552 (Backendnuken)

[meta] Project Backendnuken - Skia backend unless accelerated Windows

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

(Depends on: 3 bugs, Blocks: 1 bug, {feature})

Trunk
feature
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(relnote-firefox 51+)

Details

(Whiteboard: [gfx-noted])

(Assignee)

Description

3 years ago
Delete all backends other than D2D 1.1 and replace them with Skia.

Updated

3 years ago
Whiteboard: [gfx-noted]
(Assignee)

Updated

3 years ago
Depends on: 1188680
Depends on: 1207332
(Assignee)

Updated

2 years ago
Depends on: 1258751
(Assignee)

Updated

2 years ago
Alias: Backendnuken
(Assignee)

Updated

2 years ago
Duplicate of this bug: 687187
(Assignee)

Updated

2 years ago
Assignee: nobody → mchang
(Assignee)

Updated

2 years ago
Depends on: 1244754
(Assignee)

Updated

2 years ago
Depends on: 1278957
Summary: [meta] Project Backendnuken → [meta] Project Backendnuken - Skia backend unless accelerated Windows

Updated

2 years ago
Keywords: feature
Hi :mchang,
Will this feature be in 51? There are still a few bugs here.
Flags: needinfo?(mchang)
(In reply to Gerry Chang [:gchang] from comment #2)
> Hi :mchang,
> Will this feature be in 51? There are still a few bugs here.

We backed out Skia content for Windows for now while Mason is on PTO. We will look into the bugs more thoroughly when he gets back.
Flags: needinfo?(mchang)
Added to Fx51 (Aurora) release notes.
relnote-firefox: --- → 51+
(Assignee)

Comment 5

2 years ago
(In reply to Gerry Chang [:gchang] from comment #4)
> Added to Fx51 (Aurora) release notes.

I think this should be for 52 for Windows. Skia on OS X was 48. 51 is for Linux / Android.

Skia is now the default content backend everywhere. Resolving this as WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
I'm a bit confused by the last three comments. 

Mason, is this feature still shipping with Fx52 for Windows?

Should manual QA be tracking this? 
We had a more in-depth testing session on a similar bug in the past (Bug 1270688) and was wondering if there's anything we can help with here as well.
Flags: needinfo?(mchang)
(Assignee)

Comment 7

2 years ago
(In reply to Andrei Vaida, QA [:avaida] – please ni? me from comment #6)
> I'm a bit confused by the last three comments. 
> 
> Mason, is this feature still shipping with Fx52 for Windows?

Yes this is.

> 
> Should manual QA be tracking this? 
> We had a more in-depth testing session on a similar bug in the past (Bug
> 1270688) and was wondering if there's anything we can help with here as well.

Thanks for the offer! You can just use Nightly as usual on Windows and see if you see any big problems. You can compare this with cairo, which was happening before this on Windows. Please try this:

1) Go to about:config
2) Set "layers.acceleration.disabled" to true.
3) Restart nightly. Go to about:support and make sure "AzureContentBackend" says Skia

Then compare this to:
1) Go to about:config
2) Set "layers.acceleration.disabled" to true and "gfx.content.azure.backends" is "cairo"
3) Restart nightly. Go to about:support and make sure "AzureContentBackend" says Cairo.

Just see if there are any regressions? Thanks!
Flags: needinfo?(mchang) → needinfo?(andrei.vaida)
Thank you for following up on this so quickly! We'll draft a Test Plan for this as soon as possible and start test case creation based on your instructions.

I'm thinking that we should treat this as a full blown feature, since it might cause regressions for users without hardware acceleration. 

Mason, if you think it would be enough for QA to just treat this as regular bug work while it rides the trains, please let me know.
Flags: needinfo?(andrei.vaida) → qe-verify+
QA Contact: mihai.boldan
You need to log in before you can comment on or make changes to this bug.