If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"File Bookmark for Link..." for mailto: urls should be "Add to Addressbook"

RESOLVED DUPLICATE of bug 137010

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED DUPLICATE of bug 137010
17 years ago
9 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Bring up a context menu in the browser on any link that is a mailto: url.

Actual results:
- context menu contains "Bookmark this link" item which allows you to add the
mailto: url to your bookmarks list. Not so useful.

Expected results:
- context menu contains "Add to Addressbook" item which adds email address as
new contact to abook. More useful.

Implementation hints:
a)  should be easy way of doing this exposed by abook.
b)  the code for this item should live in abook and dynamically overlay in (so
the item is not present if abook is not installed).
should this go to candice?

Comment 2

16 years ago
*** Bug 89564 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
*** Bug 89444 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
usability/polish, 0.9.4.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.4

Updated

16 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 5

16 years ago
Updating summary to reflect the change in context menu...
"Bookmark this link" has been changed to "File Bookmark for Link..."
Summary: "Bookmark this link" for mailto: urls should be "Add to Addressbook" → "File Bookmark for Link..." for mailto: urls should be "Add to Addressbook"

Comment 6

16 years ago
Mass moving lower-priority bugs to 0.9.6 (with Blake's pre-consent) to make room
for remaining 0.9.4/eMojo bugs and MachV planning, performance and feature work.
 If anyone disagrees with the new target, please let me know.
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.8

Comment 7

16 years ago
The context menu for mailto: urls when reading messages in the mail/news
component should also have this option.

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Updated

16 years ago
Target Milestone: mozilla0.9.9 → Future

Comment 8

16 years ago
-> ben
Assignee: blaker → ben
Status: ASSIGNED → NEW
Target Milestone: Future → ---
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Product: Core → Mozilla Application Suite
(this bug is a year older but 137010 already has dependencies, so...)
duping to 137010
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 137010

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.