Closed Bug 87107 Opened 21 years ago Closed 13 years ago

"Get all new messages" in news server context menu

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0

People

(Reporter: timr, Assigned: InvisibleSmiley)

References

(Blocks 1 open bug, )

Details

(Keywords: fixed-seamonkey2.0, polish)

Attachments

(1 file)

When right-clicking on a news server name in the 3-pane window, it would be nice
to get a "get all new messages" option in the context menu.  This option would
check for new messages in all newsgroups.  Currently it seems the only way to do
this is to collapse and then reopen the tree display for that server's newsgroups.
If you right click onto a newsgroup you should see a "Get Messages for Account" 
option which should get new news messages. You are right that this option does 
not exist for the news server level. This matches the 3Pane Mail Menus 
Specification 
(http://mozilla.org/mailnews/specs/threepane/MailMenus.html#standalone). 

I like your suggestion. It would be helpful when you have alot of newsgroups.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: esther → nbaca
Dunno whether this exists or not, but there should also be a "Get All New
Headers" in all groups item, too.
OS: Windows 2000 → All
Hardware: PC → All
This is asking for a feature which would get all new messages for each separate 
newsgroup associated with a particular News Server?  That correct?

I thought we did not get new Newsgroup messages until that particular newsgroup 
was selected?  The reason being it would very time consuming to get all new 
messages for each separate Newsgroup associated with a particular News Server.
Apologies for spamming, but I just wanted to address jglick@netscape's comment.
 What I'm asking for is a context menu item which basically does the same thing
as closing and then reopening the current news server twisty.  (Or opening the
twisty of an already closed news server.)  I don't believe that it's introducing
lossy behavior into mailnews, but rather just offering a more convenient and
intuitive way of accessing existing functionality.
*** Bug 111170 has been marked as a duplicate of this bug. ***
I changed QA contact from nbaca to olgam.
QA Contact: nbaca → olgam
Blocks: 158011
Product: Browser → Seamonkey
Assignee: sspitzer → mail
*** Bug 359354 has been marked as a duplicate of this bug. ***
Assignee: mail → nobody
QA Contact: olgam → message-display
Summary: RFE: "Get all new messages" in news server context menu → "Get all new messages" in news server context menu
The backend function GetFolderMessages() in mailWindowOverlay.js, invoked through MsgGetMessage(), is already capable of this, it just needs to be activated. Since canGetMessages is only used for this context menu item all we have to do is adapt it.
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #402164 - Flags: superreview?(neil)
Attachment #402164 - Flags: review?(mnyromyr)
Attachment #402164 - Flags: superreview?(neil) → superreview+
Attachment #402164 - Flags: review?(mnyromyr) → review+
Comment on attachment 402164 [details] [diff] [review]
proposed patch
[Checkin: Comment 11]

Nice!
Comment on attachment 402164 [details] [diff] [review]
proposed patch
[Checkin: Comment 11]

Simple patch, eases updating a complete news server.
Attachment #402164 - Flags: approval-seamonkey2.0?
Attachment #402164 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
Keywords: checkin-needed
Comment on attachment 402164 [details] [diff] [review]
proposed patch
[Checkin: Comment 11]


http://hg.mozilla.org/comm-central/rev/dc6e9214c56b
Attachment #402164 - Attachment description: proposed patch → proposed patch [Checkin: Comment 11]
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: checkin-neededpolish
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0
You need to log in before you can comment on or make changes to this bug.