Closed Bug 87121 Opened 19 years ago Closed 19 years ago

Mouseover an image doesn't display the "ALT" tag

Categories

(Core :: Layout, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 25537

People

(Reporter: phil, Assigned: clayton)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1+) Gecko/20010621
BuildID:    2001062104

Mouseover the image containing the vulture at the top of the page does not
display the ALT tag for the image

Reproducible: Always
Steps to Reproduce:
1. Open http://www.theregister.co.uk
2. Move your mouse over the central image at the top of the page
3.

Actual Results:  No alt tag displayed

Expected Results:  A box showing the ALT tag contents (as with Netscape 4.77 and
IE 5.5)
dup of bug 62046?
Not a dupe of bug 62046, as that one deals with broken or non-loaded images. 
But I would suggest giving up on this.  I, and I don't know how many others,
have filed many, many bugs in the past for this, and the Mozilla folks simply
refuse to fix it because "it's wrong."

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
The reason why Mozilla folks say "it's wrong" is because, er, it's wrong. Alt
text (it's not a tag) is meant to be displayed when the image isn't. It's
alternative text, not supplementary text. When the 4.x browsers started
displaying alt text as tooltips, people started using it for captions that
required the user to be looking at the image. This harms accessibility. Captions
for images should be added using the title attribute of the <img> tag.
Alex, I realize that.  But it still doesn't change the fact that there are still
web pages out there that use it in a way that you pretty much need to see the
ALT text to navigate, and aren't likely to change.  I've brought this up before,
that at the least, it seems like this "feature" could be supported in Quirks
mode.  Web designers who don't know about TITLE are most likely writing pages
that are Quirks mode anyway.  Or, do like IE does, and support both ALT and
TITLE as tooltips, with TITLE taking precedence.  When you get down to it,
Mozilla supports a whole bunch of other "wrong" things for the sake of backward
compatibility, or for Quirks mode.  What's one more? :)
The decision was made that Gecko should follow the W3C spec exactly. The specs
say that alt text should only be displayed when the image isn't there. This
behaviour is followed correctly in Netscape Navigator 1.x, 2.x, 3.x and 6.x -
it's just 4.x that gets it wrong. Switching to full standards support does mean
making a clean break from some common conventions. It's painful, but the
benefits are worth it. There's still some sites that use the <layer> tag, but
support for that has been dropped; why is alt text any different?

I believe there is a bug that will allow users to access the metadata associated
with images (alt text, dimensions, size, format, longdesc etc.). This will
probably be available in the Properties window. I don't know the bug number
off-hand, sorry.

The best way to convince a site to stop using alt text in such a way that the
user needs to be able to see both the image and the alt text is to stop
displaying alt text as a tooltip. If you see any sites doing this, file bugs
setting the Product as "Browser" and the Component as "Evangelism" and Mozilla's
standards compliance hit squad will get onto them.
Alex, sorry, I didn't realize that not displaying ALT as a tooltip was actually
a W3C spec.  The impression I'd gotten from the other discussions on this was
that it was more of a "recommendation."  Also didn't know NS 3.x didn't do this,
either.

Of course, the LAYERS comparison isn't entirely valid, since I would guess that
involves a lot more work than this bug would.  Anyway, thanks for the helpful
comments.
"I didn't realize that not displaying ALT as a tooltip was actually
a W3C spec."

I'm not sure if it explicitly says "Don't display alt text as tooltips" in the
spec, but it does say that it's supposed to be an alternative to an image, which
amounts to pretty much the same thing.

"Also didn't know NS 3.x didn't do this, either."

Yeah, the addition of alt text tooltips was an 'enhancement' that debuted in
4.0. In my opinion it was a bad idea but I imagine no-one realised the problems
it would introduce. They made up for it by giving us drop-down lists on the Back
and Forward buttons though. :-)
vrfy dup
Status: RESOLVED → VERIFIED
SPAM. HTML Element component is deprecated, changing to Layout component. See
bug 88132 for details.
Come on Bugzilla, you can do it...
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.