remove dev-apps-firefox newsgroup/mailing list

RESOLVED FIXED

Status

Infrastructure & Operations
MOC: Service Requests
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: »Q«, Assigned: Usul)

Tracking

Details

(Whiteboard: [waiting for Giganews])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130412164743

Steps to reproduce:

See http://www.gavinsharp.com/blog/2013/02/26/announcing-the-firefox-dev-mailing-list/

Now that traffic has moved from mozilla.dev.apps.firefox/dev-apps-firefox, the old group and list should should be removed so that people stop seeing them as a way to communicate with devs.
(Reporter)

Comment 1

5 years ago
I tried to CC list owner address, but bugzilla won't let me.  M.Beltzer and G.Sharp are the owners, and the list/group shouldn't be removed unless they concur.

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

5 years ago
Also suggest that any other dev groups that are deemed as defunct should also be removed.
We should disallow posts to the list by whatever means we have to do so. Adding an automated reply suggesting posting to firefox-dev might be nice, too. I don't want to lose archives, though.
Justdave: I know you've shut one of these down in an archive-preserving way before. Can you clue us in as to how it's done? mburns might have known, but he's no longer here.

Gerv
Flags: needinfo?(justdave)
Google automatically preserves archives on the Google Group and disallows posting when we terminate the list on our end, that's the default case, and nothing special to be done.  We have to jump through a ton of hoops if we want them to NOT preserve it.
Flags: needinfo?(justdave)
OK, sounds like it's up to server-ops to actually make this change.
Assignee: gerv → server-ops
Removed the list, waiting for Giganews to follow.
Assignee: server-ops → ashish
Status: NEW → ASSIGNED
Whiteboard: [waiting for Giganews]
Okay, Giganews says they don't have this list on their servers. I'm unable to find the list creation bug, can somebody provide that? Thanks!
It was one of the original lists created when we set up the deal with GigaNews, AFAIK. I doubt there was a bug.

Logging in to news.mozilla.org using http://newsgroupstats.info certainly lists it.
It's "mozilla.dev.apps.firefox" there, though, maybe that's throwing them off?
(Reporter)

Comment 11

5 years ago
It's there.  This short session log might help them find the right one to rmgroup.

$ telnet news.mozilla.org 119
Trying 216.196.97.169...
Connected to news.mozilla.org.
Escape character is '^]'.
200 news.mozilla.org
> group mozilla.dev.apps.firefox
211 20886 2 20887 mozilla.dev.apps.firefox
mozilla.dev.apps.firefox it is, thanks guys. I've updated Giganews.
Does Google Groups really have the full archive?  And do we really want to rely on Google for preserving archives that are important to us?
It would be nice to have a copy of Giganews' archive.

Ashish: is that something we can request?
I've requested Giganews for a status update. There seems to be some ambiguity with the status on their servers. Awaiting their response.
Giganews has archived the list.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [waiting for Giganews]
(Reporter)

Comment 17

5 years ago
The news server continues to accept and index articles for the group.  This bug should be open until that stops.  

<https://groups.google.com/forum/message/raw?msg=mozilla.dev.apps.firefox/81wczonguqk/UrJbZFZhiU4J>
Fair enough, I've requested Giganews to set the group read-only.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [waiting for Giganews]
I'm taking over on this for now, since ashish is going on PTO for a few weeks.
Assignee: ashish → justdave
no progress was made on this while ashish was gone :(  and he's back now...
Assignee: justdave → ashish

Comment 21

5 years ago
It looks like there are still new posts being made in https://groups.google.com/forum/#!forum/mozilla.dev.apps.firefox . What needs to happen in order to make that impossible, so people don't have the (wrong!) impression that other folks are actually reading that?
The list is no longer present on https://lists.mozilla.org/newsgroups.txt
Google is supposed to poll that file daily and change the settings on the groups accordingly. A group that used to be present disappearing is supposed to indicate that it's supposed to be set to archived/read-only status.  The fact that it didn't do so sounds like they have a bug on their end.
Ashish: are you still working with Google on this?

Gerv
Assignee: ashish → gerv
Ashish: why did you assign this back to me? I'm not sure I can do anything - I don't control the config of these systems. 

This group still seems to be living a zombie existence, and needs killing properly. Usul has been working on similar bugs recently - perhaps he could fix it?

Gerv
Flags: needinfo?(ashish)
I unassigned for someone to pick this up and since you're the default assignee, it just happened to assign to you.
Flags: needinfo?(ashish)
Over to MOC; this won't get picked up unless it's there.

Gerv
Assignee: gerv → nobody
Component: Discussion Forums → MOC: Service Requests
Product: mozilla.org → Infrastructure & Operations
QA Contact: justdave → lypulong
(Assignee)

Updated

2 years ago
Assignee: nobody → ludovic
(Assignee)

Comment 27

2 years ago
Emailed googl support about this.
(Assignee)

Comment 28

2 years ago
Our tool actually didn't support archiving groups if they were removed, I've added that and archived >100 groups including that one.

That's in the nntp path, that will sync to the groups frontend in the next day.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago2 years ago
Resolution: --- → FIXED
Whiteboard: [waiting for Giganews]
(Reporter)

Comment 29

2 years ago
The group is still active and accepting posts on Giganews' news.mozilla.org server, so I'm afraid this needs re-opening.
(Assignee)

Comment 30

2 years ago
(In reply to »Q« from comment #29)
> The group is still active and accepting posts on Giganews' news.mozilla.org
> server, so I'm afraid this needs re-opening.

I'll look into that tomorrow
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 31

2 years ago
re-emailed giganews
(Assignee)

Updated

2 years ago
Whiteboard: [waiting for Giganews]
(Assignee)

Comment 32

2 years ago
removed by giganews.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.