Closed Bug 871318 Opened 7 years ago Closed 6 years ago

Image slideshow on Instagram profiles is broken with NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIDOMWindow.requestAnimationFrame]

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86_64
Windows 7
defect
Not set

Tracking

(firefox22 unaffected, firefox23 affected, firefox24 affected, firefox25 affected, firefox26 affected)

RESOLVED FIXED
Tracking Status
firefox22 --- unaffected
firefox23 --- affected
firefox24 --- affected
firefox25 --- affected
firefox26 --- affected

People

(Reporter: epinal99-bugzilla2, Unassigned)

References

Details

(Keywords: regression)

Maybe TE bug.

STR:
1) Open Instagram profile like http://instagram.com/nike
2) Click on a picture

Result: the picture is loaded in a 2nd tab instead of being loaded in the main tab as overlay (slideshow). In addition, clicking on a 2nd image has no effect.

Web console:
[22:58:38.645] NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIDOMWindow.requestAnimationFrame] @ http://d36xtkk24g8jdx.cloudfront.net/bluebar/940199e/cache/modules/lib/fullpage/transitions.js:71

Regression range:
m-c
good=2013-04-25
bad=2013-04-26
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=690b5e0f6562&tochange=a6104e0e5a2c

Suspected bugs:
Boris Zbarsky — Bug 704063. Add an unprefixed version of requestAnimationFrame. r=roc, sr=smaug
Boris Zbarsky — Bug 753453. Add a way for us to pass a high-res timestamp to requestAnimationFrame callbacks. r=roc
Component: Untriaged → DOM
Keywords: regression
Product: Firefox → Core
Looks like the following code:

define("framework/setImmediate", ["require", "exports", "module"],
function (e, t, n) {
    function u() {
        s = false;
        for (var e, t; (t = r.next) && !t.begun; r = t) {
            t.begun = true;
            try {
                t.cb.call(t.ctx || null)
            } catch (n) {
                e = e || [n]
            }
        }
        if (e) throw e[0]
    }
    var r = {},
        i = r,
        s = false,
        o;
    if (typeof MessageChannel != "undefined") {
        var a = new MessageChannel;
        a.port1.onmessage = u,
        o = function () {
            a.port2.postMessage()
        }
    } else {
        typeof requestAnimationFrame != "undefined"
            ? o = requestAnimationFrame
            : o = function () {
                setTimeout(u, 0)
            };
    }
    n.exports = function (e, t) {
        i = i.next = {
            cb: e,
            ctx: t
        };
        if (s) return;
        s = true,
        o()
    }
})

ends up with o = requestAnimationFrame now, and then continues to call it without arguments, which is bogus. I can't find if this is part of a library or instagram's own code.

TE, IMO, unless this turns out to be widespread.
Hmm.  So Chroem has an unprefixed requestAnimationFrame that throws if there are no arguments, but in Chrome this web page takes the MessageChannel codepath.

So yeah, I would start with evangelism.  Anyone willing to take the time to contact them?  Lawrence, do you know whether we have contacts here?
Flags: needinfo?(lmandel)
Redirecting to me - I've got the contact here for instagram.
Flags: needinfo?(lmandel)
Flags: needinfo?(jsmith)
I just fired off an email to my contact with this bug information and cc-ed Boris on the email.
Flags: needinfo?(jsmith)
Assignee: nobody → english-us
Component: DOM → English US
Product: Core → Tech Evangelism
Version: 23 Branch → Trunk
How close is this issue to the release channel? In current Aurora it's still broken...
Which issue?  The bug in this case is with the website, not with our code...

If you're an Instagram user and this is affecting you, please contact them to let them know their site is broken.
Duplicate of this bug: 910180
Duplicate of this bug: 907824
Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131014080339 CSet: ab8e70fb76a8

seems to be fine/fixed.
fixed by site itself ?
or by Firefox check-in ?
I guess it has been fixed by Instagram itself.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.