[STK] launch browser doesn't work properly

RESOLVED FIXED in Firefox OS v1.1hd

Status

Firefox OS
Gaia::Settings
P1
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gecko, Assigned: frsela)

Tracking

({regression})

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: [TD-10819])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 748640 [details]
attach file include main, radio log and video

From attached logs,  when the launch browser command is executed,  it seems that  browser is launched. However, settings app is immediately brought again to foreground. (may be due to some STK commands, not sure though)
(Reporter)

Updated

5 years ago
Severity: normal → major
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
Whiteboard: [TD]10819 → [TD-10819]
Target Milestone: --- → 1.1 QE2
(Reporter)

Comment 1

5 years ago
if you want to take a test about this case, you must have VIVO operator sim card.
After insert simcard and finish booting, you can see STK menu in setting app.

Comment 2

5 years ago
(In reply to leo.bugzilla.gecko from comment #1)
> if you want to take a test about this case, you must have VIVO operator sim
> card.
> After insert simcard and finish booting, you can see STK menu in setting app.

After finish booting, in the idle mode - settings - Movistar - launch browser - browser basico ( it is located in setting menu)

Comment 3

5 years ago
New feature, unimplemented requirement, or regression? needinfo ffos-product
Flags: needinfo?(ffos-product)

Comment 4

5 years ago
when we confirm this issue, we found additional information. 

<gaia/apps/settings/js/icc.js>

function init() {
......
icc.addEventListener('stkcommand', function do_handleSTKCmd(event) {
      handleSTKCommand(event.command);
    });
window.addEventListener('stkasynccommand',
      function do_handleAsyncSTKCmd(event) {
      handleSTKCommand(event.detail.command);
      });
......

Comment 5

5 years ago
when we confirm this issue, we found additional information. 

<gaia/apps/settings/js/icc.js>

function init() {
......
icc.addEventListener('stkcommand', function do_handleSTKCmd(event) {
      handleSTKCommand(event.command);
    });
window.addEventListener('stkasynccommand',
      function do_handleAsyncSTKCmd(event) {
      handleSTKCommand(event.detail.command);
      });
......

When the Launch Browser Command executed, the handleSTKCommand function is called twice.(icc EventListener and window EventListner).
Flags: needinfo?(akeybl)
Flags: needinfo?(ffos-product) → needinfo?(pdolanjski)

Comment 6

5 years ago
this is regression issue. when we take a test about this issue, it operated properly in qe1 version. but the problem has occured in qe2 version.    

<QE1 version>
gaia     : 663101b6eb809383e5882d9bc3868a923a57998a
gecko    : 0b83d5e6a54df9bfccdbb5ba662527bf657f5381

<QE2 version>
gaia     : d5f7b2d3f7acc04c35abda8b001262d8912f9dfe
gecko    : 0ab3418551bfcefe1e14633f8f2b0422707a4c2f
Is this a dupe of 865985?

Comment 8

5 years ago
No, it is different 865985. although mobile phone has implented launch browser in STK menu, 
mobile phone still shows stk menu. In my opinion, ME should show browser app and stk menu is located in background.
plz confirm attached video clip.
Triage - Leo+, a regression according to comment 6.
blocking-b2g: leo? → leo+
Keywords: regression

Comment 10

5 years ago
When we analyze icc.js, icc_menu.js, icc_cache.js in setting app's code, there is another problem. Although browser is implemented one time, browser tab is three except for basic tab one. I think that browser is actually implemented twice.   

UICC                 -------------------->            Mobile phone
                proactive command(launch browser)

icc_cache.js receive stkcommand and send stkcommand event to icc.js. And launch browser is implemented. However, icc_menu.js also send stkasynccommand event to icc.js. 
Therefore, this is the reason launch browser is implemented twice.
frsela - are you the right assignee for this leo+ bug?
Assignee: nobody → frsela
Flags: needinfo?(akeybl)
(In reply to Alex Keybl [:akeybl] from comment #11)
> frsela - are you the right assignee for this leo+ bug?

I'll check why the message is processed twice

Comment 13

5 years ago
(In reply to Fernando R. Sela [:frsela] from comment #12)
> (In reply to Alex Keybl [:akeybl] from comment #11)
> > frsela - are you the right assignee for this leo+ bug?
> 
> I'll check why the message is processed twice

How does it proceed about checking this problem??
I know that you have plan to code refactoring about simtoolkit code.(bugzilla : 875679)
is it possible to fix this problem, when you proceed code refactoring??
Flags: needinfo?(frsela)
Duplicate of this bug: 877506

Comment 15

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.108

Mozilla build ID: 20130526070207

FFOS os version : 1.1.0.0 

I have attached log file.(Log_enable_debug.7z) you can check more detail log, 
because it is enabled debug value from system app (icc_cache.js file DEBUG variable) and settings app (utils.js DEBUG variable). 
plz confirm this log.

Comment 16

5 years ago
Created attachment 756366 [details]
log file .(enable debug value from false to true)
Flags: needinfo?(pdolanjski)
(In reply to Leo from comment #13)
> (In reply to Fernando R. Sela [:frsela] from comment #12)
> > (In reply to Alex Keybl [:akeybl] from comment #11)
> > > frsela - are you the right assignee for this leo+ bug?
> > 
> > I'll check why the message is processed twice
> 
> How does it proceed about checking this problem??
> I know that you have plan to code refactoring about simtoolkit
> code.(bugzilla : 875679)
> is it possible to fix this problem, when you proceed code refactoring??

Sure, we've it in our radar ;)
Flags: needinfo?(frsela)

Updated

5 years ago
Depends on: 880352

Updated

5 years ago
No longer depends on: 875679

Updated

5 years ago
Target Milestone: 1.1 QE2 (6jun) → 1.1 QE3 (24jun)
880352 landed in master, can you retest this issue again?
Thanks in advance
Flags: needinfo?(leo.bugzilla.gecko)

Comment 19

5 years ago
With patch, leo works correctly. Thank you.
Flags: needinfo?(leo.bugzilla.gecko)
\o/ solved with 880352
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
fixed on branch
status-b2g18: --- → fixed
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.