Closed Bug 871410 Opened 7 years ago Closed 7 years ago

Video playback error after refreshing a direct linked content.

Categories

(Core :: Audio/Video, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED DUPLICATE of bug 871485
1.1 QE2 (6jun)
blocking-b2g leo+
Tracking Status
b2g18 + ---

People

(Reporter: leo.bugzilla.gaia, Assigned: cajbir)

References

Details

(Whiteboard: [TD-26566] c=video, MiniWW)

1. Title : [BROWSER] Video stream playback error after refreshing web page
2. Precondition : 
3. Tester's Action : 
                1) Go to some site which contains video downloadable content
                2) Click on the link, which normally is used to download it
                3) Watch the stream and next try to refresh several times
4. Detailed Symptom (ENG.) : When refreshing there is sometimes error on video preview 
5. Detailed Symptom (KOR.) : 
6. Expected : No refreshing problems
7.Reproducibility: Y
1)Frequency Rate : 100%
8.Comparison Results : 
1)Model Comparing : 
- Build ID : 20130421070203
- Gaia : 5cbb19e4bb78a7ad879fbe4b9a841e1c35714f5c
- Gecko : 950b402b6188bb2f3ce3176e620ed5249719d720
Whiteboard: [TD-26566]
blocking-b2g: --- → leo?
Sometime after refresh, next play request comes before first one is cleaned up.
So H/W codec returns error...

E       147      omx_vdec     Video decoder instance already exists.

That's why next try fails.
Target Milestone: --- → 1.1 QE2
1) Go to some site which contains video downloadable content

Means any web site which has link like "test.com/test.mp4"
Try this web site.
And touch refresh at to top of browser while playing.

http://download.wavetlan.com/SVV/Media/HTTP/http-mp4.htm
I can reproduce this with the file provided, but I can't reproduce it with an Ogg Video file (e.g. http://archive.org/download/ElephantsDream/ed_1024.ogv)

Could this be a problem with the H.264 decoder or the code in Gecko which interfaces with this?
Component: Gaia::Browser → Video/Audio
Product: Boot2Gecko → Core
This is probably caused by the hardware decoder not being destroyed before the refreshed content is attempted to play, resulting in it not being able to play it. So same root cause as the "only one hardware decoder instance on qualcomm devices" bug.
(In reply to Ben Francis [:benfrancis] from comment #4)
> I can reproduce this with the file provided, but I can't reproduce it with
> an Ogg Video file (e.g.
> http://archive.org/download/ElephantsDream/ed_1024.ogv)
> 
> Could this be a problem with the H.264 decoder or the code in Gecko which
> interfaces with this?

Yes, that's what comment 1 is implying.
Sotaro: do you think this will be fixed by (or is a dupe of) bug 831747?
Flags: needinfo?(sotaro.ikeda.g)
djf, it might needs Bug 831747 and Bug 871485.
Flags: needinfo?(sotaro.ikeda.g)
In bug 831747, nsHTMLMediaElement::NotifyOwnerDocumentActivityChanged() is called. I do not know similar event function is called in this use case.
triage: leo-, tracking-b2g18+. seem more of a QA test case than end user use case. it will happen but less likely for end users
blocking-b2g: leo? → -
tracking-b2g18: --- → +
blocking-b2g: - → leo?
Priority: -- → P1
Whiteboard: [TD-26566] → [TD-26566] c=video
leo - please do not re-nominate without justification. what's your justification?
Flags: needinfo?(leo.bugzilla.gecko)
(In reply to Joe Cheng [:jcheng] from comment #10)
> triage: leo-, tracking-b2g18+. seem more of a QA test case than end user use
> case. it will happen but less likely for end users

Does it mean that user didn't refresh webpage, normally?
Flags: needinfo?(leo.bugzilla.gecko)
Triage - partner decides to block on this as while under 3g it is possible that user does refresh while watching videos on web sites.
blocking-b2g: leo? → leo+
Chris - can you take a look? Make sure to keep the target milestone in mind.
Assignee: nobody → chris.double
(In reply to Ben Francis [:benfrancis] from comment #4)
> I can reproduce this with the file provided, but I can't reproduce it with
> an Ogg Video file (e.g.
> http://archive.org/download/ElephantsDream/ed_1024.ogv)
> 
> Could this be a problem with the H.264 decoder or the code in Gecko which
> interfaces with this?

For, Ogg Video hw codec is not used. It seems different problem.
(In reply to Alex Keybl [:akeybl] from comment #14)
> Chris - can you take a look? Make sure to keep the target milestone in mind.

Looks like a dup of the "only one HW instance allowed" bug.
I confirmed that patches in Bug 871485 fixed this problem on v1.1 buri.
Whiteboard: [TD-26566] c=video → [TD-26566] c=video, MiniWW
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 871485
Duplicate of this bug: 885032
This issue does not repro anymore. Refreshing the web page when the video is playing, page refreshes and video starts to play again. But, the video is cut off the screen. 

Verified on 
Leo Build ID: 20130625070217
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
Gaia: 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Platform Version: 18.1
RIL Version: 01.01.00.019.138
You need to log in before you can comment on or make changes to this bug.