Closed Bug 871472 Opened 7 years ago Closed 7 years ago

[Camera] unlocking the wakelock without proper testing creates problem in closing camera app.

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P3)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:leo+, b2g18 fixed)

RESOLVED FIXED
1.1 QE2 (6jun)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: leo.bugzilla.gaia)

References

()

Details

(Keywords: crash, regression, Whiteboard: [TD-25523])

Attachments

(2 files)

355 bytes, text/html
daleharvey
: review+
Details
355 bytes, text/html
daleharvey
: review+
Details
1. Title : unlocking the wakelock without proper testing creates problem in closing camera app.
2. Precondition : camera should be working fine
3. Tester's Action : (1) launch camera from lock screen
                     (2) minimize and reopen it again.

4. Detailed Symptom (ENG.) : Wakelock created for camera preview is not properly unlocked. So, because of this if camera app is relaunched for second time from lockscreen, camera preview will not be shown because the earlier instance of camera app is not released.
5. Expected : Wakelock created for camera preview should be unlocked only when filmstrip images/videos are previewed.
6.Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 3c48f7af4ecc8d32f62a44f0a30d4f18895bc33e
9.Personal email id: gjyothiprasad@gmail.com
blocking-b2g: --- → leo?
Keywords: crash, regression
Whiteboard: [TD-25523]
Hi Dale,

This is a regression for bugzilla ID: 835193, a condition was missed in 835193.
Wakelock which is created for camera preview should be unlocked only when filmstrip items preview.

This is now fixed. Please review the patch.
Attachment #748739 - Flags: review?(dale)
blocking-b2g: leo? → leo+
Comment on attachment 748739 [details]
Pointer to pull request

There is a nit in github to be addressed and similiarly to the last patch there is an unnecessary mode change in this commit that should be taken out, once those are fixed this is good to go.
Attachment #748739 - Flags: review?(dale) → review+
Target Milestone: --- → 1.1 QE2
Priority: -- → P3
Hi Dale,

I have done the changes as per your suggestions. Also, taken care for mode changes.
Please check the patch
Assignee: nobody → leo.bugzilla.gaia
Attachment #749209 - Flags: review?(dale)
Comment on attachment 749209 [details]
Pointer to pull request

Looks good, thanks
Attachment #749209 - Flags: review?(dale) → review+
Sorry, forgot to mark resolved
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Uplifted c70775cb8ed6e46fe4afb512f2c27c7d39bbf6be to:
v1-train: 945e65f04d163001c39f7ecfc37368272fc6d22e
Duplicate of this bug: 870326
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
QA Contact: croesch
You need to log in before you can comment on or make changes to this bug.