Use recent xulrunner in build system that are 3x smaller.

RESOLVED DUPLICATE of bug 852321

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 852321
5 years ago
4 years ago

People

(Reporter: ochameau, Assigned: ochameau)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Currently, to start hacking on gaia, you have to download xulrunner sdk.
For now, it is 380MB tarball that uncompress to xx MB,
But this impressive size was just a build bug on SDK side.
It has now been fixed and the tarball is only 60MB and uncompress to 200MB.

Ideally, we would just download an xpcshell build, but that doesn't exists and seems to be complicated to build solely.
(Assignee)

Comment 1

5 years ago
Created attachment 748815 [details]
Pull request 9723

I also cleaned the Makefile and build scripts from dead code and rewrote Makefile comment that are outdated.
Assignee: nobody → poirot.alex
(Assignee)

Updated

5 years ago
Attachment #748815 - Flags: review?(21)
Comment on attachment 748815 [details]
Pull request 9723

It should be safe since no databases are generated anymore but I'm always a bit scared with those changes. Let's try it.

(Thanks for the clean up).
Attachment #748815 - Flags: review?(21) → review+
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 852321
You need to log in before you can comment on or make changes to this bug.