[A/V] Camera application cannot show thumbnail after recording

RESOLVED DUPLICATE of bug 873971

Status

P1
major
RESOLVED DUPLICATE of bug 873971
6 years ago
6 years ago

People

(Reporter: leo.bugzilla.gecko, Assigned: djf)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: c=video , MiniWW)

(Reporter)

Description

6 years ago
Precondition : put many video files in SD card.

Push new SD card -> start video application -> (video application is retrieving thumbnail in background) -> start camera -> video recording 

While video application retrieves thumbnail from SD card, camera cannot show any recorded file at the top of screen. 
Sometime it can show thumbnail but it cannot be played.
(Reporter)

Updated

6 years ago
blocking-b2g: --- → leo?
(Reporter)

Updated

6 years ago
Target Milestone: --- → 1.1 QE2

Comment 1

6 years ago
> While video application retrieves thumbnail from SD card, camera cannot show
> any recorded file at the top of screen. 
I don't understand the symptom. Do you mean while video app is retrieving thumbnail, you switch to camera app and then check the filmstrip? Note filmstrip in camera app shows only photos/videos just taken/recorded, not all the videos in SD card.

> Sometime it can show thumbnail but it cannot be played.
Do you mean filmstrip shows recorded video thumbnails that cannot play?

It will be helpful if you provide detailed STR or some symptom video/screenshots.
(Reporter)

Comment 2

6 years ago
(In reply to Ben Tian [:btian] from comment #1)
> > While video application retrieves thumbnail from SD card, camera cannot show
> > any recorded file at the top of screen. 
> I don't understand the symptom. Do you mean while video app is retrieving
> thumbnail, you switch to camera app and then check the filmstrip? Note
> filmstrip in camera app shows only photos/videos just taken/recorded, not
> all the videos in SD card.
Yes, Right.
Push new SD card -> start video application -> (video application is retrieving thumbnail in background) -> start camera -> video recording 
After new video recording, recorded video is not shown on flimstrip.

> 
> > Sometime it can show thumbnail but it cannot be played.
> Do you mean filmstrip shows recorded video thumbnails that cannot play?
Yes. almost every new record video is not shown on flimstrip as I told above.
But sometimes thumbnail is shown from new recorded video.
Then, it cannot be played.

> It will be helpful if you provide detailed STR or some symptom
> video/screenshots.

Comment 3

6 years ago
> Push new SD card -> start video application -> (video application is
> retrieving thumbnail in background) -> start camera -> video recording 
> After new video recording, recorded video is not shown on flimstrip.
Do you have log files? How many video files do you put in the SD card to test?

> Yes. almost every new record video is not shown on flimstrip as I told above.
> But sometimes thumbnail is shown from new recorded video.
> Then, it cannot be played.
Please state 'cannot be played' more specifically: does black screen show when you play it? does the thumbnail enlarge after you click on it?

It sounds like video decoder is busy serving video app and camera app cannot use it to decode for thumbnail and playback.
(Reporter)

Updated

6 years ago
Priority: -- → P1
(Reporter)

Comment 4

6 years ago
(In reply to Ben Tian [:btian] from comment #3)

> It sounds like video decoder is busy serving video app and camera app cannot
> use it to decode for thumbnail and playback.
Yes, right. Both cases thumbnail failure and playback failure, camera cannot use H/W codec for decoding.
If you need full log file, I'll prepare it
(Assignee)

Comment 5

6 years ago
This should have been fixed by bug 856542. Please make sure you have that patch applied to your build.
Flags: needinfo?(leo.bugzilla.gecko)
(Reporter)

Comment 6

6 years ago
(In reply to David Flanagan [:djf] from comment #5)
> This should have been fixed by bug 856542. Please make sure you have that
> patch applied to your build.

I think this is different issue from bug 856542.
Bug 856542 focuses on video application itself. (Thumbnail and play)

However, this bug occur between video application and camera application.

This could be similar as Bug 871485.
Flags: needinfo?(leo.bugzilla.gecko)

Updated

6 years ago
Whiteboard: c=video
(Assignee)

Comment 7

6 years ago
(In reply to leo.bugzilla.gecko from comment #6)
> (In reply to David Flanagan [:djf] from comment #5)
> > This should have been fixed by bug 856542. Please make sure you have that
> > patch applied to your build.
> 
> I think this is different issue from bug 856542.
> Bug 856542 focuses on video application itself. (Thumbnail and play)
> 
> However, this bug occur between video application and camera application.
> 
> This could be similar as Bug 871485.
Assignee: nobody → dflanagan

Comment 8

6 years ago
(In reply to leo.bugzilla.gecko from comment #2)
> (In reply to Ben Tian [:btian] from comment #1)
> > > While video application retrieves thumbnail from SD card, camera cannot show
> > > any recorded file at the top of screen. 
> > I don't understand the symptom. Do you mean while video app is retrieving
> > thumbnail, you switch to camera app and then check the filmstrip? Note
> > filmstrip in camera app shows only photos/videos just taken/recorded, not
> > all the videos in SD card.
> Yes, Right.
> Push new SD card -> start video application -> (video application is
> retrieving thumbnail in background) -> start camera -> video recording 
> After new video recording, recorded video is not shown on flimstrip.

The impacted population will be so small that we would not block on this issue. The number of users that realize they've run into a bug will be even smaller.
blocking-b2g: leo? → -
(Reporter)

Comment 9

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #8)
> The impacted population will be so small that we would not block on this
> issue. The number of users that realize they've run into a bug will be even
> smaller.

There are two problems, here.
[1] Push new SD card -> start video application -> (video application is
 retrieving thumbnail in background) -> start camera -> video recording 
 After new video recording, recorded video is not shown on flimstrip.

[2] Sometimes thumbnail is shown (This is lucky case because cam's thumbnail request is done between video's thumbnail requests ). However, it cannot be play.
(Assignee)

Comment 10

6 years ago
I really think that this bug was fixed by the patch in bug 856542.  

See https://bugzilla.mozilla.org/show_bug.cgi?id=871482#c31  That bug was filed against a build that did not have the patch from bug 856542, and I think this bug is the same.

Please try to reproduce this again with a current build.
Flags: needinfo?(leo.bugzilla.gecko)

Updated

6 years ago
Whiteboard: c=video → c=video , MiniWW

Comment 11

6 years ago
As discussed in San Diego work week marking this as leo+.
blocking-b2g: - → leo+
(Assignee)

Comment 12

6 years ago
It turns out that this isn't related to video hardware contention at all, and was caused by the device storage changes. It is already fixed on master in bug 873971.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873971
(Reporter)

Comment 13

6 years ago
I cannot be reproduced because video application stop thumbnail retrieving when it goes back.
Flags: needinfo?(leo.bugzilla.gecko)
You need to log in before you can comment on or make changes to this bug.