Image do not appear after navigation-back and/or switch back tab

VERIFIED FIXED in Firefox 23

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: alice0775, Assigned: mattwoodrow)

Tracking

({regression, reproducible})

23 Branch
mozilla24
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox22 unaffected, firefox23+ verified, firefox24+ verified)

Details

Attachments

(1 attachment)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/7130e5134a6e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130513 Firefox/23.0 ID:20130513031057

When I test Bug 871729, a problem found.

Steps To Reproduce:
0. Extract attachment 748979 [details] of Bug 871729
1. Open ffTest.html
2. Open FemaleSkeleton_225.jpg in the same tab
3. Navigate Back (Press BS / Click Back button etc) (mouse pointer should be positioned outside of the image region)
4. Wait for few seconds
   --- observe image
5. Scroll Up/Down by dragging thumb/mouse wheel (mouse pointer should be positioned outside of the image region)
   --- observe image


Actual Results:
Image do not appear forever.
Image is repaints partially when page scroll.
Image appears when mouse pointer hover over image region.
Image appears when window focus change.
Expected results:
Image should appear after navigation back immediately

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/690b5e0f6562
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130424 Firefox/23.0 ID:20130424184951
Bad:
http://hg.mozilla.org/mozilla-central/rev/7f68735fc8da
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130425 Firefox/23.0 ID:20130425183955
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=690b5e0f6562&tochange=7f68735fc8da


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/78bdcb813be1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130425 Firefox/23.0 ID:20130425010450
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/96c350f2c64a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130424 Firefox/23.0 ID:20130425021949
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=78bdcb813be1&tochange=96c350f2c64a

Regressed by:
96c350f2c64a	Jonathan Watt — Bug 864832 - Get rid of the majority of the remaining nsSVGUtils::InvalidateBounds calls, except for those related to transforms and nsSVGTextFrame2. r=mattwoodrow
Alternate STR:
1. Open ffTest.html in tab[Tab A]
2. Open a new tab in the front tab[Tab B]
3. Wait for 10-15 seconds
4. Switch to tab[Tab A]

Actual Results:
Image do not appear forever.

Expected results:
Image should appear after switch tab immediately
Summary: Image do not appear after navigation-back → Image do not appear after navigation-back and/or switch back tab
I saw this as well but wasn't sure if it was related. Great find and thanks for opening this issue up Alice!
As noted in Bug 871729, this one is very crucial for us, especially since it results in images disappearing. Any status update on this one? Thanks!
jwatt is on vacation. This seems like a regression we should fix.
Assignee: jwatt → matt.woodrow
Bug 864832 removed calls to SVGUtils::InvalidateBounds in these locations (that function no longer exists), which wasn't correct.

We still need to mark the frame is invalid for DLBI to pick up on it.

Thanks for the regression range and STR Alice!
Attachment #759612 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/b6e14855f129
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Quick question on this one. When testing this out locally, I see the image still missing but it reappears within about 300-500ms which seems a little odd to me. Is this expected or should it never disappear?
Also FYI, tested this in branch 19 and I'm not seeing any delay in the image reappearing when swapping back to the other tab - it's always there.
Comment on attachment 759612 [details] [diff] [review]
Invalidate the svg frame when we get an imagelib notification

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 864832
User impact if declined: Images missing at some tmes
Testing completed (on m-c, etc.): Been on m-c for over a week.
Risk to taking this patch (and alternatives if risky): Very low risk, just makes sure we repaint SVG images.
String or IDL/UUID changes made by this patch: None
Attachment #759612 - Flags: approval-mozilla-aurora?
Attachment #759612 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Should I open up a new ticket for the images not reappearing immediately after tab switching? (200-300ms lag it seems)
Done, Bug 887792 opened.
Reproduced the issue on Nightly 2013-05-17 Win 7 x64.
Verified fixed FF 23b6, 24.0a2 (2013-07-15) considering the remaining work from bug 887792.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.