Closed Bug 872171 Opened 11 years ago Closed 10 years ago

[Dialer] UI doesn't draw properly if system resources are taxed while a call is incoming

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:-)

RESOLVED WORKSFORME
blocking-b2g -

People

(Reporter: marcia, Unassigned)

Details

(Whiteboard: [mozilla-triage])

Attachments

(1 file)

Ikura, while running 1.0.1 latest Commercial RIL build:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/08196b630a4a
Gaia   57188a05fe5b669fc98bfcc18a49c9b3effdac06
BuildID 20130514070202
Version 18.0

STR:
1. Music app playing without headphones in
2. While Aggressively pinching and zooming Here Maps, dial the phone
3. Receive the attached screenshot

I can reproduce this all the time - I can tap on the bar at the top and see the full dialer UI, but I would expect on an incoming call to be able to see the full dialer UI (answer button and hangup button).

I can reproduce this by just doing Step #2 without music as well.
See also bug 873094, which may or may not be related.
blocking-b2g: --- → leo?
Or should this be tef?  An incoming call being delayed (bug 847592) seems about as bad as this bug.
Interestingly enough, during testing last evening while I was doing nothing with the Ikura device, I hit this scenario as well. But I don't recall how many apps or system resources were consumed at that time, I wasn't doing any pinching or zooming and I didn't have music playing and it still occurred.
(In reply to Justin Lebar [:jlebar] from comment #2)
> Or should this be tef?  An incoming call being delayed (bug 847592) seems
> about as bad as this bug.

This problem/solution is too undefined for v1.0.1. Will leave this to partners to decide on whether this should block 1.1 for them.
Whiteboard: [mozilla-triage]
Is it reproducible in recent version?
Please check and comment again.
Is it reproducible in recent version?
To make a decision, Please check and comment again.
Flags: needinfo?(mozillamarcia.knous)
I will try in a more recent build on Ikura and report back.
Flags: needinfo?(mozillamarcia.knous)
What's the feedback Marcia ?
Flags: needinfo?(mozillamarcia.knous)
Right now I am blocked by Bug 876772 - I cannot receive any incoming calls on the most recent Inari/Ikura builds.
Flags: needinfo?(mozillamarcia.knous)
Marcia, please renominate if you're able to repro.
blocking-b2g: leo? → -
Flags: needinfo?(mozillamarcia.knous)
Haven't been able to replicate this bug. Closing this out as WFM since it is also very dated at this point.
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: